pg_upgrade doesn't work?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pg_upgrade doesn't work?

Cogan, Mark  Contractor, NRL Code 3030
So why does the documentation tell me that I should use the pg_upgrade
command to migrate my 8.4.20 db to 9.6, but when I run the command it tells
me that the major version is different so it won't run?  Is there some kind
of issue with the location of the execution binary?  

Mark Cogan
Systems Administrator - Contractor, Code 3030
Information Delivery Systems, Inc
Onsite - Naval Research Lab
(202) 404-2032


smime.p7s (13K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: pg_upgrade doesn't work?

Stephen Frost
Greetings,

* Cogan, Mark  Contractor, NRL Code 3030 ([hidden email]) wrote:
> So why does the documentation tell me that I should use the pg_upgrade
> command to migrate my 8.4.20 db to 9.6, but when I run the command it tells
> me that the major version is different so it won't run?  Is there some kind
> of issue with the location of the execution binary?  

Having the exact error messgaes would be really helpful.  You're sure
that you are using the pg_upgrade from 9.6?  Note that to perform a
pg_upgrade you have to have the binaries for *both* versions installed
on to the system and then pg_upgrade will perform a copy of the data
files or will create hard-links between the old and new data
directories.

Thanks!

Stephen

signature.asc (836 bytes) Download Attachment
Previous Thread Next Thread