BUG #15798: /usr/pgsql-11/lib/libpq.so.5: no version information available

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

BUG #15798: /usr/pgsql-11/lib/libpq.so.5: no version information available

PG Doc comments form
The following bug has been logged on the website:

Bug reference:      15798
Logged by:          James Szinger
Email address:      [hidden email]
PostgreSQL version: 11.3
Operating system:   Fedora 30
Description:        

I'm running /usr/bin/needle from the EMBOSS suite on Fedora 30.  EMBOSS is
linked against libpq, but the needle program doesn't need it. Whenever I run
it I get the message:

$ needle </dev/null
needle: /usr/pgsql-11/lib/libpq.so.5: no version information available
(required by /lib64/libajax.so.6)
Needleman-Wunsch global alignment of two sequences
Input sequence: Error: Unable to get reply from user - end of standard
input

I didn't get the message under Fedora 29.  I also don't get the message if I
set LD_LIBRARY_PATH to force the system libpq

$ LD_LIBRARY_PATH=/usr/lib64 needle < /dev/null
Needleman-Wunsch global alignment of two sequences
Input sequence: Error: Unable to get reply from user - end of standard
input

RPMS involved:

postgresql11-libs-11.3-1PGDG.f30.x86_64
EMBOSS-libs-6.6.0-13.fc30.x86_64
EMBOSS-6.6.0-13.fc30.x86_64
libpq-11.2-2.fc30.x86_64