BUG #15955: changes in pg_dump from 11.4 to 11.5

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

BUG #15955: changes in pg_dump from 11.4 to 11.5

PG Bug reporting form
The following bug has been logged on the website:

Bug reference:      15955
Logged by:          sly
Email address:      [hidden email]
PostgreSQL version: 11.5
Operating system:   Linux
Description:        

currently in the process of migrating a 8.1.23 to 11.x ( I know its
unsupported, long story)
these changes
(https://fossies.org/diffs/postgresql/11.4_vs_11.5/src/bin/pg_dump/pg_dump.c-diff.html)

now make it impossible to dump the old database from the new server.

ERROR:

pg_dump: reading dependency data
pg_dump: [archiver (db)] query failed: ERROR:  relation "pg_opfamily" does
not exist
pg_dump: [archiver (db)] query was: SELECT classid, objid, refclassid,
refobjid, deptype FROM pg_depend WHERE deptype != 'p' AND deptype != 'e'
UNION ALL
SELECT 'pg_opfamily'::regclass AS classid, amopfamily AS objid, refclassid,
refobjid, deptype FROM pg_depend d, pg_amop o WHERE deptype NOT IN ('p',
'e', 'i') AND classid = 'pg_amop'::regclass AND objid = o.oid AND NOT
(refclassid = 'pg_opfamily'::regclass AND amopfamily = refobjid)
UNION ALL
SELECT 'pg_opfamily'::regclass AS classid, amprocfamily AS objid,
refclassid, refobjid, deptype FROM pg_depend d, pg_amproc p WHERE deptype
NOT IN ('p', 'e', 'i') AND classid = 'pg_amproc'::regclass AND objid = p.oid
AND NOT (refclassid = 'pg_opfamily'::regclass AND amprocfamily = refobjid)
ORDER BY 1,2

Reply | Threaded
Open this post in threaded view
|

Re: BUG #15955: changes in pg_dump from 11.4 to 11.5

Tom Lane-2
PG Bug reporting form <[hidden email]> writes:
> currently in the process of migrating a 8.1.23 to 11.x ( I know its
> unsupported, long story)
> these changes
> (https://fossies.org/diffs/postgresql/11.4_vs_11.5/src/bin/pg_dump/pg_dump.c-diff.html)
> now make it impossible to dump the old database from the new server.

Hmm, yeah, somebody (probably me) was sloppy there.  Will look into it,
thanks for the report!

                        regards, tom lane