BUG #16142: host down

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

BUG #16142: host down

PG Doc comments form
The following bug has been logged on the website:

Bug reference:      16142
Logged by:          Michael Lotter
Email address:      [hidden email]
PostgreSQL version: 12.0
Operating system:   Kali Linux
Description:        

I try to initiate PostgreSQL
when I do this, it shows it is all good until the end and says host is
down.
How is that fixed?
it shows
version: cluster: port: status: etc.

Port is correct status shows down.

When I go to initialise PostgreSQL, it goes no further.

Ver Cluster Port Status Owner    Data directory              Log file
12  main    5432 down   postgres /var/lib/postgresql/12/main
/var/log/postgresql/postgresql-12-main.log
update-alternatives: using /usr/share/postgresql/12/man/man1/postmaster.1.gz
to provide /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz) in auto
mode
invoke-rc.d: could not determine current runlevel
Setting up postgresql (12+210) ...
Processing triggers for systemd (243-8) ...
Processing triggers for libc-bin (2.29-3) …

thanks

Reply | Threaded
Open this post in threaded view
|

Re: BUG #16142: host down

Tomas Vondra-4
On Fri, Nov 29, 2019 at 07:18:05PM +0000, PG Bug reporting form wrote:

>The following bug has been logged on the website:
>
>Bug reference:      16142
>Logged by:          Michael Lotter
>Email address:      [hidden email]
>PostgreSQL version: 12.0
>Operating system:   Kali Linux
>Description:
>
>I try to initiate PostgreSQL
>when I do this, it shows it is all good until the end and says host is
>down.
>How is that fixed?
>it shows
>version: cluster: port: status: etc.
>
>Port is correct status shows down.
>
>When I go to initialise PostgreSQL, it goes no further.
>
>Ver Cluster Port Status Owner    Data directory              Log file
>12  main    5432 down   postgres /var/lib/postgresql/12/main
>/var/log/postgresql/postgresql-12-main.log
>update-alternatives: using /usr/share/postgresql/12/man/man1/postmaster.1.gz
>to provide /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz) in auto
>mode
>invoke-rc.d: could not determine current runlevel

Not sure which packages you're using, but my guess is this suggests a
packaging issue.

regards

--
Tomas Vondra                  http://www.2ndQuadrant.com
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services