BUG #16716: postgresql11-devel pckage from Refreshing service 'spacewalk' complains about missing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

BUG #16716: postgresql11-devel pckage from Refreshing service 'spacewalk' complains about missing

apt.postgresql.org Repository Update
The following bug has been logged on the website:

Bug reference:      16716
Logged by:          heiko kaempf
Email address:      [hidden email]
PostgreSQL version: 11.10
Operating system:   SUSE Linux Enterpirse Server 12 SP5
Description:        

Dear PostgreSQL developer team,

we have just incuded the follwing repository of postgresql 11.10-1 for SLES
12 SP5 in our environment:
https://download.postgresql.org/pub/repos/zypp/11/suse/sles-12.5-x86_64/
When installing the development package there is a dependency to a missing
libclang6 library
that doesn't seem to be a part of SLES 12 in general, it seems.
Please find below detailed version of our Linux version and the error
messages:

cat /etc/os-release
NAME="SLES"
VERSION="12-SP5"
VERSION_ID="12.5"
PRETTY_NAME="SUSE Linux Enterprise Server 12 SP5"
ID="sles"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sles:12:sp5"

zypper in postgresql11-devel
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libclang6 needed by
clang6-6.0.1-43.25.sles12.x86_64
 Solution 1: do not install postgresql11-devel-11.10-1PGDG.sles12.x86_64
 Solution 2: break clang6-6.0.1-43.25.sles12.x86_64 by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/c] (c): c
......
.....
.
As far as we know, the libclang6 library has not been released in SLES 12,
it seems.
There are some of packages for open SUSE avalable but not a supported
version for openSUSE 12
https://software.opensuse.org/search?utf8=%E2%9C%93&baseproject=ALL&q=libclang6

Any idea on how to proceed?
Is it possible to just implement the missing library from one of the
openSUSE packages
or to install one of those package versions to SLES 12 SP5 to procced the
installation.
Will there be a postgresql 11 version bind to libclang7 which is available
in SLES12?

Many thanks
Kind regard
Heiko Kaempf

Reply | Threaded
Open this post in threaded view
|

Re: BUG #16716: postgresql11-devel pckage from Refreshing service 'spacewalk' complains about missing

Devrim GÜNDÜZ

Hi,

On Fri, 2020-11-13 at 16:11 +0000, PG Bug reporting form wrote:

<snip>

> we have just incuded the follwing repository of postgresql 11.10-1
> for SLES
> 12 SP5 in our environment:
> https://download.postgresql.org/pub/repos/zypp/11/suse/sles-12.5-x86_64/
> When installing the development package there is a dependency to a
> missing
> libclang6 library
> that doesn't seem to be a part of SLES 12 in general, it seems.
> Please find below detailed version of our Linux version and the error
> messages:
<snip>

> Problem: nothing provides libclang6 needed by
> clang6-6.0.1-43.25.sles12.x86_64
>  Solution 1: do not install postgresql11-devel-11.10-
> 1PGDG.sles12.x86_64
>  Solution 2: break clang6-6.0.1-43.25.sles12.x86_64 by ignoring some
> of its
> dependencies


Sorry for the inconvenience. Looks like I did not push those package to
our repo. Just started pushing them. They will sync in an hour.

> Will there be a postgresql 11 version bind to libclang7 which is
> available in SLES12?

Not soon, until I can enable the repo that has libclang7-devel package.

-HTH

Regards,

--
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

signature.asc (849 bytes) Download Attachment