BUG #16858: clang10-devel packages are missing in SLES15 SP2 in general

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

BUG #16858: clang10-devel packages are missing in SLES15 SP2 in general

PG Bug reporting form
The following bug has been logged on the website:

Bug reference:      16858
Logged by:          Heiko Kaempf
Email address:      [hidden email]
PostgreSQL version: 12.0
Operating system:   SUSE Linux Enterprise Server 15 SP2
Description:        

Dear PostgreSQL developer team,

we have just incuded repositories of PostgreSQL 11, 12 and 13 for
SLES15 SP2 to our SUSE Manager environment from the following download
links:
https://download.postgresql.org/pub/repos/zypp/11/suse/sles-15.2-x86_64/
https://download.postgresql.org/pub/repos/zypp/12/suse/sles-15.2-x86_64/
https://download.postgresql.org/pub/repos/zypp/13/suse/sles-15.2-x86_64/

When trying to install the development package for PostgreSQL version 11 or
12
there is a dependency to clang10-devel package that doesn't seem to be a
part of SLES15 SP2.
As far as we know, clang9 and clang9-devel versions are included from SUSE
for SLES15 SP2.
But installing of PostgreSQL version 13 is possbile, so maybe this version
is bound to clang9?

Please find below detailed version of our Linux version and the error
messages:
# cat /etc/os-release
NAME="SLES"
VERSION="15-SP2"
VERSION_ID="15.2"
PRETTY_NAME="SUSE Linux Enterprise Server 15 SP2"
ID="sles"
ID_LIKE="suse"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sles:15:sp2"

# zypper in postgresql11-devel
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides clang10-devel needed by
postgresql11-devel-11.10-1PGDG.sles15.x86_64
 Solution 1: do not install postgresql11-devel-11.10-1PGDG.sles15.x86_64
 Solution 2: break postgresql11-devel-11.10-1PGDG.sles15.x86_64 by ignoring
some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 1
Resolving dependencies...
Resolving package dependencies...
Nothing to do.

# zypper in postgresql12-devel
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides clang10-devel needed by
postgresql12-devel-12.5-1PGDG.sles15.x86_64
 Solution 1: do not install postgresql12-devel-12.5-1PGDG.sles15.x86_64
 Solution 2: break postgresql12-devel-12.5-1PGDG.sles15.x86_64 by ignoring
some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 1
Resolving dependencies...
Resolving package dependencies...
Nothing to do.

# zypper in postgresql13-devel
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  postgresql13-devel

The following package has no support information from its vendor:
  postgresql13-devel

1 new package to install.
Overall download size: 2.6 MiB. Already cached: 0 B. After the operation,
additional 11.2 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): y
Retrieving package postgresql13-devel-13.1-1PGDG.sles15.x86_64              
                                          (1/1),   2.6 MiB ( 11.2 MiB
unpacked)
Retrieving: postgresql13-devel-13.1-1PGDG.sles15.x86_64.rpm
..........................................................................................[done]
postgresql13-devel-13.1-1PGDG.sles15.x86_64.rpm:
    Header V4 DSA/SHA1 Signature, key ID 442df0f8: NOKEY
    V4 DSA/SHA1 Signature, key ID 442df0f8: NOKEY

Looking for gpg key ID 442DF0F8 in cache /var/cache/zypp/pubkeys.
Repository DEV - GKDZEN - PostgreSQL13 for SLES15-SP2-packages-x86_64 does
not define additional 'gpgkey=' URLs.
postgresql13-devel-13.1-1PGDG.sles15.x86_64 (DEV - GKDZEN - PostgreSQL13 for
SLES15-SP2-packages-x86_64): Signature verification failed [4-Signatures
public key is not available]
Abort, retry, ignore? [a/r/i] (a): i

Checking for file conflicts:
.........................................................................................................................[done]
(1/1) Installing: postgresql13-devel-13.1-1PGDG.sles15.x86_64
........................................................................................[done]
Additional rpm output:
warning:
/var/cache/zypp/packages/spacewalk:dev-gkdzen-postgresql13-for-sle15-sp2-packages-x86_64/getPackage/1/c4c3770da7836f3723d800beecd5a4ce8e5ded539da53c9a6c149542d952359f/postgresql13-devel-13.1-1PGDG.sles15.x86_64.rpm:
Header V4 DSA/SHA1 Signature, key ID 442df0f8: NOKEY

Many thanks
Kind regard
Heiko Kaempf

Reply | Threaded
Open this post in threaded view
|

Re: BUG #16858: clang10-devel packages are missing in SLES15 SP2 in general

Devrim GÜNDÜZ

Hi,

On Tue, 2021-02-09 at 10:21 +0000, PG Bug reporting form wrote:
we have just incuded repositories of PostgreSQL 11, 12 and 13 for
SLES15 SP2 to our SUSE Manager environment from the following
download links:
https://download.postgresql.org/pub/repos/zypp/11/suse/sles-15.2-x86_64/
https://download.postgresql.org/pub/repos/zypp/12/suse/sles-15.2-x86_64/
https://download.postgresql.org/pub/repos/zypp/13/suse/sles-15.2-x86_64/

When trying to install the development package for PostgreSQL version
11 or 12 there is a dependency to clang10-devel package that doesn't
seem to be a part of SLES15 SP2.
As far as we know, clang9 and clang9-devel versions are included from
SUSE for SLES15 SP2.
But installing of PostgreSQL version 13 is possbile, so maybe this
version is bound to clang9?

I'm using the following repo repo for LLVM and CLANG:

zypper addrepo https://download.opensuse.org/repositories/home:aaronpuchert:Backports:SLE-15/openSUSE_Backports_SLE-15-SP1/home:aaronpuchert:Backports:SLE-15.repo

but looks like they also removed clang 10, and added 11. Let me see
what I can do. I think downgrading to 9 is not an option for now. Looks
like I will need to upgrade to clang 11, and rebuilt the packages with
that .

FWIW, I (try to) document the external SLES 15 repos that I use for
building and installing PostgreSQL and related RPMs on this platform:

https://redmine.postgresql.org/projects/pgrpms/wiki/

Regards,
...
--
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

AW: BUG #16858: clang10-devel packages are missing in SLES15 SP2 in general

Kämpf, Heiko (OWL-IT)
Hello Devrim,

we have just synchronized and updated our Repositories of PostgreSQL 11, 12 and 13 for SLES15 SP2 from PostgreSQL download sites.
But we still have the issue about missind clang10-devel when installing PostgreSQL development version 11 or 12.
Installatin of version 13 is working. Is there a Repository where we can get clang10-devel from?
Can you advice how to proceed with this problem, please


Many thanks
Kind regards
Heiko

Please find below the output of the installation from today:

lipgsqlgist2:~ # zypper in postgresql11-devel
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides clang10-devel needed by postgresql11-devel-11.11-1PGDG.sles15.x86_64
 Solution 1: do not install postgresql11-devel-11.11-1PGDG.sles15.x86_64
 Solution 2: break postgresql11-devel-11.11-1PGDG.sles15.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 1
Resolving dependencies...
Resolving package dependencies...
Nothing to do.


lipgsqlgist2:~ # zypper in postgresql12-devel
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides clang10-devel needed by postgresql12-devel-12.6-1PGDG.sles15.x86_64
 Solution 1: do not install postgresql12-devel-12.6-1PGDG.sles15.x86_64
 Solution 2: break postgresql12-devel-12.6-1PGDG.sles15.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 1
Resolving dependencies...
Resolving package dependencies...
Nothing to do.


lipgsqlgist2:~ # zypper in postgresql13-devel
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  postgresql13-devel

The following package has no support information from its vendor:
  postgresql13-devel

1 new package to install.
Overall download size: 2.6 MiB. Already cached: 0 B. After the operation, additional 11.2 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): y
Retrieving package postgresql13-devel-13.2-1PGDG.sles15.x86_64                                                         (1/1),   2.6 MiB ( 11.2 MiB unpacked)
Retrieving: postgresql13-devel-13.2-1PGDG.sles15.x86_64.rpm ..........................................................................................[done]
postgresql13-devel-13.2-1PGDG.sles15.x86_64.rpm:
    Package is not signed!

postgresql13-devel-13.2-1PGDG.sles15.x86_64 (DEV - GKDZEN - PostgreSQL13 for SLES15-SP2-packages-x86_64): Signature verification failed [6-File is unsigned]
Abort, retry, ignore? [a/r/i] (a): i

Checking for file conflicts: .........................................................................................................................[done]
(1/1) Installing: postgresql13-devel-13.2-1PGDG.sles15.x86_64 ........................................................................................[done]

.........
......
...
.

-----Ursprüngliche Nachricht-----
Von: Devrim Gündüz <[hidden email]>
Gesendet: Freitag, 12. Februar 2021 02:21
An: Kämpf, Heiko (OWL-IT) <[hidden email]>; [hidden email]
Betreff: Re: BUG #16858: clang10-devel packages are missing in SLES15 SP2 in general


Hi,

On Tue, 2021-02-09 at 10:21 +0000, PG Bug reporting form wrote:
we have just incuded repositories of PostgreSQL 11, 12 and 13 for
SLES15 SP2 to our SUSE Manager environment from the following download links:
https://download.postgresql.org/pub/repos/zypp/11/suse/sles-15.2-x86_64/
https://download.postgresql.org/pub/repos/zypp/12/suse/sles-15.2-x86_64/
https://download.postgresql.org/pub/repos/zypp/13/suse/sles-15.2-x86_64/

When trying to install the development package for PostgreSQL version
11 or 12 there is a dependency to clang10-devel package that doesn't seem to be a part of SLES15 SP2.
As far as we know, clang9 and clang9-devel versions are included from SUSE for SLES15 SP2.
But installing of PostgreSQL version 13 is possbile, so maybe this version is bound to clang9?

I'm using the following repo repo for LLVM and CLANG:

zypper addrepo https://download.opensuse.org/repositories/home:aaronpuchert:Backports:SLE-15/openSUSE_Backports_SLE-15-SP1/home:aaronpuchert:Backports:SLE-15.repo

but looks like they also removed clang 10, and added 11. Let me see what I can do. I think downgrading to 9 is not an option for now. Looks like I will need to upgrade to clang 11, and rebuilt the packages with that .

FWIW, I (try to) document the external SLES 15 repos that I use for building and installing PostgreSQL and related RPMs on this platform:

https://redmine.postgresql.org/projects/pgrpms/wiki/

Regards,
...
--
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR