Build failed in Jenkins: pgadmin4-master-python36 #856

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Build failed in Jenkins: pgadmin4-master-python36 #856

pgAdmin 4 Jenkins
See <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/856/display/redirect?page=changes>

Changes:

[Dave Page] Fix SQL generated for tables with inherited columns. Fixes #3505

[Dave Page] Make the browser more robust in the face of multibyte characters in

------------------------------------------
[...truncated 447 B...]
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
Fetching upstream changes from git://git.postgresql.org/git/pgadmin4.git
 > git --version # timeout=10
 > git fetch --tags --progress git://git.postgresql.org/git/pgadmin4.git +refs/heads/*:refs/remotes/origin/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision d641b47adbc3dfd3203e857e75dfeed5d478ac84 (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f d641b47adbc3dfd3203e857e75dfeed5d478ac84
Commit message: "Make the browser more robust in the face of multibyte characters in SQL_ASCII databases. Fixes #3877"
 > git rev-list --no-walk 8fb340d23b00646e8bd5cdcbab11442b03bfa701 # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content
PYTHON_VERSION=3.6

[EnvInject] - Variables injected successfully.
[pgadmin4-master-python36] $ /bin/sh -xe /tmp/jenkins9168760766804898171.sh
+ <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/ws/ci/ci_runner.sh>
EXECUTING: Create pgAdmin config

EXECUTING: Python tests

Creating Python 3.6 virtual environment...

Using base prefix '/usr/local/python-3.6'
New python executable in <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/ws/pgadmin-venv/bin/python3>
Also creating executable in <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/ws/pgadmin-venv/bin/python>
Installing setuptools, pip, wheel...done.
Running virtualenv with interpreter /usr/local/python-3.6/bin/python3
Ignoring importlib: markers 'python_version <= "2.7"' don't match your environment
Ignoring psycopg2: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-Script: markers 'python_version < "2.7"' don't match your environment
Ignoring ordereddict: markers 'python_version < "2.7"' don't match your environment
Ignoring python-dateutil: markers 'python_version < "2.7"' don't match your environment
Ignoring SQLAlchemy: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-Security: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-BabelEx: markers 'python_version < "2.7"' don't match your environment
Collecting blinker==1.4 (from -r requirements.txt (line 6))
Collecting extras==1.0.0 (from -r requirements.txt (line 7))
  Using cached https://files.pythonhosted.org/packages/03/e9/e915af1f97914cd0bc021e125fd1bfd4106de614a275e4b6866dd9a209ac/extras-1.0.0-py2.py3-none-any.whl
Collecting fixtures==3.0.0 (from -r requirements.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/a8/28/7eed6bf76792f418029a18d5b2ace87ce7562927cdd00f1cefe481cd148f/fixtures-3.0.0-py2.py3-none-any.whl
Collecting Flask==0.12.4 (from -r requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/2e/48/f1936dadac2326b3d73f2fe0a964a87d16be16eb9d7fc56f09c1bea3d17c/Flask-0.12.4-py2.py3-none-any.whl
Collecting Flask-Gravatar==0.5.0 (from -r requirements.txt (line 10))
  Using cached https://files.pythonhosted.org/packages/58/4a/b20260e8d383d0037f2791dd8a3f3ea729ca9f02d7638677a34a236a8702/Flask_Gravatar-0.5.0-py2.py3-none-any.whl
Collecting Flask-Login==0.3.2 (from -r requirements.txt (line 11))
Collecting Flask-Mail==0.9.1 (from -r requirements.txt (line 12))
Collecting Flask-Migrate==2.1.1 (from -r requirements.txt (line 13))
  Using cached https://files.pythonhosted.org/packages/c6/06/053630cb5fe3974c7d60c2d3f3907bae6ff86beb8720bd4fcf53c45c6702/Flask_Migrate-2.1.1-py2.py3-none-any.whl
Collecting Flask-Principal==0.4.0 (from -r requirements.txt (line 14))
Collecting Flask-SQLAlchemy==2.3.2 (from -r requirements.txt (line 15))
  Using cached https://files.pythonhosted.org/packages/a1/44/294fb7f6bf49cc7224417cd0637018db9fee0729b4fe166e43e2bbb1f1c8/Flask_SQLAlchemy-2.3.2-py2.py3-none-any.whl
Collecting Flask-WTF==0.14.2 (from -r requirements.txt (line 16))
  Using cached https://files.pythonhosted.org/packages/60/3a/58c629472d10539ae5167dc7c1fecfa95dd7d0b7864623931e3776438a24/Flask_WTF-0.14.2-py2.py3-none-any.whl
Collecting html5lib==1.0.1 (from -r requirements.txt (line 17))
  Using cached https://files.pythonhosted.org/packages/a5/62/bbd2be0e7943ec8504b517e62bab011b4946e1258842bc159e5dfde15b96/html5lib-1.0.1-py2.py3-none-any.whl
Collecting linecache2==1.0.0 (from -r requirements.txt (line 18))
  Using cached https://files.pythonhosted.org/packages/c7/a3/c5da2a44c85bfbb6eebcfc1dde24933f8704441b98fdde6528f4831757a6/linecache2-1.0.0-py2.py3-none-any.whl
Collecting passlib==1.7.1 (from -r requirements.txt (line 19))
  Using cached https://files.pythonhosted.org/packages/ee/a7/d6d238d927df355d4e4e000670342ca4705a72f0bf694027cf67d9bcf5af/passlib-1.7.1-py2.py3-none-any.whl
Collecting pbr==3.1.1 (from -r requirements.txt (line 20))
  Using cached https://files.pythonhosted.org/packages/0c/5d/b077dbf309993d52c1d71e6bf6fe443a8029ea215135ebbe0b1b10e7aefc/pbr-3.1.1-py2.py3-none-any.whl
Collecting pycrypto>=2.6.1 (from -r requirements.txt (line 21))
Collecting pyrsistent==0.14.2 (from -r requirements.txt (line 22))
Collecting python-mimeparse==1.6.0 (from -r requirements.txt (line 23))
  Using cached https://files.pythonhosted.org/packages/26/2e/03bce213a9bf02a2750dcb04e761785e9c763fc11071edc4b447eacbb842/python_mimeparse-1.6.0-py2.py3-none-any.whl
Collecting pytz==2018.3 (from -r requirements.txt (line 24))
  Using cached https://files.pythonhosted.org/packages/3c/80/32e98784a8647880dedf1f6bf8e2c91b195fe18fdecc6767dcf5104598d6/pytz-2018.3-py2.py3-none-any.whl
Collecting simplejson==3.13.2 (from -r requirements.txt (line 25))
Collecting six>=1.11.0 (from -r requirements.txt (line 26))
  Using cached https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
Collecting speaklater==1.3 (from -r requirements.txt (line 27))
Collecting sqlparse==0.2.4 (from -r requirements.txt (line 28))
  Using cached https://files.pythonhosted.org/packages/65/85/20bdd72f4537cf2c4d5d005368d502b2f464ede22982e724a82c86268eda/sqlparse-0.2.4-py2.py3-none-any.whl
Collecting WTForms==2.1 (from -r requirements.txt (line 29))
Collecting Flask-Paranoid==0.2.0 (from -r requirements.txt (line 30))
  Using cached https://files.pythonhosted.org/packages/0e/14/359033a218c5403872e11ff7267e6c638c0279067fa932d93653188f4052/Flask_Paranoid-0.2.0-py2.py3-none-any.whl
Collecting psutil==5.4.7 (from -r requirements.txt (line 31))
Collecting psycopg2>=2.7.4 (from -r requirements.txt (line 36))
  Using cached https://files.pythonhosted.org/packages/bc/2a/61a8f9719bd6df5b421abd91740cb0595fc3c17b28eaf89fe4f144472ca6/psycopg2-2.7.6.1-cp36-cp36m-manylinux1_x86_64.whl
Collecting python-dateutil>=2.7.1 (from -r requirements.txt (line 37))
  Using cached https://files.pythonhosted.org/packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
Collecting htmlmin==0.1.12 (from -r requirements.txt (line 38))
Collecting Flask-HTMLmin==1.3.2 (from -r requirements.txt (line 39))
Collecting SQLAlchemy>=1.2.5 (from -r requirements.txt (line 40))
  Using cached https://files.pythonhosted.org/packages/05/d2/17fb194f4ae83577258ea1d81da3d5d5643f4957fa14fd0261d78d648bf5/SQLAlchemy-1.2.16.tar.gz
Collecting Flask-Security>=3.0.0 (from -r requirements.txt (line 41))
  Using cached https://files.pythonhosted.org/packages/88/47/4908a5040120768ff4fb2465c7eeafeb9239c27d2919bd67c4ccc1b43e14/Flask_Security-3.0.0-py2.py3-none-any.whl
Collecting sshtunnel>=0.1.3 (from -r requirements.txt (line 42))
Collecting testtools>=0.9.22 (from fixtures==3.0.0->-r requirements.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/87/74/a4d55da28d7bba6d6f49430f22a62afd8472cb24a63fa61daef80d3e821b/testtools-2.3.0-py2.py3-none-any.whl
Collecting Jinja2>=2.4 (from Flask==0.12.4->-r requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/7f/ff/ae64bacdfc95f27a016a7bed8e8686763ba4d277a78ca76f32659220a731/Jinja2-2.10-py2.py3-none-any.whl
Collecting Werkzeug>=0.7 (from Flask==0.12.4->-r requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/20/c4/12e3e56473e52375aa29c4764e70d1b8f3efa6682bef8d0aae04fe335243/Werkzeug-0.14.1-py2.py3-none-any.whl
Collecting click>=2.0 (from Flask==0.12.4->-r requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/fa/37/45185cb5abbc30d7257104c434fe0b07e5a195a6847506c074527aa599ec/Click-7.0-py2.py3-none-any.whl
Collecting itsdangerous>=0.21 (from Flask==0.12.4->-r requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/76/ae/44b03b253d6fade317f32c24d100b3b35c2239807046a4c953c7b89fa49e/itsdangerous-1.1.0-py2.py3-none-any.whl
Collecting alembic>=0.6 (from Flask-Migrate==2.1.1->-r requirements.txt (line 13))
Collecting webencodings (from html5lib==1.0.1->-r requirements.txt (line 17))
  Using cached https://files.pythonhosted.org/packages/f4/24/2a3e3df732393fed8b3ebf2ec078f05546de641fe1b667ee316ec1dcf3b7/webencodings-0.5.1-py2.py3-none-any.whl
Collecting Flask-BabelEx>=0.9.3 (from Flask-Security>=3.0.0->-r requirements.txt (line 41))
Collecting paramiko>=1.15.2 (from sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/cf/ae/94e70d49044ccc234bfdba20114fa947d7ba6eb68a2e452d89b920e62227/paramiko-2.4.2-py2.py3-none-any.whl
Collecting unittest2>=1.0.0 (from testtools>=0.9.22->fixtures==3.0.0->-r requirements.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/72/20/7f0f433060a962200b7272b8c12ba90ef5b903e218174301d0abfd523813/unittest2-1.1.0-py2.py3-none-any.whl
Collecting traceback2 (from testtools>=0.9.22->fixtures==3.0.0->-r requirements.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/17/0a/6ac05a3723017a967193456a2efa0aa9ac4b51456891af1e2353bb9de21e/traceback2-1.4.0-py2.py3-none-any.whl
Collecting MarkupSafe>=0.23 (from Jinja2>=2.4->Flask==0.12.4->-r requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/08/04/f2191b50fb7f0712f03f064b71d8b4605190f2178ba02e975a87f7b89a0d/MarkupSafe-1.1.0-cp36-cp36m-manylinux1_x86_64.whl
Collecting Mako (from alembic>=0.6->Flask-Migrate==2.1.1->-r requirements.txt (line 13))
Collecting python-editor>=0.3 (from alembic>=0.6->Flask-Migrate==2.1.1->-r requirements.txt (line 13))
Collecting Babel>=1.0 (from Flask-BabelEx>=0.9.3->Flask-Security>=3.0.0->-r requirements.txt (line 41))
  Using cached https://files.pythonhosted.org/packages/b8/ad/c6f60602d3ee3d92fbed87675b6fb6a6f9a38c223343ababdb44ba201f10/Babel-2.6.0-py2.py3-none-any.whl
Collecting cryptography>=1.5 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/60/c7/99b33c53cf3f20a97a4c4bfd3ab66dcc93d99da0a97cc9597aa36ae6bb62/cryptography-2.4.2-cp34-abi3-manylinux1_x86_64.whl
Collecting pyasn1>=0.1.7 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/7b/7c/c9386b82a25115cccf1903441bba3cbadcfae7b678a20167347fa8ded34c/pyasn1-0.4.5-py2.py3-none-any.whl
Collecting pynacl>=1.0.1 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/27/15/2cd0a203f318c2240b42cd9dd13c931ddd61067809fee3479f44f086103e/PyNaCl-1.3.0-cp34-abi3-manylinux1_x86_64.whl
Collecting bcrypt>=3.1.3 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/31/4b/4057d0716e7170c29ff12e19791eb6037422620835e4a58a01d4790e56d1/bcrypt-3.1.5-cp34-abi3-manylinux1_x86_64.whl
Collecting argparse (from unittest2>=1.0.0->testtools>=0.9.22->fixtures==3.0.0->-r requirements.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Collecting asn1crypto>=0.21.0 (from cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting idna>=2.1 (from cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/14/2c/cd551d81dbe15200be1cf41cd03869a46fe7226e7450af7a6545bfc474c9/idna-2.8-py2.py3-none-any.whl
Collecting cffi!=1.11.3,>=1.7 (from cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
  Using cached https://files.pythonhosted.org/packages/6d/c0/47db8f624f3e4e2f3f27be03a93379d1ba16a1450a7b1aacfa0366e2c0dd/cffi-1.11.5-cp36-cp36m-manylinux1_x86_64.whl
Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 42))
Building wheels for collected packages: SQLAlchemy
  Running setup.py bdist_wheel for SQLAlchemy: started
  Running setup.py bdist_wheel for SQLAlchemy: finished with status 'done'
  Stored in directory: /var/lib/jenkins/.cache/pip/wheels/71/b5/67/1b1ae0279de6e79ee0d0a4061cdfa0604908e6052046671480
Successfully built SQLAlchemy
Installing collected packages: blinker, extras, six, pbr, linecache2, traceback2, argparse, unittest2, python-mimeparse, testtools, fixtures, MarkupSafe, Jinja2, Werkzeug, click, itsdangerous, Flask, Flask-Gravatar, Flask-Login, Flask-Mail, SQLAlchemy, Mako, python-dateutil, python-editor, alembic, Flask-SQLAlchemy, Flask-Migrate, Flask-Principal, WTForms, Flask-WTF, webencodings, html5lib, passlib, pycrypto, pyrsistent, pytz, simplejson, speaklater, sqlparse, Flask-Paranoid, psutil, psycopg2, htmlmin, Flask-HTMLmin, Babel, Flask-BabelEx, Flask-Security, asn1crypto, idna, pycparser, cffi, cryptography, pyasn1, pynacl, bcrypt, paramiko, sshtunnel
Successfully installed Babel-2.6.0 Flask-0.12.4 Flask-BabelEx-0.9.3 Flask-Gravatar-0.5.0 Flask-HTMLmin-1.3.2 Flask-Login-0.3.2 Flask-Mail-0.9.1 Flask-Migrate-2.1.1 Flask-Paranoid-0.2.0 Flask-Principal-0.4.0 Flask-SQLAlchemy-2.3.2 Flask-Security-3.0.0 Flask-WTF-0.14.2 Jinja2-2.10 Mako-1.0.7 MarkupSafe-1.1.0 SQLAlchemy-1.2.16 WTForms-2.1 Werkzeug-0.14.1 alembic-1.0.5 argparse-1.4.0 asn1crypto-0.24.0 bcrypt-3.1.5 blinker-1.4 cffi-1.11.5 click-7.0 cryptography-2.4.2 extras-1.0.0 fixtures-3.0.0 html5lib-1.0.1 htmlmin-0.1.12 idna-2.8 itsdangerous-1.1.0 linecache2-1.0.0 paramiko-2.4.2 passlib-1.7.1 pbr-3.1.1 psutil-5.4.7 psycopg2-2.7.6.1 pyasn1-0.4.5 pycparser-2.19 pycrypto-2.6.1 pynacl-1.3.0 pyrsistent-0.14.2 python-dateutil-2.7.5 python-editor-1.0.3 python-mimeparse-1.6.0 pytz-2018.3 simplejson-3.13.2 six-1.12.0 speaklater-1.3 sqlparse-0.2.4 sshtunnel-0.1.4 testtools-2.3.0 traceback2-1.4.0 unittest2-1.1.0 webencodings-0.5.1
Ignoring importlib: markers 'python_version <= "2.7"' don't match your environment
Ignoring psycopg2: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-Script: markers 'python_version < "2.7"' don't match your environment
Ignoring ordereddict: markers 'python_version < "2.7"' don't match your environment
Ignoring python-dateutil: markers 'python_version < "2.7"' don't match your environment
Ignoring SQLAlchemy: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-Security: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-BabelEx: markers 'python_version < "2.7"' don't match your environment
Ignoring selenium: markers 'python_version < "2.7"' don't match your environment
Ignoring mock: markers 'python_version < "3.3"' don't match your environment
Requirement already satisfied: blinker==1.4 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 6)) (1.4)
Requirement already satisfied: extras==1.0.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 7)) (1.0.0)
Requirement already satisfied: fixtures==3.0.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 8)) (3.0.0)
Requirement already satisfied: Flask==0.12.4 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 9)) (0.12.4)
Requirement already satisfied: Flask-Gravatar==0.5.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 10)) (0.5.0)
Requirement already satisfied: Flask-Login==0.3.2 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 11)) (0.3.2)
Requirement already satisfied: Flask-Mail==0.9.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 12)) (0.9.1)
Requirement already satisfied: Flask-Migrate==2.1.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 13)) (2.1.1)
Requirement already satisfied: Flask-Principal==0.4.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 14)) (0.4.0)
Requirement already satisfied: Flask-SQLAlchemy==2.3.2 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 15)) (2.3.2)
Requirement already satisfied: Flask-WTF==0.14.2 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 16)) (0.14.2)
Requirement already satisfied: html5lib==1.0.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 17)) (1.0.1)
Requirement already satisfied: linecache2==1.0.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 18)) (1.0.0)
Requirement already satisfied: passlib==1.7.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 19)) (1.7.1)
Requirement already satisfied: pbr==3.1.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 20)) (3.1.1)
Requirement already satisfied: pycrypto>=2.6.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 21)) (2.6.1)
Requirement already satisfied: pyrsistent==0.14.2 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 22)) (0.14.2)
Requirement already satisfied: python-mimeparse==1.6.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 23)) (1.6.0)
Requirement already satisfied: pytz==2018.3 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 24)) (2018.3)
Requirement already satisfied: simplejson==3.13.2 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 25)) (3.13.2)
Requirement already satisfied: six>=1.11.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 26)) (1.12.0)
Requirement already satisfied: speaklater==1.3 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 27)) (1.3)
Requirement already satisfied: sqlparse==0.2.4 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 28)) (0.2.4)
Requirement already satisfied: WTForms==2.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 29)) (2.1)
Requirement already satisfied: Flask-Paranoid==0.2.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 30)) (0.2.0)
Requirement already satisfied: psutil==5.4.7 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 31)) (5.4.7)
Requirement already satisfied: psycopg2>=2.7.4 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 36)) (2.7.6.1)
Requirement already satisfied: python-dateutil>=2.7.1 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 37)) (2.7.5)
Requirement already satisfied: htmlmin==0.1.12 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 38)) (0.1.12)
Requirement already satisfied: Flask-HTMLmin==1.3.2 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 39)) (1.3.2)
Requirement already satisfied: SQLAlchemy>=1.2.5 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 40)) (1.2.16)
Requirement already satisfied: Flask-Security>=3.0.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 41)) (3.0.0)
Requirement already satisfied: sshtunnel>=0.1.3 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/../../requirements.txt (line 42)) (0.1.4)
Collecting pycodestyle==2.3.1 (from -r web/regression/requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/e1/88/0e2cbf412bd849ea6f1af1f97882add46a374f4ba1d2aea39353609150ad/pycodestyle-2.3.1.tar.gz
Collecting pyperclip~=1.6.0 (from -r web/regression/requirements.txt (line 10))
  Using cached https://files.pythonhosted.org/packages/80/a4/7c65c8fb16787d74f720dfb1dee4227a65058f268e91014e24fd76b18f8b/pyperclip-1.6.5.tar.gz
Collecting testscenarios==0.5.0 (from -r web/regression/requirements.txt (line 11))
  Using cached https://files.pythonhosted.org/packages/f0/de/b0b5b98c0f38fd7086d082c47fcb455eedd39a044abe7c595f5f40cd6eed/testscenarios-0.5.0.tar.gz
Requirement already satisfied: testtools==2.3.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/requirements.txt (line 12)) (2.3.0)
Requirement already satisfied: traceback2==1.4.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/requirements.txt (line 13)) (1.4.0)
Requirement already satisfied: unittest2==1.1.0 in ./pgadmin-venv/lib/python3.6/site-packages (from -r web/regression/requirements.txt (line 14)) (1.1.0)
Collecting selenium==3.11.0 (from -r web/regression/requirements.txt (line 19))
  Using cached https://files.pythonhosted.org/packages/d4/28/8124d32415bd3d67fabea52480395427576b582771283e89ce10a56d9e5b/selenium-3.11.0.tar.gz
Collecting chromedriver_installer==0.0.6 (from -r web/regression/requirements.txt (line 33))
  Using cached https://files.pythonhosted.org/packages/c8/01/0a8a725bb605f68923aba16099a01cbbfe547c8b7dc96fd9a554424f6524/chromedriver_installer-0.0.6.tar.gz
Requirement already satisfied: Jinja2>=2.4 in ./pgadmin-venv/lib/python3.6/site-packages (from Flask==0.12.4->-r web/regression/../../requirements.txt (line 9)) (2.10)
Requirement already satisfied: Werkzeug>=0.7 in ./pgadmin-venv/lib/python3.6/site-packages (from Flask==0.12.4->-r web/regression/../../requirements.txt (line 9)) (0.14.1)
Requirement already satisfied: itsdangerous>=0.21 in ./pgadmin-venv/lib/python3.6/site-packages (from Flask==0.12.4->-r web/regression/../../requirements.txt (line 9)) (1.1.0)
Requirement already satisfied: click>=2.0 in ./pgadmin-venv/lib/python3.6/site-packages (from Flask==0.12.4->-r web/regression/../../requirements.txt (line 9)) (7.0)
Requirement already satisfied: alembic>=0.6 in ./pgadmin-venv/lib/python3.6/site-packages (from Flask-Migrate==2.1.1->-r web/regression/../../requirements.txt (line 13)) (1.0.5)
Requirement already satisfied: webencodings in ./pgadmin-venv/lib/python3.6/site-packages (from html5lib==1.0.1->-r web/regression/../../requirements.txt (line 17)) (0.5.1)
Requirement already satisfied: Flask-BabelEx>=0.9.3 in ./pgadmin-venv/lib/python3.6/site-packages (from Flask-Security>=3.0.0->-r web/regression/../../requirements.txt (line 41)) (0.9.3)
Requirement already satisfied: paramiko>=1.15.2 in ./pgadmin-venv/lib/python3.6/site-packages (from sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (2.4.2)
Requirement already satisfied: argparse in ./pgadmin-venv/lib/python3.6/site-packages (from unittest2==1.1.0->-r web/regression/requirements.txt (line 14)) (1.4.0)
Requirement already satisfied: MarkupSafe>=0.23 in ./pgadmin-venv/lib/python3.6/site-packages (from Jinja2>=2.4->Flask==0.12.4->-r web/regression/../../requirements.txt (line 9)) (1.1.0)
Requirement already satisfied: python-editor>=0.3 in ./pgadmin-venv/lib/python3.6/site-packages (from alembic>=0.6->Flask-Migrate==2.1.1->-r web/regression/../../requirements.txt (line 13)) (1.0.3)
Requirement already satisfied: Mako in ./pgadmin-venv/lib/python3.6/site-packages (from alembic>=0.6->Flask-Migrate==2.1.1->-r web/regression/../../requirements.txt (line 13)) (1.0.7)
Requirement already satisfied: Babel>=1.0 in ./pgadmin-venv/lib/python3.6/site-packages (from Flask-BabelEx>=0.9.3->Flask-Security>=3.0.0->-r web/regression/../../requirements.txt (line 41)) (2.6.0)
Requirement already satisfied: pynacl>=1.0.1 in ./pgadmin-venv/lib/python3.6/site-packages (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (1.3.0)
Requirement already satisfied: bcrypt>=3.1.3 in ./pgadmin-venv/lib/python3.6/site-packages (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (3.1.5)
Requirement already satisfied: pyasn1>=0.1.7 in ./pgadmin-venv/lib/python3.6/site-packages (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (0.4.5)
Requirement already satisfied: cryptography>=1.5 in ./pgadmin-venv/lib/python3.6/site-packages (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (2.4.2)
Requirement already satisfied: cffi>=1.4.1 in ./pgadmin-venv/lib/python3.6/site-packages (from pynacl>=1.0.1->paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (1.11.5)
Requirement already satisfied: idna>=2.1 in ./pgadmin-venv/lib/python3.6/site-packages (from cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (2.8)
Requirement already satisfied: asn1crypto>=0.21.0 in ./pgadmin-venv/lib/python3.6/site-packages (from cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (0.24.0)
Requirement already satisfied: pycparser in ./pgadmin-venv/lib/python3.6/site-packages (from cffi>=1.4.1->pynacl>=1.0.1->paramiko>=1.15.2->sshtunnel>=0.1.3->-r web/regression/../../requirements.txt (line 42)) (2.19)
Skipping bdist_wheel for pycodestyle, due to binaries being disabled for it.
Skipping bdist_wheel for pyperclip, due to binaries being disabled for it.
Skipping bdist_wheel for testscenarios, due to binaries being disabled for it.
Skipping bdist_wheel for selenium, due to binaries being disabled for it.
Skipping bdist_wheel for chromedriver-installer, due to binaries being disabled for it.
Installing collected packages: pycodestyle, pyperclip, testscenarios, selenium, chromedriver-installer
  Running setup.py install for pycodestyle: started
    Running setup.py install for pycodestyle: finished with status 'done'
  Running setup.py install for pyperclip: started
    Running setup.py install for pyperclip: finished with status 'done'
  Running setup.py install for testscenarios: started
    Running setup.py install for testscenarios: finished with status 'done'
  Running setup.py install for selenium: started
    Running setup.py install for selenium: finished with status 'done'
  Running setup.py install for chromedriver-installer: started
    Running setup.py install for chromedriver-installer: finished with status 'done'
Successfully installed chromedriver-installer-0.0.6 pycodestyle-2.3.1 pyperclip-1.6.5 selenium-3.11.0 testscenarios-0.5.0
<https://jenkins.pgadmin.org/job/pgadmin4-master-python36/ws/pgadmin-venv/lib/python3.6/site-packages/pip/_internal/req/req_file.py>:150: UserWarning: Disabling all use of wheels due to the use of --build-options / --global-options / --install-options.
  cmdoptions.check_install_build_global(options, opts)
Running PEP-8 checks...

cd web && pycodestyle --config=.pycodestyle .
./pgadmin/utils/driver/psycopg2/connection.py:55: [E302] expected 2 blank lines, found 1
./pgadmin/utils/driver/psycopg2/connection.py:412: [E303] too many blank lines (2)
./pgadmin/utils/driver/psycopg2/encoding.py:38: [E302] expected 2 blank lines, found 1
3
2       E302 expected 2 blank lines, found 1
1       E303 too many blank lines (2)
make: *** [check-pep8] Error 1
ERROR: Error detected when running the Python PEP-8 checks.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

Reply | Threaded
Open this post in threaded view
|

Jenkins build is back to normal : pgadmin4-master-python36 #857

pgAdmin 4 Jenkins