Can't start 4.6

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't start 4.6

durumdara
Hello!

I wrote this before to "Eternal loading" mail.

I had an installed 4.5 - that worked well.

I installed 4.6 cca a week before.

The instance tried to start, the icon was visible in system tray, the splash was visible for long time, and then the instance closed +  the icon/app vanished.

That day I reinstalled 4.5 which worked well for this time.

Today I tried to install 4.6 again.

The problem is also same as before.

The icon is visible on the tray, the splash is on. 
I can click on icon, but I can't copy the server address because it's empty.

After long time (1-2 minutes) the program will close with errormessage:

---------------------------
Fatal Error
---------------------------
The application server could not be contacted.
---------------------------
OK  
---------------------------

I think it's not browser based thing.

No pgadmin.log created.

Please help me how to I find any debug information about this problem?

Thanks

Best Regards
    dd







Reply | Threaded
Open this post in threaded view
|

Re: Can't start 4.6

Khushboo Vashi


On Fri, May 10, 2019 at 6:52 PM Durumdara <[hidden email]> wrote:
Hello!

I wrote this before to "Eternal loading" mail.

I had an installed 4.5 - that worked well.

I installed 4.6 cca a week before.

The instance tried to start, the icon was visible in system tray, the splash was visible for long time, and then the instance closed +  the icon/app vanished.

That day I reinstalled 4.5 which worked well for this time.

Today I tried to install 4.6 again.

The problem is also same as before.

The icon is visible on the tray, the splash is on. 
I can click on icon, but I can't copy the server address because it's empty.

After long time (1-2 minutes) the program will close with errormessage:

---------------------------
Fatal Error
---------------------------
The application server could not be contacted.
---------------------------
OK  
---------------------------

I think it's not browser based thing.

No pgadmin.log created.

Please help me how to I find any debug information about this problem?

Please search for pgAdmin4.startup.log and pgAdmin.<long number>.log files in your home directory, which may have the information.
Thanks

Best Regards
    dd







Reply | Threaded
Open this post in threaded view
|

Re: Can't start 4.6

durumdara
Hello!

I tried to find any files with "pgadm*.log" in all drives.
I have found only two: every of them is old (2018-07-*).
Do you know any possibilites to catch the error's source?

Thanks for you!
  dd

Khushboo Vashi <[hidden email]> ezt írta (időpont: 2019. máj. 13., H, 7:38):


Please help me how to I find any debug information about this problem?

Please search for pgAdmin4.startup.log and pgAdmin.<long number>.log files in your home directory, which may have the information.
Thanks

Best Regards
    dd







Reply | Threaded
Open this post in threaded view
|

Re: Can't start 4.6

Aditya Toshniwal
Hi,

On Mon, May 13, 2019 at 12:21 PM Durumdara <[hidden email]> wrote:
Hello!

I tried to find any files with "pgadm*.log" in all drives.
The files start with a "." dot. Try search again with ".pgAdmin*"  
I have found only two: every of them is old (2018-07-*).
Do you know any possibilites to catch the error's source?

Thanks for you!
  dd

Khushboo Vashi <[hidden email]> ezt írta (időpont: 2019. máj. 13., H, 7:38):


Please help me how to I find any debug information about this problem?

Please search for pgAdmin4.startup.log and pgAdmin.<long number>.log files in your home directory, which may have the information.
Thanks

Best Regards
    dd









--
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"
Reply | Threaded
Open this post in threaded view
|

Re: Can't start 4.6

durumdara
Hello!

Aditya Toshniwal <[hidden email]> ezt írta (időpont: 2019. máj. 13., H, 8:55):
Hi,

On Mon, May 13, 2019 at 12:21 PM Durumdara <[hidden email]> wrote:
Hello!

I tried to find any files with "pgadm*.log" in all drives.
The files start with a "." dot. Try search again with ".pgAdmin*"  


Firstly the new version didn't like "t:\" path.

Traceback (most recent call last):
  File "D:/Programok/pgAdmin 4/v4/web/pgAdmin4.py", line 97, in <module>
    app = create_app()
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\__init__.py", line 241, in create_app
    create_app_data_directory(config)
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\setup\data_directory.py", line 24, in create_app_data_directory
    os.chmod(os.path.dirname(config.SQLITE_PATH), 0o700)
OSError: [WinError 87] A paraméter nem megfelelő: 't:\\'

----

Then I replaced with "/", but it is also problematic.

SQLITE_PATH = 't:/pgadmin4.db'  

  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\setup\data_directory.py", line 24, in create_app_data_directory
    os.chmod(os.path.dirname(config.SQLITE_PATH), 0o700)
OSError: [WinError 87] A paraméter nem megfelelő: 't:/'

-----

Traceback (most recent call last):
  File "D:/Programok/pgAdmin 4/v4/web/pgAdmin4.py", line 97, in <module>
    app = create_app()
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\__init__.py", line 241, in create_app
    create_app_data_directory(config)
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\setup\data_directory.py", line 24, in create_app_data_directory
    os.chmod(os.path.dirname(config.SQLITE_PATH), 0o700)
OSError: [WinError 87] A paraméter nem megfelelő: 't:\\'

-----

The config local is:

import logging

CONSOLE_LOG_LEVEL = logging.DEBUG
FILE_LOG_LEVEL = logging.DEBUG

# Log format.
CONSOLE_LOG_FORMAT = '%(asctime)s: %(levelname)s\t%(name)s:\t%(message)s'
FILE_LOG_FORMAT = '%(asctime)s: %(levelname)s\t%(name)s:\t%(message)s'

# Log file name
#LOG_FILE = 't:/pgadmin4.log'
LOG_FILE = 'd:/temp/pgadmin4.log'

SQLITE_PATH = 't:\\pgadmin4.db'

----

How can I define the path to work as needed?

All versions before 4.6  work with these format. What I can do?

Thanks!

dd
Reply | Threaded
Open this post in threaded view
|

Re: Can't start 4.6

Aditya Toshniwal
Hi,

On Mon, May 13, 2019 at 7:17 PM Durumdara <[hidden email]> wrote:
Hello!

Aditya Toshniwal <[hidden email]> ezt írta (időpont: 2019. máj. 13., H, 8:55):
Hi,

On Mon, May 13, 2019 at 12:21 PM Durumdara <[hidden email]> wrote:
Hello!

I tried to find any files with "pgadm*.log" in all drives.
The files start with a "." dot. Try search again with ".pgAdmin*"  


Firstly the new version didn't like "t:\" path.

Traceback (most recent call last):
  File "D:/Programok/pgAdmin 4/v4/web/pgAdmin4.py", line 97, in <module>
    app = create_app()
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\__init__.py", line 241, in create_app
    create_app_data_directory(config)
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\setup\data_directory.py", line 24, in create_app_data_directory
    os.chmod(os.path.dirname(config.SQLITE_PATH), 0o700)
OSError: [WinError 87] A paraméter nem megfelelő: 't:\\'

----

Then I replaced with "/", but it is also problematic.

SQLITE_PATH = 't:/pgadmin4.db'  

  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\setup\data_directory.py", line 24, in create_app_data_directory
    os.chmod(os.path.dirname(config.SQLITE_PATH), 0o700)
OSError: [WinError 87] A paraméter nem megfelelő: 't:/'

-----

Traceback (most recent call last):
  File "D:/Programok/pgAdmin 4/v4/web/pgAdmin4.py", line 97, in <module>
    app = create_app()
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\__init__.py", line 241, in create_app
    create_app_data_directory(config)
  File "D:\Programok\pgAdmin 4\v4\web\pgadmin\setup\data_directory.py", line 24, in create_app_data_directory
    os.chmod(os.path.dirname(config.SQLITE_PATH), 0o700)
OSError: [WinError 87] A paraméter nem megfelelő: 't:\\'

-----

The config local is:

import logging

CONSOLE_LOG_LEVEL = logging.DEBUG
FILE_LOG_LEVEL = logging.DEBUG

# Log format.
CONSOLE_LOG_FORMAT = '%(asctime)s: %(levelname)s\t%(name)s:\t%(message)s'
FILE_LOG_FORMAT = '%(asctime)s: %(levelname)s\t%(name)s:\t%(message)s'

# Log file name
#LOG_FILE = 't:/pgadmin4.log'
LOG_FILE = 'd:/temp/pgadmin4.log'

SQLITE_PATH = 't:\\pgadmin4.db'

----

How can I define the path to work as needed?

All versions before 4.6  work with these format. What I can do?
Try creating a directory under "t:" and set sqlite path to that directory. I suspect it is failing when it is trying to give permissions. 

Thanks!

dd


--
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"
Reply | Threaded
Open this post in threaded view
|

Re: Can't start 4.6

durumdara
Hi to All!

 

How can I define the path to work as needed?

All versions before 4.6  work with these format. What I can do?
Try creating a directory under "t:" and set sqlite path to that directory. I suspect it is failing when it is trying to give permissions. 


That is working well! Woooow!  Thank you for (the music, ABBA 😊 ) the solution!

Best dishes... 😂

dd
Reply | Threaded
Open this post in threaded view
|

Re: Can't start 4.6

Aditya Toshniwal


On Tue, May 14, 2019 at 12:32 PM Durumdara <[hidden email]> wrote:
Hi to All!

 

How can I define the path to work as needed?

All versions before 4.6  work with these format. What I can do?
Try creating a directory under "t:" and set sqlite path to that directory. I suspect it is failing when it is trying to give permissions. 


That is working well! Woooow!  Thank you for (the music, ABBA 😊 ) the solution!
Glad to help :)  

Best dishes... 😂

dd


--
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"