Dependency problem using community repo on Redhat 7

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Dependency problem using community repo on Redhat 7

Lawrence Layhee

Hi,

We are having a dependency problem when using the community repo on redhat 7

When we install postgresql12-devel-12.4-1PGDG.rhel7.x86_64 we get the issue below.

Redhat doesn’t support the dependencies. Any ideas? We are trying to get the ruby gem installed. It works with the Redhat dist of PostgreSQL but we prefer community.

Any help would be appreciated

 

Finished Dependency Resolution

Error: Package: postgresql12-devel-12.4-1PGDG.rhel7.x86_64 (/postgresql12-devel-12.4-1PGDG.rhel7.x86_64)

           Requires: llvm-toolset-7-clang >= 4.0.1

Error: Package: llvm5.0-devel-5.0.1-7.el7.x86_64 (epel)

           Requires: libedit-devel

Error: Package: postgresql12-devel-12.4-1PGDG.rhel7.x86_64 (/postgresql12-devel-12.4-1PGDG.rhel7.x86_64)

           Requires: libicu-devel

 

 

 

Thank you, Larry

 

 

Lawrence Layhee

Database Administration

Midrange Computing Division

Los Angeles County Internal Services Department

(  (562) 658-1701 – Office

Cell (562)-302-3080

* [hidden email]

P Please consider the environment before printing this e-mail and/or attachments

 

Reply | Threaded
Open this post in threaded view
|

Re: Dependency problem using community repo on Redhat 7

Adrian Klaver-4
On 9/3/20 11:31 AM, Lawrence Layhee wrote:

> Hi,
>
> We are having a dependency problem when using the community repo on redhat 7
>
> When we install postgresql12-devel-12.4-1PGDG.rhel7.x86_64 we get the
> issue below.
>
> Redhat doesn’t support the dependencies. Any ideas? We are trying to get
> the ruby gem installed. It works with the Redhat dist of PostgreSQL but
> we prefer community.
>
> Any help would be appreciated
>
> Finished Dependency Resolution
>
> Error: Package: postgresql12-devel-12.4-1PGDG.rhel7.x86_64
> (/postgresql12-devel-12.4-1PGDG.rhel7.x86_64)
>
>             Requires: llvm-toolset-7-clang >= 4.0.1
>
> Error: Package: llvm5.0-devel-5.0.1-7.el7.x86_64 (epel)
>
>             Requires: libedit-devel
>
> Error: Package: postgresql12-devel-12.4-1PGDG.rhel7.x86_64
> (/postgresql12-devel-12.4-1PGDG.rhel7.x86_64)
>
>             Requires: libicu-devel


Have you seen this?:

https://yum.postgresql.org/news/devel-rpms-require-a-new-repository/

>
> Thank you, Larry
>
> Lawrence Layhee
>
> Database Administration
>
> Midrange Computing Division
>
> Los Angeles County Internal Services Department
>
> ((562) 658-1701 – Office
>
> Cell (562)-302-3080
>
> * [hidden email] <mailto:[hidden email]>_
>
> /P //Please consider the environment before printing this e-mail and/or
> attachments/
>


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Dependency problem using community repo on Redhat 7

Devrim GÜNDÜZ
In reply to this post by Lawrence Layhee

Hi,

On Thu, 2020-09-03 at 18:31 +0000, Lawrence Layhee wrote:
> We are having a dependency problem when using the community repo on
> redhat 7
> When we install postgresql12-devel-12.4-1PGDG.rhel7.x86_64 we get the
> issue below.

<snip>

https://yum.postgresql.org/news/devel-rpms-require-a-new-repository/

Regards,
--
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

signature.asc (849 bytes) Download Attachment