[HELP] Unable to initiate database cluster

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[HELP] Unable to initiate database cluster

dsge94@outlook.com

I download the zip archives [Binaries from installer Version 11.4] from postgresql website (https://www.enterprisedb.com/download-postgresql-binaries) . The binaries are unzipped in the folder D:\pgsql.

 

When I cd into folder D:\pgsql\bin and execute the following command

  >> .\initdb -D E:\path\to\my\data -U postgres -W

I get an error. The error prompt is:

The program "postgres" was found by "D:/pgsql/bin/initdb.exe"

but was not the same version as initdb.

Check your installation.

 

But I check both the initdb.exe and postgres.exe, only to find that their versions are the same (11.4)

 

Is there anything wrong with my configuration? What should I do?

 

Thanks for your help

 

Devon

Reply | Threaded
Open this post in threaded view
|

Re: [HELP] Unable to initiate database cluster

Kyotaro Horiguchi-4
Hello.

At Fri, 9 Aug 2019 03:14:29 +0000, "[hidden email]" <[hidden email]> wrote in
 <[hidden email]>

> I download the zip archives [Binaries from installer Version 11.4] from postgresql website (https://www.enterprisedb.com/download-postgresql-binaries) . The binaries are unzipped in the folder D:\pgsql.
>
> When I cd into folder D:\pgsql\bin and execute the following command
>   >> .\initdb -D E:\path\to\my\data -U postgres -W
> I get an error. The error prompt is:
> The program "postgres" was found by "D:/pgsql/bin/initdb.exe"
> but was not the same version as initdb.
> Check your installation.
>
> But I check both the initdb.exe and postgres.exe, only to find that their versions are the same (11.4)
>
> Is there anything wrong with my configuration? What should I do?

The message means that postgres.exe is found in the same
directory, but it is not the same version with initdb. Maybe you
have copied the zip file partly onto existing installation of
maybe-older version of postgresql.

You will see what is wrong by running the commands with -V option
like this.

> .\initdb -V
initdb (PostgreSQL) 11.4
> .\postgres -V
postgres (PostgreSQL) 13devel

The versions must match exactly.

regards.

--
Kyotaro Horiguchi
NTT Open Source Software Center


Reply | Threaded
Open this post in threaded view
|

Re: [HELP] Unable to initiate database cluster

Sandeep Thakkar-2
BTW, the version available at https://www.enterprisedb.com/download-postgresql-binaries is 11.5

On Fri, Aug 9, 2019 at 1:12 PM Kyotaro Horiguchi <[hidden email]> wrote:
Hello.

At Fri, 9 Aug 2019 03:14:29 +0000, "[hidden email]" <[hidden email]> wrote in
 <[hidden email]>
> I download the zip archives [Binaries from installer Version 11.4] from postgresql website (https://www.enterprisedb.com/download-postgresql-binaries) . The binaries are unzipped in the folder D:\pgsql.
>
> When I cd into folder D:\pgsql\bin and execute the following command
>   >> .\initdb -D E:\path\to\my\data -U postgres -W
> I get an error. The error prompt is:
> The program "postgres" was found by "D:/pgsql/bin/initdb.exe"
> but was not the same version as initdb.
> Check your installation.
>
> But I check both the initdb.exe and postgres.exe, only to find that their versions are the same (11.4)
>
> Is there anything wrong with my configuration? What should I do?

The message means that postgres.exe is found in the same
directory, but it is not the same version with initdb. Maybe you
have copied the zip file partly onto existing installation of
maybe-older version of postgresql.

You will see what is wrong by running the commands with -V option
like this.

> .\initdb -V
initdb (PostgreSQL) 11.4
> .\postgres -V
postgres (PostgreSQL) 13devel

The versions must match exactly.

regards.

--
Kyotaro Horiguchi
NTT Open Source Software Center




--
Sandeep Thakkar