Help - Need 9.3 for Centos - recovery of legacy system

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Help - Need 9.3 for Centos - recovery of legacy system

Brad Thompson
Need to get 9.3 to install to recover a legacy system.  We have a legacy system that experienced a hardware failure requiring a OS reload.  Have installed 9.6 as an interim step but it won't let me get to the 9.3 databases.

Am hoping to use the migration tools to get the 9.3 data dumped then reloaded into newer version.

Can anyone assist?

Thanks in advance
Reply | Threaded
Open this post in threaded view
|

Re: Help - Need 9.3 for Centos - recovery of legacy system

Adrian Klaver-4
On 6/29/20 5:04 AM, Brad Thompson wrote:
> Need to get 9.3 to install to recover a legacy system.  We have a legacy
> system that experienced a hardware failure requiring a OS reload.  Have
> installed 9.6 as an interim step but it won't let me get to the 9.3
> databases.

So you have the 9.3 data directories, but not the 9.3 binaries to use
the them?

>
> Am hoping to use the migration tools to get the 9.3 data dumped then
> reloaded into newer version.
>
> Can anyone assist?

What OS and it's version?

Or you could build 9.3 from source:

https://www.postgresql.org/ftp/source/v9.3.25/

and then dump from the 9.3 running instance using the 9.6 pg_dump.

>
> Thanks in advance


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Help - Need 9.3 for Centos - recovery of legacy system

Adrian Klaver-4
On 6/29/20 6:02 AM, Adrian Klaver wrote:

> On 6/29/20 5:04 AM, Brad Thompson wrote:
>> Need to get 9.3 to install to recover a legacy system.  We have a
>> legacy system that experienced a hardware failure requiring a OS
>> reload.  Have installed 9.6 as an interim step but it won't let me get
>> to the 9.3 databases.
>
> So you have the 9.3 data directories, but not the 9.3 binaries to use
> the them?
>
>>
>> Am hoping to use the migration tools to get the 9.3 data dumped then
>> reloaded into newer version.
>>
>> Can anyone assist?
>
> What OS and it's version?

It would help if I read the subject. Still not sure of the version, but
there are EOL versions available here:

https://yum.postgresql.org/repopackages.php

>
> Or you could build 9.3 from source:
>
> https://www.postgresql.org/ftp/source/v9.3.25/
>
> and then dump from the 9.3 running instance using the 9.6 pg_dump.
>
>>
>> Thanks in advance
>
>


--
Adrian Klaver
[hidden email]