Minor cleanup of partbounds.c

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Minor cleanup of partbounds.c

Etsuro Fujita-2
Here is a patch for minor cleanup of the partbounds.c changes made by
commit c8434d64c: 1) removes a useless assignment (in normal builds)
and 2) improves comments a little.

Best regards,
Etsuro Fujita

partbounds-cleanup.patch (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Minor cleanup of partbounds.c

Alvaro Herrera-9
On 2020-Sep-09, Etsuro Fujita wrote:

> Here is a patch for minor cleanup of the partbounds.c changes made by
> commit c8434d64c: 1) removes a useless assignment (in normal builds)

LGTM.

> and 2) improves comments a little.

No objection to changing "bounds" to "range bounds".

I think the point other is to replace the only appearance of "dummy
relation" to better match the extensive use of "dummy partition" in this
file.  The concept of a "dummy relation" is well established in the
planner.  I didn't know if "dummy partition" is itself a concept
(apparently in the newfangled partition-wise join stuff), or just
glorified wording to say "a dummy relation that happens to be a
partition".  Looking at is_dummy_partition, apparently a dummy partition
is either a dummy relation or a partition that doesn't have a
RelOptInfo.  So my conclusion is that this wording is okay to change
too.

--
Álvaro Herrera                https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services


Reply | Threaded
Open this post in threaded view
|

Re: Minor cleanup of partbounds.c

Etsuro Fujita-2
On Thu, Sep 10, 2020 at 2:05 AM Alvaro Herrera <[hidden email]> wrote:

> On 2020-Sep-09, Etsuro Fujita wrote:
> > Here is a patch for minor cleanup of the partbounds.c changes made by
> > commit c8434d64c: 1) removes a useless assignment (in normal builds)
>
> LGTM.
>
> > and 2) improves comments a little.
>
> No objection to changing "bounds" to "range bounds".
>
> I think the point other is to replace the only appearance of "dummy
> relation" to better match the extensive use of "dummy partition" in this
> file.  The concept of a "dummy relation" is well established in the
> planner.  I didn't know if "dummy partition" is itself a concept
> (apparently in the newfangled partition-wise join stuff), or just
> glorified wording to say "a dummy relation that happens to be a
> partition".  Looking at is_dummy_partition, apparently a dummy partition
> is either a dummy relation or a partition that doesn't have a
> RelOptInfo.  So my conclusion is that this wording is okay to change
> too.

Cool!

I pushed the patch.  Thanks for reviewing!

Best regards,
Etsuro Fujita