Missing libpq-dev version in buster-pgdg?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing libpq-dev version in buster-pgdg?

Nick Aldwin
Hi folks,

Did something change recently with what versions of libpq-dev are published to buster-pgdg?  We have a dockerfile based on postgres:12.2 (which is based on buster-slim) that installs "libpq-dev=$PG_MAJOR.*"  and it just recently (this week) started failing.  running a brand new postgres container and checking the apt cache, I only see versions for 11 (coming from debian sources) and 13 (coming from buster-pgdg main).  I have verified that the sources list includes both main and 12 -- was it removed from 12?
$ docker run --rm -it --entrypoint bash postgres:12.2root@fb7c949f82a0:/# apt update && apt-cache policy libpq-devGet:1 http://deb.debian.org/debian buster InRelease [121 kB]
Get:2 http://security.debian.org/debian-security buster/updates InRelease [65.4 kB]
Get:3 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
Get:4 http://apt.postgresql.org/pub/repos/apt buster-pgdg InRelease [103 kB]
Get:5 http://security.debian.org/debian-security buster/updates/main amd64 Packages [233 kB]
Get:6 http://deb.debian.org/debian buster/main amd64 Packages [7,906 kB]
Get:7 http://deb.debian.org/debian buster-updates/main amd64 Packages [7,868 B]
Get:8 http://apt.postgresql.org/pub/repos/apt buster-pgdg/12 amd64 Packages [861 B]
Get:9 http://apt.postgresql.org/pub/repos/apt buster-pgdg/main amd64 Packages [203 kB]
Fetched 8,694 kB in 2s (3,782 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
19 packages can be upgraded. Run 'apt list --upgradable' to see them.
libpq-dev:
Installed: (none)
Candidate: 13.0-1.pgdg100+1
Version table:
13.0-1.pgdg100+1 500
500 http://apt.postgresql.org/pub/repos/apt buster-pgdg/main amd64 Packages
11.9-0+deb10u1 500
500 http://deb.debian.org/debian buster/main amd64 Packages
11.7-0+deb10u1 500
500 http://security.debian.org/debian-security buster/updates/main amd64 Packagesroot@fb7c949f82a0:/# cat /etc/apt/sources.list.d/pgdg.listdeb http://apt.postgresql.org/pub/repos/apt/ buster-pgdg main 12

Thanks,
Nick
Reply | Threaded
Open this post in threaded view
|

Re: Missing libpq-dev version in buster-pgdg?

Adrian Klaver-4
On 10/7/20 11:01 AM, Nick Aldwin wrote:

> Hi folks,
>
> Did something change recently with what versions of libpq-dev are
> published to buster-pgdg?  We have a dockerfile based on
> |postgres:12.2| (which is based on |buster-slim|) that installs
> |"libpq-dev=$PG_MAJOR.*"|  and it just recently (this week) started
> failing.  running a brand new postgres container and checking the apt
> cache, I only see versions for 11 (coming from debian sources) and 13
> (coming from buster-pgdg main).  I have verified that the sources list
> includes both |main| and |12| -- was it removed from |12|?

See this FAQ item:

https://wiki.postgresql.org/wiki/Apt/FAQ#I_want_libpq5_for_version_X.2C_but_there_is_only_version_Y_in_the_repository

for how it works in the PGDG repos.

On the Debian side V11 is the supported version for Buster.

>
> $ docker run --rm -it --entrypoint bash postgres:12.2root@fb7c949f82a0:/# apt update && apt-cache policy libpq-devGet:1http://deb.debian.org/debian  buster InRelease [121 kB]
> Get:2http://security.debian.org/debian-security  buster/updates InRelease [65.4 kB]
> Get:3http://deb.debian.org/debian  buster-updates InRelease [51.9 kB]
> Get:4http://apt.postgresql.org/pub/repos/apt  buster-pgdg InRelease [103 kB]
> Get:5http://security.debian.org/debian-security  buster/updates/main amd64 Packages [233 kB]
> Get:6http://deb.debian.org/debian  buster/main amd64 Packages [7,906 kB]
> Get:7http://deb.debian.org/debian  buster-updates/main amd64 Packages [7,868 B]
> Get:8http://apt.postgresql.org/pub/repos/apt  buster-pgdg/12 amd64 Packages [861 B]
> Get:9http://apt.postgresql.org/pub/repos/apt  buster-pgdg/main amd64 Packages [203 kB]
> Fetched 8,694 kB in 2s (3,782 kB/s)
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> 19 packages can be upgraded. Run 'apt list --upgradable' to see them.
> libpq-dev:
>    Installed: (none)
>    Candidate: 13.0-1.pgdg100+1
>    Version table:
>       13.0-1.pgdg100+1 500
>          500http://apt.postgresql.org/pub/repos/apt  buster-pgdg/main amd64 Packages
>       11.9-0+deb10u1 500
>          500http://deb.debian.org/debian  buster/main amd64 Packages
>       11.7-0+deb10u1 500
>          500http://security.debian.org/debian-security  buster/updates/main amd64 Packagesroot@fb7c949f82a0:/# cat /etc/apt/sources.list.d/pgdg.listdebhttp://apt.postgresql.org/pub/repos/apt/  buster-pgdg main 12
>
>
> Thanks,
> Nick


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Missing libpq-dev version in buster-pgdg?

Nick Aldwin
Hi Adrian,

The FAQ you linked to says the following:

If you really want to use a different version, the packages are available in separate archive components named after the PostgreSQL major version. Append that version after "main" in your sources.list. For example, if you wanted 9.0's libpq5 on Debian Squeeze, use this: deb http://apt.postgresql.org/pub/repos/apt/ squeeze-pgdg main 9.0

In the postgres dockerfile, it _is_ appending the version 12 to the sources list:

root@fb7c949f82a0:/# cat /etc/apt/sources.list.d/pgdg.list
deb http://apt.postgresql.org/pub/repos/apt/ buster-pgdg main 12

However I am still not seeing that version show up.  If I remove 'main', leaving just 12, no versions show up as coming from the postgres repo at all.  Am I missing something else here?

-Nick


On Wed, Oct 7, 2020 at 2:56 PM Adrian Klaver <[hidden email]> wrote:
On 10/7/20 11:01 AM, Nick Aldwin wrote:
> Hi folks,
>
> Did something change recently with what versions of libpq-dev are
> published to buster-pgdg?  We have a dockerfile based on
> |postgres:12.2| (which is based on |buster-slim|) that installs
> |"libpq-dev=$PG_MAJOR.*"|  and it just recently (this week) started
> failing.  running a brand new postgres container and checking the apt
> cache, I only see versions for 11 (coming from debian sources) and 13
> (coming from buster-pgdg main).  I have verified that the sources list
> includes both |main| and |12| -- was it removed from |12|?

See this FAQ item:

https://wiki.postgresql.org/wiki/Apt/FAQ#I_want_libpq5_for_version_X.2C_but_there_is_only_version_Y_in_the_repository

for how it works in the PGDG repos.

On the Debian side V11 is the supported version for Buster.

>
> $ docker run --rm -it --entrypoint bash postgres:12.2root@fb7c949f82a0:/# apt update && apt-cache policy libpq-devGet:1http://deb.debian.org/debian  buster InRelease [121 kB]
> Get:2http://security.debian.org/debian-security  buster/updates InRelease [65.4 kB]
> Get:3http://deb.debian.org/debian  buster-updates InRelease [51.9 kB]
> Get:4http://apt.postgresql.org/pub/repos/apt  buster-pgdg InRelease [103 kB]
> Get:5http://security.debian.org/debian-security  buster/updates/main amd64 Packages [233 kB]
> Get:6http://deb.debian.org/debian  buster/main amd64 Packages [7,906 kB]
> Get:7http://deb.debian.org/debian  buster-updates/main amd64 Packages [7,868 B]
> Get:8http://apt.postgresql.org/pub/repos/apt  buster-pgdg/12 amd64 Packages [861 B]
> Get:9http://apt.postgresql.org/pub/repos/apt  buster-pgdg/main amd64 Packages [203 kB]
> Fetched 8,694 kB in 2s (3,782 kB/s)
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> 19 packages can be upgraded. Run 'apt list --upgradable' to see them.
> libpq-dev:
>    Installed: (none)
>    Candidate: 13.0-1.pgdg100+1
>    Version table:
>       13.0-1.pgdg100+1 500
>          500http://apt.postgresql.org/pub/repos/apt  buster-pgdg/main amd64 Packages
>       11.9-0+deb10u1 500
>          500http://deb.debian.org/debian  buster/main amd64 Packages
>       11.7-0+deb10u1 500
>          500http://security.debian.org/debian-security  buster/updates/main amd64 Packagesroot@fb7c949f82a0:/# cat /etc/apt/sources.list.d/pgdg.listdebhttp://apt.postgresql.org/pub/repos/apt/  buster-pgdg main 12
>
>
> Thanks,
> Nick


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Missing libpq-dev version in buster-pgdg?

Adrian Klaver-4
On 10/7/20 12:02 PM, Nick Aldwin wrote:

> Hi Adrian,
>
> The FAQ you linked to says the following:
>
>  > If you really want to use a different version, the packages are
> available in separate archive components named after the PostgreSQL
> major version. Append that version after "main" in your sources.list.
> For example, if you wanted 9.0's libpq5 on Debian Squeeze, use this: deb
> http://apt.postgresql.org/pub/repos/apt/ squeeze-pgdg main *9.0*
>
> In the postgres dockerfile, it _is_ appending the version 12 to the
> sources list:
>
> root@fb7c949f82a0:/# cat /etc/apt/sources.list.d/pgdg.list
>
> debhttp://apt.postgresql.org/pub/repos/apt/  buster-pgdg main 12
>
>
> However I am still not seeing that version show up.  If I remove 'main',
> leaving just 12, no versions show up as coming from the postgres repo at
> all.  Am I missing something else here?

Yeah not working for me either. Probably means one of the packagers will
need to chime in.
>
> -Nick
>


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Missing libpq-dev version in buster-pgdg?

Nick Aldwin
Thanks for the reply.  Should I post to the separate hackers list, or wait for someone to chime in here?

FWIW, I am able to access older v12 libpq-dev by using the archive apt list: https://apt-archive.postgresql.org/ -- so we will do that going forward until this is resolved.

-Nick

On Wed, Oct 7, 2020 at 3:23 PM Adrian Klaver <[hidden email]> wrote:
On 10/7/20 12:02 PM, Nick Aldwin wrote:
> Hi Adrian,
>
> The FAQ you linked to says the following:
>
>  > If you really want to use a different version, the packages are
> available in separate archive components named after the PostgreSQL
> major version. Append that version after "main" in your sources.list.
> For example, if you wanted 9.0's libpq5 on Debian Squeeze, use this: deb
> http://apt.postgresql.org/pub/repos/apt squeeze-pgdg main *9.0*
>
> In the postgres dockerfile, it _is_ appending the version 12 to the
> sources list:
>
> root@fb7c949f82a0:/# cat /etc/apt/sources.list.d/pgdg.list
>
> debhttp://apt.postgresql.org/pub/repos/apt/  buster-pgdg main 12
>
>
> However I am still not seeing that version show up.  If I remove 'main',
> leaving just 12, no versions show up as coming from the postgres repo at
> all.  Am I missing something else here?

Yeah not working for me either. Probably means one of the packagers will
need to chime in.
>
> -Nick
>


--
Adrian Klaver
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Missing libpq-dev version in buster-pgdg?

Adrian Klaver-4
On 10/7/20 12:34 PM, Nick Aldwin wrote:
> Thanks for the reply.  Should I post to the separate hackers list, or
> wait for someone to chime in here?

There is the APT issue tracker(you will need community account to access):

https://redmine.postgresql.org/projects/pgapt/issues

or the APT packaging list:

https://www.postgresql.org/list/pgsql-pkg-debian/

>
> FWIW, I am able to access older v12 libpq-dev by using the archive apt
> list: https://apt-archive.postgresql.org/ -- so we will do that going
> forward until this is resolved.
>
> -Nick
>
> On Wed, Oct 7, 2020 at 3:23 PM Adrian Klaver <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     On 10/7/20 12:02 PM, Nick Aldwin wrote:
>      > Hi Adrian,
>      >
>      > The FAQ you linked to says the following:
>      >
>      >  > If you really want to use a different version, the packages are
>      > available in separate archive components named after the PostgreSQL
>      > major version. Append that version after "main" in your
>     sources.list.
>      > For example, if you wanted 9.0's libpq5 on Debian Squeeze, use
>     this: deb
>      > http://apt.postgresql.org/pub/repos/apt squeeze-pgdg main *9.0*
>      >
>      > In the postgres dockerfile, it _is_ appending the version 12 to the
>      > sources list:
>      >
>      > root@fb7c949f82a0:/# cat /etc/apt/sources.list.d/pgdg.list
>      >
>      > debhttp://apt.postgresql.org/pub/repos/apt/
>     <http://apt.postgresql.org/pub/repos/apt/>  buster-pgdg main 12
>      >
>      >
>      > However I am still not seeing that version show up.  If I remove
>     'main',
>      > leaving just 12, no versions show up as coming from the postgres
>     repo at
>      > all.  Am I missing something else here?
>
>     Yeah not working for me either. Probably means one of the packagers
>     will
>     need to chime in.
>      >
>      > -Nick
>      >
>
>
>     --
>     Adrian Klaver
>     [hidden email] <mailto:[hidden email]>
>


--
Adrian Klaver
[hidden email]