Need to confirm jdk/Java version required?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Need to confirm jdk/Java version required?

Mayur Mundada
Hello Team,

This is Mayur and I am  learning postgresql . So just need to confirm about jdk and java versions required for postgresql server .

Do we need Jdk/java for postgresql server? If yes then please let me know the version comparability with postgresql version 9/10/11/12.

Thanks and Regards
Mayur Mundada
9860900093
Reply | Threaded
Open this post in threaded view
|

Re: Need to confirm jdk/Java version required?

Thomas Kellerer-4
Mayur Mundada schrieb am 23.06.2020 um 16:43:
> This is Mayur and I am  learning postgresql . So just need to confirm about jdk and java versions required for postgresql server .
>
> Do we need Jdk/java for postgresql server? If yes then please let me know the version comparability with postgresql version 9/10/11/12.

The Postgres server does not need Java at all.

Thomas



Reply | Threaded
Open this post in threaded view
|

Re: Need to confirm jdk/Java version required?

David G Johnston
In reply to this post by Mayur Mundada
On Tue, Jun 23, 2020 at 8:46 AM Mayur Mundada <[hidden email]> wrote:
Do we need Jdk/java for postgresql server? If yes then please let me know the version comparability with postgresql version 9/10/11/12.

No, the PostgreSQL server does not require Java.  There are some third-party extensions that make using Java within client application code in the server possible.

David J.