Pgpool2 Service Won't Start

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Pgpool2 Service Won't Start

alanhi
Hi,

Hi, my pgpool status indicates that it failed even after trying to restart
the service.  What can I check to see what configurations may be causing
this?  Thanks.

Alan

● pgpool2.service - pgpool-II
   Loaded: loaded (/lib/systemd/system/pgpool2.service; enabled; vendor
preset: enabled)
   Active: failed (Result: exit-code) since Fri 2020-10-16 10:16:21 HST;
10min ago
     Docs: man:pgpool(8)
  Process: 20052 ExecStart=/usr/sbin/pgpool -n (code=exited, status=3)
 Main PID: 20052 (code=exited, status=3)





--
Sent from: https://www.postgresql-archive.org/PostgreSQL-general-f1843780.html


Reply | Threaded
Open this post in threaded view
|

Re: Pgpool2 Service Won't Start

Bo Peng
Hi,

On Fri, 16 Oct 2020 14:33:33 -0700 (MST)
alanhi <[hidden email]> wrote:

> Hi,
>
> Hi, my pgpool status indicates that it failed even after trying to restart
> the service.  What can I check to see what configurations may be causing
> this?  Thanks.
>
> Alan
>
> ● pgpool2.service - pgpool-II
>    Loaded: loaded (/lib/systemd/system/pgpool2.service; enabled; vendor
> preset: enabled)
>    Active: failed (Result: exit-code) since Fri 2020-10-16 10:16:21 HST;
> 10min ago
>      Docs: man:pgpool(8)
>   Process: 20052 ExecStart=/usr/sbin/pgpool -n (code=exited, status=3)
>  Main PID: 20052 (code=exited, status=3)

You may go to https://www.pgpool.net/mailman/listinfo/pgpool-general to ask questions.
Could you share the result of "systemctl status pgpool" and pgpool log?
 
> --
> Sent from: https://www.postgresql-archive.org/PostgreSQL-general-f1843780.html
>
>


--
Bo Peng <[hidden email]>
SRA OSS, Inc. Japan


Reply | Threaded
Open this post in threaded view
|

Re: Pgpool2 Service Won't Start

alanhi
Hi Bo,

I replaced the pgpool.conf file with the original file, reconfigured and it
works now.  Interesting because it was pretty much the same settings after
reconfiguring again.  Must be a setting that I missed.

Thanks,
Alan


Bo Peng wrote
> Hi,
>
> On Fri, 16 Oct 2020 14:33:33 -0700 (MST)
> alanhi &lt;

> tnguyen3@

> &gt; wrote:
>
>> Hi,
>>
>> Hi, my pgpool status indicates that it failed even after trying to
>> restart
>> the service.  What can I check to see what configurations may be causing
>> this?  Thanks.
>>
>> Alan
>>
>> ● pgpool2.service - pgpool-II
>>    Loaded: loaded (/lib/systemd/system/pgpool2.service; enabled; vendor
>> preset: enabled)
>>    Active: failed (Result: exit-code) since Fri 2020-10-16 10:16:21 HST;
>> 10min ago
>>      Docs: man:pgpool(8)
>>   Process: 20052 ExecStart=/usr/sbin/pgpool -n (code=exited, status=3)
>>  Main PID: 20052 (code=exited, status=3)
>
> You may go to https://www.pgpool.net/mailman/listinfo/pgpool-general to
> ask questions.
> Could you share the result of "systemctl status pgpool" and pgpool log?
>  
>> --
>> Sent from:
>> https://www.postgresql-archive.org/PostgreSQL-general-f1843780.html
>>
>>
>
>
> --
> Bo Peng &lt;

> pengbo@.co

> &gt;
> SRA OSS, Inc. Japan


Bo Peng wrote
> Hi,
>
> On Fri, 16 Oct 2020 14:33:33 -0700 (MST)
> alanhi &lt;

> tnguyen3@

> &gt; wrote:
>
>> Hi,
>>
>> Hi, my pgpool status indicates that it failed even after trying to
>> restart
>> the service.  What can I check to see what configurations may be causing
>> this?  Thanks.
>>
>> Alan
>>
>> ● pgpool2.service - pgpool-II
>>    Loaded: loaded (/lib/systemd/system/pgpool2.service; enabled; vendor
>> preset: enabled)
>>    Active: failed (Result: exit-code) since Fri 2020-10-16 10:16:21 HST;
>> 10min ago
>>      Docs: man:pgpool(8)
>>   Process: 20052 ExecStart=/usr/sbin/pgpool -n (code=exited, status=3)
>>  Main PID: 20052 (code=exited, status=3)
>
> You may go to https://www.pgpool.net/mailman/listinfo/pgpool-general to
> ask questions.
> Could you share the result of "systemctl status pgpool" and pgpool log?
>  
>> --
>> Sent from:
>> https://www.postgresql-archive.org/PostgreSQL-general-f1843780.html
>>
>>
>
>
> --
> Bo Peng &lt;

> pengbo@.co

> &gt;
> SRA OSS, Inc. Japan


Bo Peng wrote
> Hi,
>
> On Fri, 16 Oct 2020 14:33:33 -0700 (MST)
> alanhi &lt;

> tnguyen3@

> &gt; wrote:
>
>> Hi,
>>
>> Hi, my pgpool status indicates that it failed even after trying to
>> restart
>> the service.  What can I check to see what configurations may be causing
>> this?  Thanks.
>>
>> Alan
>>
>> ● pgpool2.service - pgpool-II
>>    Loaded: loaded (/lib/systemd/system/pgpool2.service; enabled; vendor
>> preset: enabled)
>>    Active: failed (Result: exit-code) since Fri 2020-10-16 10:16:21 HST;
>> 10min ago
>>      Docs: man:pgpool(8)
>>   Process: 20052 ExecStart=/usr/sbin/pgpool -n (code=exited, status=3)
>>  Main PID: 20052 (code=exited, status=3)
>
> You may go to https://www.pgpool.net/mailman/listinfo/pgpool-general to
> ask questions.
> Could you share the result of "systemctl status pgpool" and pgpool log?
>  
>> --
>> Sent from:
>> https://www.postgresql-archive.org/PostgreSQL-general-f1843780.html
>>
>>
>
>
> --
> Bo Peng &lt;

> pengbo@.co

> &gt;
> SRA OSS, Inc. Japan





--
Sent from: https://www.postgresql-archive.org/PostgreSQL-general-f1843780.html