PostGIS 3.0 dependency error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

PostGIS 3.0 dependency error

Joe McEttrick
Greetings,

I'm seeing a transitive dependency issue in the pgdg yum repos when installing postgis30 packages.

sudo yum install postgis30_10-utils

...

 -> Processing Dependency: sqlite-libs >= 3.7 for package: proj61-6.1.0-1.rhel7.x86_64
--> Finished Dependency Resolution
Error: Package: proj61-6.1.0-1.rhel7.x86_64 (pgdg10)
          Requires: sqlite-libs >= 3.7

This is on CentOS 7. I'm seeing the same issue with the postgis30_11 package. Anyone have thoughts on how to get the proj61 dependency fixed? 

Forcing the dependency to install has worked so far as a workaround, but this is not ideal obviously.

sudo rpm -Uvh --nodeps proj61-6.1.0-1.rhel7.x86_64.rpm


Thanks in advance,
Joe
Reply | Threaded
Open this post in threaded view
|

Re: PostGIS 3.0 dependency error

James Cassell
On Tue, Sep 10, 2019, at 5:52 PM, Joe McEttrick wrote:

> Greetings,
>
> I'm seeing a transitive dependency issue in the pgdg yum repos when
> installing postgis30 packages.
>
> sudo yum install postgis30_10-utils
>
> ...
>
>  -> Processing Dependency: sqlite-libs >= 3.7 for package:
> proj61-6.1.0-1.rhel7.x86_64
> --> Finished Dependency Resolution
> Error: Package: proj61-6.1.0-1.rhel7.x86_64 (pgdg10)
>  Requires: sqlite-libs >= 3.7
>
> This is on CentOS 7. I'm seeing the same issue with the postgis30_11
> package. Anyone have thoughts on how to get the proj61 dependency
> fixed?
>

I can confirm this issue on RHEL 7.7.

V/r,
James Cassell

> Forcing the dependency to install has worked so far as a workaround,
> but this is not ideal obviously.
>
> sudo rpm -Uvh --nodeps proj61-6.1.0-1.rhel7.x86_64.rpm
>
>
> Thanks in advance,
> Joe