Problem in starting pgagent after installation in ubuntu

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem in starting pgagent after installation in ubuntu

pavan95
Hi Community,

The below is the link I'm following to install pgagent. My doubt is does
pgagent look for an already installed pgadmin? Else can it be installed
separately?

Link:
"https://www.tutorialdba.com/2017/09/how-to-schedule-postgresql-jobs-using.html"

The below is the error I'm facing while trying to run the pgAgent daemon.

--While I have given hostaddr as localhost
root@pgdbsrv2:~/backups# pgagent hostaddr=localhost dbname=postgres
user=postgres
root@pgdbsrv2:~/backups# Tue Apr 23 15:28:38 2019 WARNING: Couldn't create
the primary connection [Attempt #1]
Tue Apr 23 15:28:43 2019 WARNING: Couldn't create the primary connection
[Attempt #2]
Tue Apr 23 15:28:48 2019 WARNING: Couldn't create the primary connection
[Attempt #3]
Tue Apr 23 15:28:53 2019 WARNING: Couldn't create the primary connection
[Attempt #4]
Tue Apr 23 15:28:58 2019 WARNING: Couldn't create the primary connection
[Attempt #5]
Tue Apr 23 15:29:03 2019 WARNING: Couldn't create the primary connection
[Attempt #6]
Tue Apr 23 15:29:08 2019 WARNING: Couldn't create the primary connection
[Attempt #7]
Tue Apr 23 15:29:13 2019 WARNING: Couldn't create the primary connection
[Attempt #8]
Tue Apr 23 15:29:18 2019 WARNING: Couldn't create the primary connection
[Attempt #9]
Tue Apr 23 15:29:23 2019 WARNING: Couldn't create the primary connection
[Attempt #10]
Tue Apr 23 15:29:23 2019 ERROR: Stopping pgAgent: Couldn't establish the
primary connection with the database server.

--While I given hostaddr as "127.0.0.1"

root@pgdbsrv2:~/backups# pgagent hostaddr=127.0.0.1 dbname=postgres
user=postgres
root@pgdbsrv2:~/backups# Tue Apr 23 15:29:40 2019 ERROR: Unsupported schema
version: 3. Version 4 is required - please run pgagent_upgrade.sql.

And when I type "which pgagent" it is showing as /usr/bin/pgagent

Could you please help me where I'm heading wrong?  Looking forward to hear
from you.

Regards,
Pavan



--
Sent from: http://www.postgresql-archive.org/PostgreSQL-admin-f2076596.html