RPM dependency on pg_partman12 fails

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

RPM dependency on pg_partman12 fails

Peter Krefting
Hi!

We are using the Partition Manager (pg_partman) in our software, and
to make sure the correct version is installed, our RPM (CentOS 7) has
declared a dependency on the pg_partman12 package.

However, the latest update to the package renames it without a
Provides on the old name, so a "yum update" now fails with an error:

Error: Package: XXXX
            Requires: pg_partman12
            Removing: pg_partman12-4.4.0-1.rhel7.x86_64 (@/pg_partman12-4.4.0-1.rhel7.x86_64)
                pg_partman12 = 4.4.0-1.rhel7
            Obsoleted By: pg_partman_12-4.4.1-1.rhel7.x86_64 (pgdg12)
                Not found
            Available: pg_partman12-4.2.0-1.rhel7.1.x86_64 (pgdg12)
                pg_partman12 = 4.2.0-1.rhel7.1
            Available: pg_partman12-4.3.0-1.rhel7.x86_64 (pgdg12)
                pg_partman12 = 4.3.0-1.rhel7
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest

Is this an error in the pg_partman package, or are we declaring the
dependency incorrectly on our end?

--
\\// Peter - http://www.softwolves.pp.se/