Updating postgres 7.4.5 to 8 via cygwin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Updating postgres 7.4.5 to 8 via cygwin

Nick Texidor
Hi,

I was wondering whether someone can help me.   I already have postgres 7.4.5 running under cygwin on my web server, and I've looked into installing the native version of 8, but it looks like there is a bit of dumping/importing of database to be done.   I noticed that postgres 8 is available under cygwin, and it came up as an update.  If I install it through cygwin, is there any messing around with databases to be done?  Is that an easier option than installing the native version and moving from a cygwin version?

Thank you

Nick


Reply | Threaded
Open this post in threaded view
|

Re: Updating postgres 7.4.5 to 8 via cygwin

Reini Urban
Nick Texidor schrieb:
> I was wondering whether someone can help me.   I already have postgres
> 7.4.5 running under cygwin on my web server, and I've looked into
> installing the native version of 8, but it looks like there is a bit of
> dumping/importing of database to be done.   I noticed that postgres 8 is
> available under cygwin, and it came up as an update.  If I install it
> through cygwin, is there any messing around with databases to be done?  
> Is that an easier option than installing the native version and moving
> from a cygwin version?

Installing a native version will create a new database.
Upgrading cygwin to 8 will leave you with a non-accessible database.

So if you need the data from the old database, you MUST export it.

See the cygwin announcement, which describes it in detail.
http://article.gmane.org/gmane.os.cygwin.announce/2310

Which says:
Before you upgrade a postgresql package to a new new major or
minor version (7.4 => 8.0 => 8.1 => 8.2), be sure to dump all your data
before!
With the new package you will not be able to access your old databases.
=> http://www.postgresql.org/docs/8.2/static/app-pg-dumpall.html
Minor subrelease updates (e.g. 8.2.4 to 8.2.5) can safely access the
same database.
--
Reini Urban
http://phpwiki.org/  http://murbreak.at/

--
Sent via pgsql-cygwin mailing list ([hidden email])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-cygwin