What version postgresql libpqxx

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

What version postgresql libpqxx

Gavin M2301
Hi all

I installed 12.0 development branch on postgresql with mingw. It is too new to use with libpqxx. Anyone have a recent version of postgresql working with libpqxx? What is a good version? 

Thnx roboloki
Reply | Threaded
Open this post in threaded view
|

Fwd: What version postgresql libpqxx

Gavin M2301
Hi all-
I decided to look around. 11.0 got released 2 years ago. I decided to go with 11.x postgresql with 7.0 libpqxx. The stable branch came out around same time as 11.0 so I will go with probably 11.3 and 7.0.

Thnx.  Roboloki

---------- Forwarded message ---------
From:Gavin M2301 <[hidden email]>
Date: Mon, May 20, 2019, 1:18 PM
Subject: What version postgresql libpqxx
To: <[hidden email]>


Hi all

I installed 12.0 development branch on postgresql with mingw. It is too new to use with libpqxx. Anyone have a recent version of postgresql working with libpqxx? What is a good version? 

Thnx roboloki
Reply | Threaded
Open this post in threaded view
|

RE: What version postgresql libpqxx

Stephen Froehlich

Hi Roboloki,

 

Each new version of pg releases in mid-October … and pg11 came out on Oct 18, 2018 (https://www.postgresql.org/docs/11/release-11.html) … so each current version of PostgreSQL is only current for about a year … though support continues for several years for each version.

 

In general, libpqxx and similar libraries for other languages are not very sensitive to the version running on the server but instead implement parts of the PostgreSQL protocol that aren’t changing … its not where the innovation typically is anyway. What changes is these libraries from version to version is typically the C++ - facing API.

As for libpqxx, unless you need a feature in 7.0, my instinct would be to go with the most recent stable release (6.4.4) and watch out for deprecation warnings.

--Stephen

 

From: Gavin M2301 <[hidden email]>
Sent: Monday, May 20, 2019 12:44 PM
To: [hidden email]
Subject: Fwd: What version postgresql libpqxx

 

Hi all-

I decided to look around. 11.0 got released 2 years ago. I decided to go with 11.x postgresql with 7.0 libpqxx. The stable branch came out around same time as 11.0 so I will go with probably 11.3 and 7.0.

 

Thnx.  Roboloki

 

---------- Forwarded message ---------
From:Gavin M2301 <[hidden email]>
Date: Mon, May 20, 2019, 1:18 PM
Subject: What version postgresql libpqxx
To: <[hidden email]>

 

Hi all

 

I installed 12.0 development branch on postgresql with mingw. It is too new to use with libpqxx. Anyone have a recent version of postgresql working with libpqxx? What is a good version? 

 

Thnx roboloki

Reply | Threaded
Open this post in threaded view
|

Re: What version postgresql libpqxx

Gavin M2301
Hi Stephen-
On github it said stable was 5.x. I will look for the more recent version you mention. Many thnx!
Roboloki

On Mon, May 20, 2019, 3:31 PM Stephen Froehlich <[hidden email]> wrote:

Hi Roboloki,

 

Each new version of pg releases in mid-October … and pg11 came out on Oct 18, 2018 (https://www.postgresql.org/docs/11/release-11.html) … so each current version of PostgreSQL is only current for about a year … though support continues for several years for each version.

 

In general, libpqxx and similar libraries for other languages are not very sensitive to the version running on the server but instead implement parts of the PostgreSQL protocol that aren’t changing … its not where the innovation typically is anyway. What changes is these libraries from version to version is typically the C++ - facing API.

As for libpqxx, unless you need a feature in 7.0, my instinct would be to go with the most recent stable release (6.4.4) and watch out for deprecation warnings.

--Stephen

 

From: Gavin M2301 <[hidden email]>
Sent: Monday, May 20, 2019 12:44 PM
To: [hidden email]
Subject: Fwd: What version postgresql libpqxx

 

Hi all-

I decided to look around. 11.0 got released 2 years ago. I decided to go with 11.x postgresql with 7.0 libpqxx. The stable branch came out around same time as 11.0 so I will go with probably 11.3 and 7.0.

 

Thnx.  Roboloki

 

---------- Forwarded message ---------
From:Gavin M2301 <[hidden email]>
Date: Mon, May 20, 2019, 1:18 PM
Subject: What version postgresql libpqxx
To: <[hidden email]>

 

Hi all

 

I installed 12.0 development branch on postgresql with mingw. It is too new to use with libpqxx. Anyone have a recent version of postgresql working with libpqxx? What is a good version? 

 

Thnx roboloki

Reply | Threaded
Open this post in threaded view
|

RE: What version postgresql libpqxx

Stephen Froehlich

I’m an R user … I could be completely wrong about libpqxx release is stable … I was referencing this: https://github.com/jtv/libpqxx/releases

 

--Stephen

 

From: Gavin M2301 <[hidden email]>
Sent: Monday, May 20, 2019 5:17 PM
To: [hidden email]
Subject: Re: What version postgresql libpqxx

 

Hi Stephen-

On github it said stable was 5.x. I will look for the more recent version you mention. Many thnx!

Roboloki

 

On Mon, May 20, 2019, 3:31 PM Stephen Froehlich <[hidden email]> wrote:

Hi Roboloki,

 

Each new version of pg releases in mid-October … and pg11 came out on Oct 18, 2018 (https://www.postgresql.org/docs/11/release-11.html) … so each current version of PostgreSQL is only current for about a year … though support continues for several years for each version.

 

In general, libpqxx and similar libraries for other languages are not very sensitive to the version running on the server but instead implement parts of the PostgreSQL protocol that aren’t changing … its not where the innovation typically is anyway. What changes is these libraries from version to version is typically the C++ - facing API.

As for libpqxx, unless you need a feature in 7.0, my instinct would be to go with the most recent stable release (6.4.4) and watch out for deprecation warnings.

--Stephen

 

From: Gavin M2301 <[hidden email]>
Sent: Monday, May 20, 2019 12:44 PM
To: [hidden email]
Subject: Fwd: What version postgresql libpqxx

 

Hi all-

I decided to look around. 11.0 got released 2 years ago. I decided to go with 11.x postgresql with 7.0 libpqxx. The stable branch came out around same time as 11.0 so I will go with probably 11.3 and 7.0.

 

Thnx.  Roboloki

 

---------- Forwarded message ---------
From:Gavin M2301 <[hidden email]>
Date: Mon, May 20, 2019, 1:18 PM
Subject: What version postgresql libpqxx
To: <[hidden email]>

 

Hi all

 

I installed 12.0 development branch on postgresql with mingw. It is too new to use with libpqxx. Anyone have a recent version of postgresql working with libpqxx? What is a good version? 

 

Thnx roboloki