authentication fail

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

authentication fail

Michael Eschweiler-2
Hi there,

I am using postgresql 12 on Linux opensuse Leap 15.2.
In 'former times' with my postgresql-db I used pgadmin3. It was nice and
tiny, and I was happy.
Now, with pgadmin4 I am not able to connect to my server. There is no
problem with pgsql nor with knoda even from another computer but with
pgadmin4 I always get an authentication error. In pg_hba.conf I changed
all connections to 'trust' - but no way!
Is there a verbose-mode for pgadmin4 in order to see what is happening?

Thanks in advance.
Best regards,
Michael

By the way: Is there a way to get rid of this annoying nag screen
telling me every time I start pgadmin that there is a new version? My
version came with the distro


Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Khushboo Vashi
Hi,

On Tue, Jan 12, 2021 at 12:39 AM Michael Eschweiler <[hidden email]> wrote:
Hi there,

I am using postgresql 12 on Linux opensuse Leap 15.2.
In 'former times' with my postgresql-db I used pgadmin3. It was nice and
tiny, and I was happy.
Now, with pgadmin4 I am not able to connect to my server. There is no
problem with pgsql nor with knoda even from another computer but with
pgadmin4 I always get an authentication error. In pg_hba.conf I changed
all connections to 'trust' - but no way!
Is there a verbose-mode for pgadmin4 in order to see what is happening?

It should work with pgAdmin as you have no problem with psql.
You can enable logging to check the issue, please refer https://www.pgadmin.org/faq/#8 to enable it.
Also, you can provide the screen-shot of the error you are getting, so we can help you.
 
Thanks in advance.
Best regards,
Michael

By the way: Is there a way to get rid of this annoying nag screen
telling me every time I start pgadmin that there is a new version? My
version came with the distro
You can disable the version check by setting UPGRADE_CHECK_ENABLED parameter to False, refer https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html for the. same.

Thanks,
Khushboo
Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Michael Eschweiler-2
Hi Khushboo,

Am 12.01.21 um 05:26 schrieb Khushboo Vashi:

> Hi,
>
> On Tue, Jan 12, 2021 at 12:39 AM Michael Eschweiler
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi there,
>
>     I am using postgresql 12 on Linux opensuse Leap 15.2.
>     In 'former times' with my postgresql-db I used pgadmin3. It was nice and
>     tiny, and I was happy.
>     Now, with pgadmin4 I am not able to connect to my server. There is no
>     problem with pgsql nor with knoda even from another computer but with
>     pgadmin4 I always get an authentication error. In pg_hba.conf I changed
>     all connections to 'trust' - but no way!
>     Is there a verbose-mode for pgadmin4 in order to see what is happening?
>
> It should work with pgAdmin as you have no problem with psql.
> You can enable logging to check the issue, please
> refer https://www.pgadmin.org/faq/#8 <https://www.pgadmin.org/faq/#8> to
> enable it.
> Also, you can provide the screen-shot of the error you are getting, so
> we can help you.
>  
>
>     Thanks in advance.
>     Best regards,
>     Michael
>
>     By the way: Is there a way to get rid of this annoying nag screen
>     telling me every time I start pgadmin that there is a new version? My
>     version came with the distro
>
> You can disable the version check by setting UPGRADE_CHECK_ENABLED
> parameter to False,
> refer https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
> <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html> for the. same.
>
Thanks for the hints and sorry for the delay. Here is what I did after
having deleted everything related to pgadmin in my user directory:
First I created the file config_local.py following the advice at
https://www.pgadmin.org/faq/#8
Then I started pgAdmin4 on a console. During the start I get this message:
--- snip ---
Invalid MIT-MAGIC-COOKIE-1 keyPython path:
"/usr/lib/python3.6/site-packages:/usr/lib64/python3.6/site-packages"
Python Home:  ""
Webapp path:  "/usr/lib/python3.6/site-packages/pgadmin4-web/pgAdmin4.py"
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

 * Serving Flask app "pgadmin" (lazy loading)
 * Environment: production
   WARNING: Do not use the development server in a production environment.
   Use a production WSGI server instead.
 * Debug mode: off
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid
MIT-MAGIC-COOKIE-1 key
--- snip ---
(don't know if this is ok...)

The browser window with pgAdmin4 opened. In order to see what happened
please revise the attached pdf. As you will see, my trial ended up with
... nothing.

Looking through the pgAdmin4.startup.log (attached) I didn't find
nothing special - this seems ok but I must confess that don't know how
to interprete the messages in pgadmin4.log (attached) and if there is
any hint in order to see what went wrong.

I would appreciate any help in order to get pgAdmin4 working.

Best regards,
Michael

P.S.: The authentication configuring in pg_hba.conf:

# "local" is for Unix domain socket connections only
local   all   all                                     trust
# IPv4 local connections:
host    all   all             127.0.0.1/32            md5
host    all   username        xxx.xxx.xx.0/24         trust

(the last line I introduced so that my normal user can access the
database remotely from different machines in my local network.)

pgadmin_d.pdf (1M) Download Attachment
.pgAdmin4.startup.log (1K) Download Attachment
pgadmin4.log (100K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Khushboo Vashi
Hi,

Looks like you are running pgAdmin 4 version 4.1 and the latest version is 4.30. Please upgrade the pgAdmin to the latest and your issue will be resolved.

Thanks,
Khushboo


On Sat, Jan 30, 2021 at 1:58 PM Michael Eschweiler <[hidden email]> wrote:
Hi Khushboo,

Am 12.01.21 um 05:26 schrieb Khushboo Vashi:
> Hi,
>
> On Tue, Jan 12, 2021 at 12:39 AM Michael Eschweiler
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi there,
>
>     I am using postgresql 12 on Linux opensuse Leap 15.2.
>     In 'former times' with my postgresql-db I used pgadmin3. It was nice and
>     tiny, and I was happy.
>     Now, with pgadmin4 I am not able to connect to my server. There is no
>     problem with pgsql nor with knoda even from another computer but with
>     pgadmin4 I always get an authentication error. In pg_hba.conf I changed
>     all connections to 'trust' - but no way!
>     Is there a verbose-mode for pgadmin4 in order to see what is happening?
>
> It should work with pgAdmin as you have no problem with psql.
> You can enable logging to check the issue, please
> refer https://www.pgadmin.org/faq/#8 <https://www.pgadmin.org/faq/#8> to
> enable it.
> Also, you can provide the screen-shot of the error you are getting, so
> we can help you.
>  
>
>     Thanks in advance.
>     Best regards,
>     Michael
>
>     By the way: Is there a way to get rid of this annoying nag screen
>     telling me every time I start pgadmin that there is a new version? My
>     version came with the distro
>
> You can disable the version check by setting UPGRADE_CHECK_ENABLED
> parameter to False,
> refer https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
> <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html> for the. same.
>

Thanks for the hints and sorry for the delay. Here is what I did after
having deleted everything related to pgadmin in my user directory:
First I created the file config_local.py following the advice at
https://www.pgadmin.org/faq/#8
Then I started pgAdmin4 on a console. During the start I get this message:
--- snip ---
Invalid MIT-MAGIC-COOKIE-1 keyPython path:
"/usr/lib/python3.6/site-packages:/usr/lib64/python3.6/site-packages"
Python Home:  ""
Webapp path:  "/usr/lib/python3.6/site-packages/pgadmin4-web/pgAdmin4.py"
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

 * Serving Flask app "pgadmin" (lazy loading)
 * Environment: production
   WARNING: Do not use the development server in a production environment.
   Use a production WSGI server instead.
 * Debug mode: off
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid
MIT-MAGIC-COOKIE-1 key
--- snip ---
(don't know if this is ok...)

The browser window with pgAdmin4 opened. In order to see what happened
please revise the attached pdf. As you will see, my trial ended up with
... nothing.

Looking through the pgAdmin4.startup.log (attached) I didn't find
nothing special - this seems ok but I must confess that don't know how
to interprete the messages in pgadmin4.log (attached) and if there is
any hint in order to see what went wrong.

I would appreciate any help in order to get pgAdmin4 working.

Best regards,
Michael

P.S.: The authentication configuring in pg_hba.conf:

# "local" is for Unix domain socket connections only
local   all   all                                     trust
# IPv4 local connections:
host    all   all             127.0.0.1/32            md5
host    all   username        xxx.xxx.xx.0/24         trust

(the last line I introduced so that my normal user can access the
database remotely from different machines in my local network.)
Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Michael Eschweiler-2
Hi,

Am 01.02.21 um 05:50 schrieb Khushboo Vashi:

>
> Looks like you are running pgAdmin 4 version 4.1 and the latest version
> is 4.30. Please upgrade the pgAdmin to the latest and your issue will be
> resolved.

Seems that I must be VERY patient. I am working with opensuse Leap 15.2.
The version of paAdmin4 which comes with the distro is this version
(4.1).  Even the rolling release distro (Tumbleweed) only offers the
version 4.29.
At:
https://ftp.postgresql.org/pub/pgadmin/pgadmin4
I found the rpm-Package für Red Hat and Fedora. Do you have any
information if this works on opensuse too?


Thanks in advance,
Michael

>
> Thanks,
> Khushboo
>
>
> On Sat, Jan 30, 2021 at 1:58 PM Michael Eschweiler
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi Khushboo,
>
>     Am 12.01.21 um 05:26 schrieb Khushboo Vashi:
>     > Hi,
>     >
>     > On Tue, Jan 12, 2021 at 12:39 AM Michael Eschweiler
>     > <[hidden email] <mailto:[hidden email]>
>     <mailto:[hidden email]
>     <mailto:[hidden email]>>> wrote:
>     >
>     >     Hi there,
>     >
>     >     I am using postgresql 12 on Linux opensuse Leap 15.2.
>     >     In 'former times' with my postgresql-db I used pgadmin3. It
>     was nice and
>     >     tiny, and I was happy.
>     >     Now, with pgadmin4 I am not able to connect to my server.
>     There is no
>     >     problem with pgsql nor with knoda even from another computer
>     but with
>     >     pgadmin4 I always get an authentication error. In pg_hba.conf
>     I changed
>     >     all connections to 'trust' - but no way!
>     >     Is there a verbose-mode for pgadmin4 in order to see what is
>     happening?
>     >
>     > It should work with pgAdmin as you have no problem with psql.
>     > You can enable logging to check the issue, please
>     > refer https://www.pgadmin.org/faq/#8
>     <https://www.pgadmin.org/faq/#8> <https://www.pgadmin.org/faq/#8
>     <https://www.pgadmin.org/faq/#8>> to
>     > enable it.
>     > Also, you can provide the screen-shot of the error you are getting, so
>     > we can help you.
>     >  
>     >
>     >     Thanks in advance.
>     >     Best regards,
>     >     Michael
>     >
>     >     By the way: Is there a way to get rid of this annoying nag screen
>     >     telling me every time I start pgadmin that there is a new
>     version? My
>     >     version came with the distro
>     >
>     > You can disable the version check by setting UPGRADE_CHECK_ENABLED
>     > parameter to False,
>     > refer https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
>     <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html>
>     > <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
>     <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html>> for
>     the. same.
>     >
>
>     Thanks for the hints and sorry for the delay. Here is what I did after
>     having deleted everything related to pgadmin in my user directory:
>     First I created the file config_local.py following the advice at
>     https://www.pgadmin.org/faq/#8 <https://www.pgadmin.org/faq/#8>
>     Then I started pgAdmin4 on a console. During the start I get this
>     message:
>     --- snip ---
>     Invalid MIT-MAGIC-COOKIE-1 keyPython path:
>     "/usr/lib/python3.6/site-packages:/usr/lib64/python3.6/site-packages"
>     Python Home:  ""
>     Webapp path: 
>     "/usr/lib/python3.6/site-packages/pgadmin4-web/pgAdmin4.py"
>     NOTE: Configuring authentication for DESKTOP mode.
>     pgAdmin 4 - Application Initialisation
>     ======================================
>
>      * Serving Flask app "pgadmin" (lazy loading)
>      * Environment: production
>        WARNING: Do not use the development server in a production
>     environment.
>        Use a production WSGI server instead.
>      * Debug mode: off
>     Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid
>     MIT-MAGIC-COOKIE-1 key
>     --- snip ---
>     (don't know if this is ok...)
>
>     The browser window with pgAdmin4 opened. In order to see what happened
>     please revise the attached pdf. As you will see, my trial ended up with
>     ... nothing.
>
>     Looking through the pgAdmin4.startup.log (attached) I didn't find
>     nothing special - this seems ok but I must confess that don't know how
>     to interprete the messages in pgadmin4.log (attached) and if there is
>     any hint in order to see what went wrong.
>
>     I would appreciate any help in order to get pgAdmin4 working.
>
>     Best regards,
>     Michael
>
>     P.S.: The authentication configuring in pg_hba.conf:
>
>     # "local" is for Unix domain socket connections only
>     local   all   all                                     trust
>     # IPv4 local connections:
>     host    all   all             127.0.0.1/32 <http://127.0.0.1/32>   
>             md5
>     host    all   username        xxx.xxx.xx.0/24         trust
>
>     (the last line I introduced so that my normal user can access the
>     database remotely from different machines in my local network.)
>


Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Edson Richter
May I suggest you to use dockerized pgAdmin?


Edson Richter
Soli Deo Gloria
Em 1 de fev de 2021, em 18:26, Michael Eschweiler <[hidden email]> escreveu:
Hi,

Am 01.02.21 um 05:50 schrieb Khushboo Vashi:


Looks like you are running pgAdmin 4 version 4.1 and the latest version
is 4.30. Please upgrade the pgAdmin to the latest and your issue will be
resolved.

Seems that I must be VERY patient. I am working with opensuse Leap 15.2.
The version of paAdmin4 which comes with the distro is this version
(4.1). Even the rolling release distro (Tumbleweed) only offers the
version 4.29.
At:
https://ftp.postgresql.org/pub/pgadmin/pgadmin4
I found the rpm-Package für Red Hat and Fedora. Do you have any
information if this works on opensuse too?


Thanks in advance,
Michael


Thanks,
Khushboo


On Sat, Jan 30, 2021 at 1:58 PM Michael Eschweiler
<[hidden email] <mailto:[hidden email]>> wrote:

Hi Khushboo,

Am 12.01.21 um 05:26 schrieb Khushboo Vashi:
Hi,

On Tue, Jan 12, 2021 at 12:39 AM Michael Eschweiler
<[hidden email] <mailto:[hidden email]>
<mailto:[hidden email]
<mailto:[hidden email]>>> wrote:

     Hi there,

     I am using postgresql 12 on Linux opensuse Leap 15.2.
     In 'former times' with my postgresql-db I used pgadmin3. It
was nice and
     tiny, and I was happy.
     Now, with pgadmin4 I am not able to connect to my server.
There is no
     problem with pgsql nor with knoda even from another computer
but with
     pgadmin4 I always get an authentication error. In pg_hba.conf
I changed
     all connections to 'trust' - but no way!
     Is there a verbose-mode for pgadmin4 in order to see what is
happening?

It should work with pgAdmin as you have no problem with psql.
You can enable logging to check the issue, please
refer https://www.pgadmin.org/faq/#8
<https://www.pgadmin.org/faq/#8> <https://www.pgadmin.org/faq/#8
<https://www.pgadmin.org/faq/#8>> to
enable it.
Also, you can provide the screen-shot of the error you are getting, so
we can help you.
 

     Thanks in advance.
     Best regards,
     Michael

     By the way: Is there a way to get rid of this annoying nag screen
     telling me every time I start pgadmin that there is a new
version? My
     version came with the distro

You can disable the version check by setting UPGRADE_CHECK_ENABLED
parameter to False,
refer https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
<https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html>
<https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
<https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html>> for
the. same.


Thanks for the hints and sorry for the delay. Here is what I did after
having deleted everything related to pgadmin in my user directory:
First I created the file config_local.py following the advice at
https://www.pgadmin.org/faq/#8 <https://www.pgadmin.org/faq/#8>
Then I started pgAdmin4 on a console. During the start I get this
message:
--- snip ---
Invalid MIT-MAGIC-COOKIE-1 keyPython path:
"/usr/lib/python3.6/site-packages:/usr/lib64/python3.6/site-packages"
Python Home:  ""
Webapp path: 
"/usr/lib/python3.6/site-packages/pgadmin4-web/pgAdmin4.py"
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation



 * Serving Flask app "pgadmin" (lazy loading)
 * Environment: production
   WARNING: Do not use the development server in a production
environment.
   Use a production WSGI server instead.
 * Debug mode: off
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid
MIT-MAGIC-COOKIE-1 key
--- snip ---
(don't know if this is ok...)

The browser window with pgAdmin4 opened. In order to see what happened
please revise the attached pdf. As you will see, my trial ended up with
... nothing.

Looking through the pgAdmin4.startup.log (attached) I didn't find
nothing special - this seems ok but I must confess that don't know how
to interprete the messages in pgadmin4.log (attached) and if there is
any hint in order to see what went wrong.

I would appreciate any help in order to get pgAdmin4 working.

Best regards,
Michael

P.S.: The authentication configuring in pg_hba.conf:

# "local" is for Unix domain socket connections only
local   all   all                                     trust
# IPv4 local connections:
host    all   all             127.0.0.1/32 <http://127.0.0.1/32>   
        md5
host    all   username        xxx.xxx.xx.0/24         trust

(the last line I introduced so that my normal user can access the
database remotely from different machines in my local network.)



Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Khushboo Vashi
In reply to this post by Michael Eschweiler-2
Hi,

On Tue, Feb 2, 2021 at 2:55 AM Michael Eschweiler <[hidden email]> wrote:
Hi,

Am 01.02.21 um 05:50 schrieb Khushboo Vashi:

>
> Looks like you are running pgAdmin 4 version 4.1 and the latest version
> is 4.30. Please upgrade the pgAdmin to the latest and your issue will be
> resolved.

Seems that I must be VERY patient. I am working with opensuse Leap 15.2.
The version of paAdmin4 which comes with the distro is this version
(4.1).  Even the rolling release distro (Tumbleweed) only offers the
version 4.29.
At:
https://ftp.postgresql.org/pub/pgadmin/pgadmin4
I found the rpm-Package für Red Hat and Fedora. Do you have any
information if this works on opensuse too?

We do not support OpenSuse. As an alternative, you can use other distributions from https://www.pgadmin.org/download/  like Python package or Docker Container.

Thanks,
Khushboo

Thanks in advance,
Michael

>
> Thanks,
> Khushboo
>
>
> On Sat, Jan 30, 2021 at 1:58 PM Michael Eschweiler
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi Khushboo,
>
>     Am 12.01.21 um 05:26 schrieb Khushboo Vashi:
>     > Hi,
>     >
>     > On Tue, Jan 12, 2021 at 12:39 AM Michael Eschweiler
>     > <[hidden email] <mailto:[hidden email]>
>     <mailto:[hidden email]
>     <mailto:[hidden email]>>> wrote:
>     >
>     >     Hi there,
>     >
>     >     I am using postgresql 12 on Linux opensuse Leap 15.2.
>     >     In 'former times' with my postgresql-db I used pgadmin3. It
>     was nice and
>     >     tiny, and I was happy.
>     >     Now, with pgadmin4 I am not able to connect to my server.
>     There is no
>     >     problem with pgsql nor with knoda even from another computer
>     but with
>     >     pgadmin4 I always get an authentication error. In pg_hba.conf
>     I changed
>     >     all connections to 'trust' - but no way!
>     >     Is there a verbose-mode for pgadmin4 in order to see what is
>     happening?
>     >
>     > It should work with pgAdmin as you have no problem with psql.
>     > You can enable logging to check the issue, please
>     > refer https://www.pgadmin.org/faq/#8
>     <https://www.pgadmin.org/faq/#8> <https://www.pgadmin.org/faq/#8
>     <https://www.pgadmin.org/faq/#8>> to
>     > enable it.
>     > Also, you can provide the screen-shot of the error you are getting, so
>     > we can help you.
>     >  
>     >
>     >     Thanks in advance.
>     >     Best regards,
>     >     Michael
>     >
>     >     By the way: Is there a way to get rid of this annoying nag screen
>     >     telling me every time I start pgadmin that there is a new
>     version? My
>     >     version came with the distro
>     >
>     > You can disable the version check by setting UPGRADE_CHECK_ENABLED
>     > parameter to False,
>     > refer https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
>     <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html>
>     > <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html
>     <https://www.pgadmin.org/docs/pgadmin4/4.29/config_py.html>> for
>     the. same.
>     >
>
>     Thanks for the hints and sorry for the delay. Here is what I did after
>     having deleted everything related to pgadmin in my user directory:
>     First I created the file config_local.py following the advice at
>     https://www.pgadmin.org/faq/#8 <https://www.pgadmin.org/faq/#8>
>     Then I started pgAdmin4 on a console. During the start I get this
>     message:
>     --- snip ---
>     Invalid MIT-MAGIC-COOKIE-1 keyPython path:
>     "/usr/lib/python3.6/site-packages:/usr/lib64/python3.6/site-packages"
>     Python Home:  ""
>     Webapp path: 
>     "/usr/lib/python3.6/site-packages/pgadmin4-web/pgAdmin4.py"
>     NOTE: Configuring authentication for DESKTOP mode.
>     pgAdmin 4 - Application Initialisation
>     ======================================
>
>      * Serving Flask app "pgadmin" (lazy loading)
>      * Environment: production
>        WARNING: Do not use the development server in a production
>     environment.
>        Use a production WSGI server instead.
>      * Debug mode: off
>     Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid
>     MIT-MAGIC-COOKIE-1 key
>     --- snip ---
>     (don't know if this is ok...)
>
>     The browser window with pgAdmin4 opened. In order to see what happened
>     please revise the attached pdf. As you will see, my trial ended up with
>     ... nothing.
>
>     Looking through the pgAdmin4.startup.log (attached) I didn't find
>     nothing special - this seems ok but I must confess that don't know how
>     to interprete the messages in pgadmin4.log (attached) and if there is
>     any hint in order to see what went wrong.
>
>     I would appreciate any help in order to get pgAdmin4 working.
>
>     Best regards,
>     Michael
>
>     P.S.: The authentication configuring in pg_hba.conf:
>
>     # "local" is for Unix domain socket connections only
>     local   all   all                                     trust
>     # IPv4 local connections:
>     host    all   all             127.0.0.1/32 <http://127.0.0.1/32>   
>             md5
>     host    all   username        xxx.xxx.xx.0/24         trust
>
>     (the last line I introduced so that my normal user can access the
>     database remotely from different machines in my local network.)
>
Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Michael Eschweiler-2
Hi,

Am 02.02.21 um 05:37 schrieb Khushboo Vashi:

> Hi,
>
> On Tue, Feb 2, 2021 at 2:55 AM Michael Eschweiler
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi,
>
>     Am 01.02.21 um 05:50 schrieb Khushboo Vashi:
>
>     >
>     > Looks like you are running pgAdmin 4 version 4.1 and the latest
>     version
>     > is 4.30. Please upgrade the pgAdmin to the latest and your issue
>     will be
>     > resolved.
>
>     Seems that I must be VERY patient. I am working with opensuse Leap 15.2.
>     The version of paAdmin4 which comes with the distro is this version
>     (4.1).  Even the rolling release distro (Tumbleweed) only offers the
>     version 4.29.
>     At:
>     https://ftp.postgresql.org/pub/pgadmin/pgadmin4
>     <https://ftp.postgresql.org/pub/pgadmin/pgadmin4>
>     I found the rpm-Package für Red Hat and Fedora. Do you have any
>     information if this works on opensuse too?
>
> We do not support OpenSuse. As an alternative, you can use other
> distributions from https://www.pgadmin.org/download/
> <https://www.pgadmin.org/download/>  like Python package or Docker
> Container.

Thanks for the hints. I would like to try with the docker container.
Therefore I installed docker and started docker daemon.
Perhaps I am too simple-hearted: I than copied the command indicated at
the web site: docker pull dpage/pgadmin4
I got the message 'Got permission denied while trying to connect to the
Docker daemon socket at unix:///var/run/docker.sock: Post
"http://%2Fvar%2Frun%2Fdocker.sock/v1.40/images/create?fromImage=dpage%2Fpgadmin4&tag=latest":
dial unix /var/run/docker.sock: connect: permission denied'
Do I have to register or do something else?

Thx in advance,
Michael


Reply | Threaded
Open this post in threaded view
|

Re: authentication fail

Khushboo Vashi
Hi,

On Wed, Feb 3, 2021 at 3:30 AM Michael Eschweiler <[hidden email]> wrote:
Hi,

Am 02.02.21 um 05:37 schrieb Khushboo Vashi:
> Hi,
>
> On Tue, Feb 2, 2021 at 2:55 AM Michael Eschweiler
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi,
>
>     Am 01.02.21 um 05:50 schrieb Khushboo Vashi:
>
>     >
>     > Looks like you are running pgAdmin 4 version 4.1 and the latest
>     version
>     > is 4.30. Please upgrade the pgAdmin to the latest and your issue
>     will be
>     > resolved.
>
>     Seems that I must be VERY patient. I am working with opensuse Leap 15.2.
>     The version of paAdmin4 which comes with the distro is this version
>     (4.1).  Even the rolling release distro (Tumbleweed) only offers the
>     version 4.29.
>     At:
>     https://ftp.postgresql.org/pub/pgadmin/pgadmin4
>     <https://ftp.postgresql.org/pub/pgadmin/pgadmin4>
>     I found the rpm-Package für Red Hat and Fedora. Do you have any
>     information if this works on opensuse too?
>
> We do not support OpenSuse. As an alternative, you can use other
> distributions from https://www.pgadmin.org/download/
> <https://www.pgadmin.org/download/>  like Python package or Docker
> Container.

Thanks for the hints. I would like to try with the docker container.
Therefore I installed docker and started docker daemon.
Perhaps I am too simple-hearted: I than copied the command indicated at
the web site: docker pull dpage/pgadmin4
I got the message 'Got permission denied while trying to connect to the
Docker daemon socket at unix:///var/run/docker.sock: Post
"http://%2Fvar%2Frun%2Fdocker.sock/v1.40/images/create?fromImage=dpage%2Fpgadmin4&tag=latest":
dial unix /var/run/docker.sock: connect: permission denied'
Do I have to register or do something else?

This is something related to your system. I googled the issue and found this, https://unix.stackexchange.com/questions/382262/cannot-start-docker-daemon-in-opensuse, it may help you.

Thanks,
Khushboo
 
Thx in advance,
Michael