install problem with extensions

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

install problem with extensions

stan-9
I am trying to build an extension, and I haveit installed on 2 machines,
but the ake install fails on a 3rd.  Tow of the machines are Ubuntu 18.04,
and it installs fine on one, and fails on the other.

Here is the make install output:

stan@ica-db:~/src/pg-libphonenumber$ sudo make install
/bin/mkdir -p '/usr/lib/postgresql/11/lib'
/bin/mkdir -p '/usr/share/postgresql/11/extension'
/bin/mkdir -p '/usr/share/postgresql/11/extension'
/usr/bin/install -c -m 755  pg_libphonenumber.so
'/usr/lib/postgresql/11/lib/pg_libphonenumber.so'
/usr/bin/install -c -m 644 .//pg_libphonenumber.control
'/usr/share/postgresql/11/extension/'
/usr/bin/install -c -m 644 .//sql/pg_libphonenumber--*.sql
'/usr/share/postgresql/11/extension/'
/bin/mkdir -p '/usr/lib/postgresql/11/lib/bitcode/pg_libphonenumber'
/bin/mkdir -p '/usr/lib/postgresql/11/lib/bitcode'/pg_libphonenumber/src/
/usr/bin/install -c -m 644 src/error_handling.bc
'/usr/lib/postgresql/11/lib/bitcode'/pg_libphonenumber/src/
/usr/bin/install -c -m 644 src/pg_libphonenumber.bc
'/usr/lib/postgresql/11/lib/bitcode'/pg_libphonenumber/src/
/usr/bin/install -c -m 644 src/packed_phone_number.bc
'/usr/lib/postgresql/11/lib/bitcode'/pg_libphonenumber/src/
cd '/usr/lib/postgresql/11/lib/bitcode' && /usr/lib/llvm-6.0/bin/llvm-lto
-thinlto -thinlto-action=thinlink -o pg_libphonenumber.index.bc
pg_libphonenumber/src/error_handling.bc
pg_libphonenumber/src/pg_libphonenumber.bc
pg_libphonenumber/src/packed_phone_number.bc
error: can't create module summary index for buffer: Expected a single
module
LLVM ERROR: ThinLink didn't create an index
/usr/lib/postgresql/11/lib/pgxs/src/makefiles/pgxs.mk:229: recipe for
target 'install' failed
make: *** [install] Error 1

Can anyoine sygest where to look to resolve this error?


--
"They that would give up essential liberty for temporary safety deserve
neither liberty nor safety."
                                                -- Benjamin Franklin


Reply | Threaded
Open this post in threaded view
|

Re: install problem with extensions

legrand legrand
Hello

this seems very similar to your problem
https://github.com/PierreSenellart/provsql/issues/9

refreing to
https://github.com/rdkit/rdkit/issues/2192#issuecomment-445579020

are you using the same version of postgres ?

regards
PAscal



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-sql-f2142323.html


Reply | Threaded
Open this post in threaded view
|

Re: install problem with extensions

stan-9
On Wed, Nov 13, 2019 at 05:29:09PM +0000, legrand legrand wrote:
> Oups you are right
> This is a c++ patch ...
>
> Sorry I went too quickly because error message was the same :0(
>
> This is out of my knowledge
Please do not apologize. I believe your input was helpful, and likely to
lead to a resolution of my issue.

I do believe it is the same issue. Looks like there are 3 *.bc files in the
type I am trying to add, but I do not understand what these files are, or
how to tell the compiler/linker to properly handle more than one.

--
"They that would give up essential liberty for temporary safety deserve
neither liberty nor safety."
                                                -- Benjamin Franklin


Reply | Threaded
Open this post in threaded view
|

Re: install problem with extensions

legrand legrand
In reply to this post by legrand legrand
Hello,

I have been told off list, that thoses links refer to a C++ problem,
not a C makefile one.

Error message was exactly the same !
But I won't be able to help porting that C++ fix in C.

Regards
PAscal





--
Sent from: https://www.postgresql-archive.org/PostgreSQL-sql-f2142323.html