libgeotiff missing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

libgeotiff missing

Richard Suematsu-2
Hi,  Trying to update postgis24_10 on centos6 but it fails on a libgeotiff dependency.  On another machine, it looks like libgeotiff comes from @pgdg11, but I don't see it there anymore.

sudo yum install postgis24_10
Loaded plugins: amazon-id, search-disabled-repos, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package postgis24_10.x86_64 0:2.4.5-1.rhel6 will be installed
--> Processing Dependency: geos36 >= 3.6.2 for package: postgis24_10-2.4.5-1.rhel6.x86_64
--> Processing Dependency: gdal-libs >= 1.9.0 for package: postgis24_10-2.4.5-1.rhel6.x86_64
--> Processing Dependency: proj49 for package: postgis24_10-2.4.5-1.rhel6.x86_64

...

--> Running transaction check
---> Package arpack.x86_64 0:3.1.3-1.el6 will be installed
---> Package blas.x86_64 0:3.2.1-5.el6 will be installed
---> Package gdal-libs.x86_64 0:1.9.2-8.rhel6 will be installed
--> Processing Dependency: libgeotiff.so.2()(64bit) for package: gdal-libs-1.9.2-8.rhel6.x86_64
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package proj.x86_64 0:4.7.0-1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: gdal-libs-1.9.2-8.rhel6.x86_64 (pgdg-common)
           Requires: libgeotiff.so.2()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Richard Suematsu
Development Manager

SYNCADD Systems, Inc.
677 Ala Moana Blvd Suite 901
Honolulu, HI 96813
o: 808.941.8286 x 206
Reply | Threaded
Open this post in threaded view
|

Re: libgeotiff missing

Adrian Klaver-4
On 5/23/20 1:08 AM, Richard Suematsu wrote:
> Hi,  Trying to update postgis24_10 on centos6 but it fails on a
> libgeotiff dependency.  On another machine, it looks like libgeotiff
> comes from @pgdg11, but I don't see it there anymore.

I suspect this:

https://yum.postgresql.org/news-newreporpmsreleased.php

>
> sudo yum install postgis24_10
> Loaded plugins: amazon-id, search-disabled-repos, security
> Setting up Install Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package postgis24_10.x86_64 0:2.4.5-1.rhel6 will be installed
> --> Processing Dependency: geos36 >= 3.6.2 for package:
> postgis24_10-2.4.5-1.rhel6.x86_64
> --> Processing Dependency: gdal-libs >= 1.9.0 for package:
> postgis24_10-2.4.5-1.rhel6.x86_64
> --> Processing Dependency: proj49 for package:
> postgis24_10-2.4.5-1.rhel6.x86_64
>
> ...
>
> --> Running transaction check
> ---> Package arpack.x86_64 0:3.1.3-1.el6 will be installed
> ---> Package blas.x86_64 0:3.2.1-5.el6 will be installed
> ---> Package gdal-libs.x86_64 0:1.9.2-8.rhel6 will be installed
> --> Processing Dependency: libgeotiff.so.2()(64bit) for package:
> gdal-libs-1.9.2-8.rhel6.x86_64
> ---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
> ---> Package proj.x86_64 0:4.7.0-1.el6 will be installed
> --> Finished Dependency Resolution
> Error: Package: gdal-libs-1.9.2-8.rhel6.x86_64 (pgdg-common)
>             Requires: libgeotiff.so.2()(64bit)
>   You could try using --skip-broken to work around the problem
>   You could try running: rpm -Va --nofiles --nodigest
>
> Richard Suematsu
> Development Manager
>
> SYNCADD Systems, Inc.
> 677 Ala Moana Blvd Suite 901
> Honolulu, HI 96813
> o: 808.941.8286 x 206


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: libgeotiff missing

Richard Suematsu-2
 
On 5/23/20 1:08 AM, Richard Suematsu wrote:
> Hi,  Trying to update postgis24_10 on centos6 but it fails on a
> libgeotiff dependency.  On another machine, it looks like libgeotiff
> comes from @pgdg11, but I don't see it there anymore.

I suspect this:



Thanks, I found the issue logged here: https://redmine.postgresql.org/issues/5483
>
> sudo yum install postgis24_10
> Loaded plugins: amazon-id, search-disabled-repos, security
> Setting up Install Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package postgis24_10.x86_64 0:2.4.5-1.rhel6 will be installed
> --> Processing Dependency: geos36 >= 3.6.2 for package:
> postgis24_10-2.4.5-1.rhel6.x86_64
> --> Processing Dependency: gdal-libs >= 1.9.0 for package:
> postgis24_10-2.4.5-1.rhel6.x86_64
> --> Processing Dependency: proj49 for package:
> postgis24_10-2.4.5-1.rhel6.x86_64
>
> ...
>
> --> Running transaction check
> ---> Package arpack.x86_64 0:3.1.3-1.el6 will be installed
> ---> Package blas.x86_64 0:3.2.1-5.el6 will be installed
> ---> Package gdal-libs.x86_64 0:1.9.2-8.rhel6 will be installed
> --> Processing Dependency: libgeotiff.so.2()(64bit) for package:
> gdal-libs-1.9.2-8.rhel6.x86_64
> ---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
> ---> Package proj.x86_64 0:4.7.0-1.el6 will be installed
> --> Finished Dependency Resolution
> Error: Package: gdal-libs-1.9.2-8.rhel6.x86_64 (pgdg-common)
>             Requires: libgeotiff.so.2()(64bit)
>   You could try using --skip-broken to work around the problem
>   You could try running: rpm -Va --nofiles --nodigest
>
> Richard Suematsu
> Development Manager
>
> SYNCADD Systems, Inc.
> 677 Ala Moana Blvd Suite 901
> Honolulu, HI 96813
> o: 808.941.8286 x 206


--
Adrian Klaver
[hidden email]