pg Admin 4 v4.28 Errors on launch

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

pg Admin 4 v4.28 Errors on launch

Sasha

Hello!

I have updated my pgAdmin 4 from v4.27 to v4.28 and discovered that it won't start up in browser, because of MIME types of javascript files returned by server (maybe?).

I tried my best to fix this on my side, clearing all the caches in browser several times, rebooting the machine and reinstalling the software, but nothing helped.

According to the logs server started normally, but in browsers (Chrome and Mozilla) it doesn't work.

I'll try to roll back to 4.27 and use this version, hope this info helps to find and fix the issue:


Thanks for your great job maintaining this app!

Best wishes,

Sasha.


Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

Sasha
This post was updated on .
Hello again!
I forgot to mention that I installed windows distro (4.28 x64 and x32).
Also maybe I was wrong about updating from 4.27 because when I installed
x64 and x32 versions of 4.27 it just crashed before launch. (empty log)
I also tried to run v4.28 in x32 and x64 installer of pgadmin 4 and had
the issue reproduced every time.
Also I have removed settings from %APPDATA% folder just to be sure it is
unrelated to its format.

I installed v4.26 and everything seems to run fine.
Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

tito.calleros
I have the same problem, I just upgrade from v4.27 to v4.28.

Refused to execute script from
'http://127.0.0.1:57313/static/vendor/require/require.min.js?ver=42800'
because its MIME type ('text/plain') is not executable, and strict MIME type
checking is enabled.

(index):39 Uncaught ReferenceError: require is not defined at (index):39



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html


Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

Akshay Joshi
Hi All

We are working on the fix and will try to fix it asap. Once we fix the issue will release the pgAdmin 4.

Sorry for the inconvenience.

On Fri, Nov 13, 2020 at 12:05 AM tito.calleros <[hidden email]> wrote:
I have the same problem, I just upgrade from v4.27 to v4.28.

Refused to execute script from
'http://127.0.0.1:57313/static/vendor/require/require.min.js?ver=42800'
because its MIME type ('text/plain') is not executable, and strict MIME type
checking is enabled.

(index):39 Uncaught ReferenceError: require is not defined at (index):39



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html




--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246

Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

Akshay Joshi
Hi All

We were not able to reproduce this issue on any of our machines during pre-release testing for v4.28. Then after some R&D, we are able to reproduce this issue. 

Cause of the problem: if value of "HKEY_CLASSES_ROOT\.js\Content Type" is set to "text/plain" then issue is reproducible. In any javascript file, the content type should be “text/javascript” in the response header but in the above registry setting it is "text/plain", so the browser won't allow it.

Solution: Open the registry and changed the value of "HKEY_CLASSES_ROOT\.js\Content Type" to "text/javascript".

Please let us know the above solution works for you all.

On Fri, Nov 13, 2020 at 9:54 AM Akshay Joshi <[hidden email]> wrote:
Hi All

We are working on the fix and will try to fix it asap. Once we fix the issue will release the pgAdmin 4.

Sorry for the inconvenience.

On Fri, Nov 13, 2020 at 12:05 AM tito.calleros <[hidden email]> wrote:
I have the same problem, I just upgrade from v4.27 to v4.28.

Refused to execute script from
'http://127.0.0.1:57313/static/vendor/require/require.min.js?ver=42800'
because its MIME type ('text/plain') is not executable, and strict MIME type
checking is enabled.

(index):39 Uncaught ReferenceError: require is not defined at (index):39



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html




--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246



--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246

Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

Murtuza Zabuawala
++ Attaching the fix

Save the given attachment on your desktop, Double click on the file to import it and restart pgAdmin4.


On Fri, Nov 13, 2020 at 1:11 PM Akshay Joshi <[hidden email]> wrote:
Hi All

We were not able to reproduce this issue on any of our machines during pre-release testing for v4.28. Then after some R&D, we are able to reproduce this issue. 

Cause of the problem: if value of "HKEY_CLASSES_ROOT\.js\Content Type" is set to "text/plain" then issue is reproducible. In any javascript file, the content type should be “text/javascript” in the response header but in the above registry setting it is "text/plain", so the browser won't allow it.

Solution: Open the registry and changed the value of "HKEY_CLASSES_ROOT\.js\Content Type" to "text/javascript".

Please let us know the above solution works for you all.

On Fri, Nov 13, 2020 at 9:54 AM Akshay Joshi <[hidden email]> wrote:
Hi All

We are working on the fix and will try to fix it asap. Once we fix the issue will release the pgAdmin 4.

Sorry for the inconvenience.

On Fri, Nov 13, 2020 at 12:05 AM tito.calleros <[hidden email]> wrote:
I have the same problem, I just upgrade from v4.27 to v4.28.

Refused to execute script from
'http://127.0.0.1:57313/static/vendor/require/require.min.js?ver=42800'
because its MIME type ('text/plain') is not executable, and strict MIME type
checking is enabled.

(index):39 Uncaught ReferenceError: require is not defined at (index):39



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html




--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246



--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246


Fix_registery_for_JS_pgAdmin4.reg (246 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

Sasha
Hello!
Fix actually worked!
Pgadmin4 v4.28 started up normally.
Maybe some software changed the default values of this registry key.
It would be great if it was set automatically during installation.

Thanks!





--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html


Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

Sasha
In reply to this post by Sasha
Hello!

The registry key fix actually solved the problem.

Thank you!



Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

tito.calleros
In reply to this post by Murtuza Zabuawala
Thanks for your help.  

For work reasons, at the moment I have version 4.26 installed, as soon as I can I will try your fix. .

El vie., 13 de nov. de 2020 a la(s) 01:45, Murtuza Zabuawala ([hidden email]) escribió:
++ Attaching the fix

Save the given attachment on your desktop, Double click on the file to import it and restart pgAdmin4.


On Fri, Nov 13, 2020 at 1:11 PM Akshay Joshi <[hidden email]> wrote:
Hi All

We were not able to reproduce this issue on any of our machines during pre-release testing for v4.28. Then after some R&D, we are able to reproduce this issue. 

Cause of the problem: if value of "HKEY_CLASSES_ROOT\.js\Content Type" is set to "text/plain" then issue is reproducible. In any javascript file, the content type should be “text/javascript” in the response header but in the above registry setting it is "text/plain", so the browser won't allow it.

Solution: Open the registry and changed the value of "HKEY_CLASSES_ROOT\.js\Content Type" to "text/javascript".

Please let us know the above solution works for you all.

On Fri, Nov 13, 2020 at 9:54 AM Akshay Joshi <[hidden email]> wrote:
Hi All

We are working on the fix and will try to fix it asap. Once we fix the issue will release the pgAdmin 4.

Sorry for the inconvenience.

On Fri, Nov 13, 2020 at 12:05 AM tito.calleros <[hidden email]> wrote:
I have the same problem, I just upgrade from v4.27 to v4.28.

Refused to execute script from
'http://127.0.0.1:57313/static/vendor/require/require.min.js?ver=42800'
because its MIME type ('text/plain') is not executable, and strict MIME type
checking is enabled.

(index):39 Uncaught ReferenceError: require is not defined at (index):39



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html




--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246



--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246

Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

richard coleman
In reply to this post by tito.calleros
tito, 

This is a known issue with the latest version under windows.  The solution is documented here:

TLDR; 
To resolve the issue, use the Registry Editor and reset the value of HKEY_CLASSES_ROOT\.js\Content Type to:
text/javascript


Good luck,

rik.

On Thu, Nov 12, 2020 at 1:35 PM tito.calleros <[hidden email]> wrote:
I have the same problem, I just upgrade from v4.27 to v4.28.

Refused to execute script from
'http://127.0.0.1:57313/static/vendor/require/require.min.js?ver=42800'
because its MIME type ('text/plain') is not executable, and strict MIME type
checking is enabled.

(index):39 Uncaught ReferenceError: require is not defined at (index):39



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html


Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

esra
In reply to this post by Sasha
hello everyone i tried to fix it same problem but not working pgadmin4 also i
change the registry but it is not working please help me!!!!



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html


Reply | Threaded
Open this post in threaded view
|

Re: pg Admin 4 v4.28 Errors on launch

Akshay Joshi
Hi Esra

We have fixed the issue in v4.29, so no need to change the registry. Please verify it on the v4.29. 

On Tue, Dec 29, 2020 at 2:41 PM esra <[hidden email]> wrote:
hello everyone i tried to fix it same problem but not working pgadmin4 also i
change the registry but it is not working please help me!!!!



--
Sent from: https://www.postgresql-archive.org/PostgreSQL-pgadmin-support-f2191615.html




--
Thanks & Regards
Akshay Joshi
pgAdmin Hacker | Principal Software Architect
EDB Postgres
Mobile: +91 976-788-8246