pgAdmin 4 on Debian testing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pgAdmin 4 on Debian testing

Micha Silver

Hello:

I am running Debian 11, Bullseye, soon to become stable. There is no candidate package for this release of Debian yet. Neither the Buster package, nor the Ubuntu 20.04 package work since they rely on python 3.7 or 3.8, whereas Bullseye has moved to 3.9.


Any idea when a Bullseye package will become available?

Thanks


-- 
Micha Silver
Ben Gurion Univ.
Sde Boker, Remote Sensing Lab
cell: +972-523-665918
Reply | Threaded
Open this post in threaded view
|

Re: pgAdmin 4 on Debian testing

Dave Page-7
Hi

On Mon, Jan 4, 2021 at 5:09 PM Micha Silver <[hidden email]> wrote:

Hello:

I am running Debian 11, Bullseye, soon to become stable. There is no candidate package for this release of Debian yet. Neither the Buster package, nor the Ubuntu 20.04 package work since they rely on python 3.7 or 3.8, whereas Bullseye has moved to 3.9.


Any idea when a Bullseye package will become available?

I've setup our internal QA builds and the nightly snapshot builds to start including Bullseye packages. You should see the first builds at https://www.postgresql.org/ftp/pgadmin/pgadmin4/snapshots/2021-01-08/apt/ after they run tonight. Note that they haven't been tested at all yet, so any feedback would be welcome.


--
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com

Reply | Threaded
Open this post in threaded view
|

Re: pgAdmin 4 on Debian testing

Micha Silver

Great, I appreciate your quick response.

I'll get the package installed once it's ready and let you know if any issues come up.


On 1/7/2021 1:32 PM, Dave Page wrote:
Hi

On Mon, Jan 4, 2021 at 5:09 PM Micha Silver <[hidden email]> wrote:

Hello:

I am running Debian 11, Bullseye, soon to become stable. There is no candidate package for this release of Debian yet. Neither the Buster package, nor the Ubuntu 20.04 package work since they rely on python 3.7 or 3.8, whereas Bullseye has moved to 3.9.


Any idea when a Bullseye package will become available?

I've setup our internal QA builds and the nightly snapshot builds to start including Bullseye packages. You should see the first builds at https://www.postgresql.org/ftp/pgadmin/pgadmin4/snapshots/2021-01-08/apt/ after they run tonight. Note that they haven't been tested at all yet, so any feedback would be welcome.


--
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com

-- 
Micha Silver
Remote Sensing Lab, Sde Boker
Ben Gurion University
cell: +972-523-665918