pgadmin4 2.0 not properly starting

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

pgadmin4 2.0 not properly starting

Mark Murawski-2
Hi,

Checkout
  master                        8b543a58

Python 2.7

Pgadmin4 draws an initial window and then goes no further.  Attached
screenshot.

There's no log file output.  And only this from the main process:
$ runtime/pgAdmin4
Python path:
"/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
Python Home:  ""
Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"


It says the path is 3.4, but I've build with 2.7 (not sure how to fix it
to load 3.4, I'm not a python expert)

Here's the output from qmake
$ qmake
Project MESSAGE: Building for QT5+...
Project MESSAGE: Using QWebEngine...
Project MESSAGE: Building for Linux/Mac...
Project MESSAGE: Using /home/markm/.virtualenvs/pgadmin4/bin/python-config
Project MESSAGE: Python2 detected.

I had a lot of problems installing dependencies using pip, and it was
recommended I use pipenv.  Using pipenv I was able to get all the
dependencies installed for 2.7 into
/.virtualenvs/pgadmin4/lib/python2.7/site-packages.

When pgadmin4 loads, it's looking for site-pacakges in
.virtualenvs/pgadmin4/lib/python3.4/site-packages, so I symlinked 3.4 to
2.7 and pgadmin4 was able to start loading.

Any help greatly appreciated!

Thanks.

pg.png (22K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 2.0 not properly starting

Neel Patel
Hi Mark,

You have to use same python version while building and running pgAdmin4 application.

If you want to compile pgAdmin4 runtime application with Python 3.4 then export "PYTHON_CONFIG" variable so that application will use python 3.4 while compiling.
Hope you have used python 3.4 while creating virtual environment.

e.g. export PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config

After exporting above variable - while executing "qmake" message should be displayed like "Python3 detected.".

Let us know if you face any issue.

Thanks

On Tue, Nov 7, 2017 at 7:03 AM, Mark Murawski <[hidden email]> wrote:
Hi,

Checkout
 master                        8b543a58

Python 2.7

Pgadmin4 draws an initial window and then goes no further.  Attached screenshot.

There's no log file output.  And only this from the main process:
$ runtime/pgAdmin4
Python path: "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
Python Home:  ""
Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"


It says the path is 3.4, but I've build with 2.7 (not sure how to fix it to load 3.4, I'm not a python expert)

Here's the output from qmake
$ qmake
Project MESSAGE: Building for QT5+...
Project MESSAGE: Using QWebEngine...
Project MESSAGE: Building for Linux/Mac...
Project MESSAGE: Using /home/markm/.virtualenvs/pgadmin4/bin/python-config
Project MESSAGE: Python2 detected.

I had a lot of problems installing dependencies using pip, and it was recommended I use pipenv.  Using pipenv I was able to get all the dependencies installed for 2.7 into /.virtualenvs/pgadmin4/lib/python2.7/site-packages.

When pgadmin4 loads, it's looking for site-pacakges in .virtualenvs/pgadmin4/lib/python3.4/site-packages, so I symlinked 3.4 to 2.7 and pgadmin4 was able to start loading.

Any help greatly appreciated!

Thanks.

Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 2.0 not properly starting

Mark Murawski-2
Hi Neel,

Here you go:

source /usr/share/virtualenvwrapper/virtualenvwrapper.sh
mkvirtualenv --python=/usr/bin/python3.5 pgadmin4
export PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
workon pgadmin4
pip3 install --upgrade -r requirements.txt

$ qmake
Project MESSAGE: Building for QT5+...
Project MESSAGE: Using QWebEngine...
Project MESSAGE: Building for Linux/Mac...
Project MESSAGE: Using /home/markm/.virtualenvs/pgadmin4/bin/python-config
Project MESSAGE: Python3 detected.

$ make
build successful...

./pgAdmin4
Python path:
"/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
Python Home:  ""
Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
Traceback (most recent call last):
   File "/home/markm/download/pgadmin4/web/pgAdmin4.py", line 34, in
<module>
     import config
   File "/home/markm/download/pgadmin4/web/config.py", line 30, in <module>
     from pgadmin.utils import env, IS_PY2, IS_WIN, fs_short_path
   File "/home/markm/download/pgadmin4/web/pgadmin/__init__.py", line
17, in <module>
     from flask import Flask, abort, request, current_app, session, url_for
ImportError: No module named 'flask'


It's still trying to load 3.4


On 11/07/17 00:24, Neel Patel wrote:

> Hi Mark,
>
> You have to use same python version while building and running pgAdmin4
> application.
>
> If you want to compile pgAdmin4 runtime application with Python 3.4 then
> export "PYTHON_CONFIG" variable so that application will use python 3.4
> while compiling.
> Hope you have used python 3.4 while creating virtual environment.
>
> e.g. export
> PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
>
> After exporting above variable - while executing "qmake" message should
> be displayed like "Python3 detected.".
>
> Let us know if you face any issue.
>
> Thanks
>
> On Tue, Nov 7, 2017 at 7:03 AM, Mark Murawski
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi,
>
>     Checkout
>       master                        8b543a58
>
>     Python 2.7
>
>     Pgadmin4 draws an initial window and then goes no further.  Attached
>     screenshot.
>
>     There's no log file output.  And only this from the main process:
>     $ runtime/pgAdmin4
>     Python path:
>     "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
>     Python Home:  ""
>     Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
>
>
>     It says the path is 3.4, but I've build with 2.7 (not sure how to
>     fix it to load 3.4, I'm not a python expert)
>
>     Here's the output from qmake
>     $ qmake
>     Project MESSAGE: Building for QT5+...
>     Project MESSAGE: Using QWebEngine...
>     Project MESSAGE: Building for Linux/Mac...
>     Project MESSAGE: Using
>     /home/markm/.virtualenvs/pgadmin4/bin/python-config
>     Project MESSAGE: Python2 detected.
>
>     I had a lot of problems installing dependencies using pip, and it
>     was recommended I use pipenv.  Using pipenv I was able to get all
>     the dependencies installed for 2.7 into
>     /.virtualenvs/pgadmin4/lib/python2.7/site-packages.
>
>     When pgadmin4 loads, it's looking for site-pacakges in
>     .virtualenvs/pgadmin4/lib/python3.4/site-packages, so I symlinked
>     3.4 to 2.7 and pgadmin4 was able to start loading.
>
>     Any help greatly appreciated!
>
>     Thanks.
>
>



Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 2.0 not properly starting

Neel Patel
HI Mark,

I can see different version of Python 3.4 & 3.5. Here build is correct but issue is while running pgAdmin4 - it is not able to detect the correct virtualenv packages with python version.
Can you make virtualenv of one python version, install requirements and run pgAdmin4 from same virtualenv ?

Thanks,
Neel Patel

On Tue, Nov 7, 2017 at 8:54 PM, Mark Murawski <[hidden email]> wrote:
Hi Neel,

Here you go:

source /usr/share/virtualenvwrapper/virtualenvwrapper.sh
mkvirtualenv --python=/usr/bin/python3.5 pgadmin4
export PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
workon pgadmin4
pip3 install --upgrade -r requirements.txt

$ qmake
Project MESSAGE: Building for QT5+...
Project MESSAGE: Using QWebEngine...
Project MESSAGE: Building for Linux/Mac...
Project MESSAGE: Using /home/markm/.virtualenvs/pgadmin4/bin/python-config
Project MESSAGE: Python3 detected.

$ make
build successful...

./pgAdmin4
Python path: "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
Python Home:  ""
Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
Traceback (most recent call last):
  File "/home/markm/download/pgadmin4/web/pgAdmin4.py", line 34, in <module>
    import config
  File "/home/markm/download/pgadmin4/web/config.py", line 30, in <module>
    from pgadmin.utils import env, IS_PY2, IS_WIN, fs_short_path
  File "/home/markm/download/pgadmin4/web/pgadmin/__init__.py", line 17, in <module>
    from flask import Flask, abort, request, current_app, session, url_for
ImportError: No module named 'flask'


It's still trying to load 3.4


On 11/07/17 00:24, Neel Patel wrote:
Hi Mark,

You have to use same python version while building and running pgAdmin4 application.

If you want to compile pgAdmin4 runtime application with Python 3.4 then export "PYTHON_CONFIG" variable so that application will use python 3.4 while compiling.
Hope you have used python 3.4 while creating virtual environment.

e.g. export PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config

After exporting above variable - while executing "qmake" message should be displayed like "Python3 detected.".

Let us know if you face any issue.

Thanks

On Tue, Nov 7, 2017 at 7:03 AM, Mark Murawski <[hidden email] <mailto:[hidden email]>> wrote:

    Hi,

    Checkout
      master                        8b543a58

    Python 2.7

    Pgadmin4 draws an initial window and then goes no further.  Attached
    screenshot.

    There's no log file output.  And only this from the main process:
    $ runtime/pgAdmin4
    Python path:
    "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
    Python Home:  ""
    Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"


    It says the path is 3.4, but I've build with 2.7 (not sure how to
    fix it to load 3.4, I'm not a python expert)

    Here's the output from qmake
    $ qmake
    Project MESSAGE: Building for QT5+...
    Project MESSAGE: Using QWebEngine...
    Project MESSAGE: Building for Linux/Mac...
    Project MESSAGE: Using
    /home/markm/.virtualenvs/pgadmin4/bin/python-config
    Project MESSAGE: Python2 detected.

    I had a lot of problems installing dependencies using pip, and it
    was recommended I use pipenv.  Using pipenv I was able to get all
    the dependencies installed for 2.7 into
    /.virtualenvs/pgadmin4/lib/python2.7/site-packages.

    When pgadmin4 loads, it's looking for site-pacakges in
    .virtualenvs/pgadmin4/lib/python3.4/site-packages, so I symlinked
    3.4 to 2.7 and pgadmin4 was able to start loading.

    Any help greatly appreciated!

    Thanks.






Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 2.0 not properly starting

Mark Murawski-2
Hi Neel,

Yes, this is what I have done already.  I pasted my process in the
previous email.

What I did was make a virtualenv for python 3.5, I installed the
requirements for python 3.5, and then from the same virtualenv, I built
pgadmin4, and then also from the same virtualenv (same shell session and
everything), I started pgadmin4.


On 11/07/17 10:32, Neel Patel wrote:

> HI Mark,
>
> I can see different version of Python 3.4 & 3.5. Here build is correct
> but issue is while running pgAdmin4 - it is not able to detect the
> correct virtualenv packages with python version.
> Can you make virtualenv of one python version, install requirements and
> run pgAdmin4 from same virtualenv ?
>
> Thanks,
> Neel Patel
>
> On Tue, Nov 7, 2017 at 8:54 PM, Mark Murawski
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi Neel,
>
>     Here you go:
>
>     source /usr/share/virtualenvwrapper/virtualenvwrapper.sh
>     mkvirtualenv --python=/usr/bin/python3.5 pgadmin4
>     export PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
>     workon pgadmin4
>     pip3 install --upgrade -r requirements.txt
>
>     $ qmake
>     Project MESSAGE: Building for QT5+...
>     Project MESSAGE: Using QWebEngine...
>     Project MESSAGE: Building for Linux/Mac...
>     Project MESSAGE: Using
>     /home/markm/.virtualenvs/pgadmin4/bin/python-config
>     Project MESSAGE: Python3 detected.
>
>     $ make
>     build successful...
>
>     ./pgAdmin4
>     Python path:
>     "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
>     Python Home:  ""
>     Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
>     Traceback (most recent call last):
>        File "/home/markm/download/pgadmin4/web/pgAdmin4.py", line 34, in
>     <module>
>          import config
>        File "/home/markm/download/pgadmin4/web/config.py", line 30, in
>     <module>
>          from pgadmin.utils import env, IS_PY2, IS_WIN, fs_short_path
>        File "/home/markm/download/pgadmin4/web/pgadmin/__init__.py",
>     line 17, in <module>
>          from flask import Flask, abort, request, current_app, session,
>     url_for
>     ImportError: No module named 'flask'
>
>
>     It's still trying to load 3.4
>
>
>     On 11/07/17 00:24, Neel Patel wrote:
>
>         Hi Mark,
>
>         You have to use same python version while building and running
>         pgAdmin4 application.
>
>         If you want to compile pgAdmin4 runtime application with Python
>         3.4 then export "PYTHON_CONFIG" variable so that application
>         will use python 3.4 while compiling.
>         Hope you have used python 3.4 while creating virtual environment.
>
>         e.g. export
>         PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
>
>         After exporting above variable - while executing "qmake" message
>         should be displayed like "Python3 detected.".
>
>         Let us know if you face any issue.
>
>         Thanks
>
>         On Tue, Nov 7, 2017 at 7:03 AM, Mark Murawski
>         <[hidden email]
>         <mailto:[hidden email]>
>         <mailto:[hidden email]
>         <mailto:[hidden email]>>> wrote:
>
>              Hi,
>
>              Checkout
>                master                        8b543a58
>
>              Python 2.7
>
>              Pgadmin4 draws an initial window and then goes no further.
>         Attached
>              screenshot.
>
>              There's no log file output.  And only this from the main
>         process:
>              $ runtime/pgAdmin4
>              Python path:
>              "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
>              Python Home:  ""
>              Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
>
>
>              It says the path is 3.4, but I've build with 2.7 (not sure
>         how to
>              fix it to load 3.4, I'm not a python expert)
>
>              Here's the output from qmake
>              $ qmake
>              Project MESSAGE: Building for QT5+...
>              Project MESSAGE: Using QWebEngine...
>              Project MESSAGE: Building for Linux/Mac...
>              Project MESSAGE: Using
>              /home/markm/.virtualenvs/pgadmin4/bin/python-config
>              Project MESSAGE: Python2 detected.
>
>              I had a lot of problems installing dependencies using pip,
>         and it
>              was recommended I use pipenv.  Using pipenv I was able to
>         get all
>              the dependencies installed for 2.7 into
>              /.virtualenvs/pgadmin4/lib/python2.7/site-packages.
>
>              When pgadmin4 loads, it's looking for site-pacakges in
>              .virtualenvs/pgadmin4/lib/python3.4/site-packages, so I
>         symlinked
>              3.4 to 2.7 and pgadmin4 was able to start loading.
>
>              Any help greatly appreciated!
>
>              Thanks.
>
>
>
>
>
>



Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 2.0 not properly starting

Neel Patel
Hi Mark,

Before launching pgAdmin4 application, can you please export PYTHONPATH variable to "/home/markm/.virtualenvs/pgadmin4/bin/python-config", so that application will pick the packages from that path.
Below path is reference - You may need to change according to your environment.

e.g.
export PYTHONPATH="/home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages"

Thanks,
Neel Patel

On Tue, Nov 7, 2017 at 9:46 PM, Mark Murawski <[hidden email]> wrote:
Hi Neel,

Yes, this is what I have done already.  I pasted my process in the previous email.

What I did was make a virtualenv for python 3.5, I installed the requirements for python 3.5, and then from the same virtualenv, I built pgadmin4, and then also from the same virtualenv (same shell session and everything), I started pgadmin4.


On 11/07/17 10:32, Neel Patel wrote:
HI Mark,

I can see different version of Python 3.4 & 3.5. Here build is correct but issue is while running pgAdmin4 - it is not able to detect the correct virtualenv packages with python version.
Can you make virtualenv of one python version, install requirements and run pgAdmin4 from same virtualenv ?

Thanks,
Neel Patel

On Tue, Nov 7, 2017 at 8:54 PM, Mark Murawski <[hidden email] <mailto:[hidden email]>> wrote:

    Hi Neel,

    Here you go:

    source /usr/share/virtualenvwrapper/virtualenvwrapper.sh
    mkvirtualenv --python=/usr/bin/python3.5 pgadmin4
    export PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
    workon pgadmin4
    pip3 install --upgrade -r requirements.txt

    $ qmake
    Project MESSAGE: Building for QT5+...
    Project MESSAGE: Using QWebEngine...
    Project MESSAGE: Building for Linux/Mac...
    Project MESSAGE: Using
    /home/markm/.virtualenvs/pgadmin4/bin/python-config
    Project MESSAGE: Python3 detected.

    $ make
    build successful...

    ./pgAdmin4
    Python path:
    "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
    Python Home:  ""
    Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
    Traceback (most recent call last):
       File "/home/markm/download/pgadmin4/web/pgAdmin4.py", line 34, in
    <module>
         import config
       File "/home/markm/download/pgadmin4/web/config.py", line 30, in
    <module>
         from pgadmin.utils import env, IS_PY2, IS_WIN, fs_short_path
       File "/home/markm/download/pgadmin4/web/pgadmin/__init__.py",
    line 17, in <module>
         from flask import Flask, abort, request, current_app, session,
    url_for
    ImportError: No module named 'flask'


    It's still trying to load 3.4


    On 11/07/17 00:24, Neel Patel wrote:

        Hi Mark,

        You have to use same python version while building and running
        pgAdmin4 application.

        If you want to compile pgAdmin4 runtime application with Python
        3.4 then export "PYTHON_CONFIG" variable so that application
        will use python 3.4 while compiling.
        Hope you have used python 3.4 while creating virtual environment.

        e.g. export
        PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config

        After exporting above variable - while executing "qmake" message
        should be displayed like "Python3 detected.".

        Let us know if you face any issue.

        Thanks

        On Tue, Nov 7, 2017 at 7:03 AM, Mark Murawski
        <[hidden email]
        <mailto:[hidden email]>
        <mailto:[hidden email]

        <mailto:[hidden email]>>> wrote:

             Hi,

             Checkout
               master                        8b543a58

             Python 2.7

             Pgadmin4 draws an initial window and then goes no further.         Attached
             screenshot.

             There's no log file output.  And only this from the main
        process:
             $ runtime/pgAdmin4
             Python path:
             "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
             Python Home:  ""
             Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"


             It says the path is 3.4, but I've build with 2.7 (not sure
        how to
             fix it to load 3.4, I'm not a python expert)

             Here's the output from qmake
             $ qmake
             Project MESSAGE: Building for QT5+...
             Project MESSAGE: Using QWebEngine...
             Project MESSAGE: Building for Linux/Mac...
             Project MESSAGE: Using
             /home/markm/.virtualenvs/pgadmin4/bin/python-config
             Project MESSAGE: Python2 detected.

             I had a lot of problems installing dependencies using pip,
        and it
             was recommended I use pipenv.  Using pipenv I was able to
        get all
             the dependencies installed for 2.7 into
             /.virtualenvs/pgadmin4/lib/python2.7/site-packages.

             When pgadmin4 loads, it's looking for site-pacakges in
             .virtualenvs/pgadmin4/lib/python3.4/site-packages, so I
        symlinked
             3.4 to 2.7 and pgadmin4 was able to start loading.

             Any help greatly appreciated!

             Thanks.










Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 2.0 not properly starting

Mark Murawski-2
The instructions you've provided don't solve the issue: here's my process.


walnut {~} kobaz$ cat /tmp/scrollback-kobaz-wm6r
walnut {~} markm$ ssh -X markm
markm@markm's password:
Linux markm 4.9.7 #1 SMP PREEMPT Wed Feb 1 11:01:52 EST 2017 x86_64

You have mail.
Last login: Tue Nov 14 13:37:45 2017 from 192.168.5.6

markm {~} markm$ export PYTHONPATH="/home/markm/.virtualenvs/pgadmin4/bin/python-config"
markm {~/download/pgadmin4} markm$ source /usr/share/virtualenvwrapper/virtualenvwrapper.sh
markm {~/download/pgadmin4} markm$ mkvirtualenv --python=/usr/bin/python3.5 pgadmin4
Running virtualenv with interpreter /usr/bin/python3.5
Using base prefix '/usr'
New python executable in /home/markm/.virtualenvs/pgadmin4/bin/python3.5
Also creating executable in /home/markm/.virtualenvs/pgadmin4/bin/python
Installing setuptools, pkg_resources, pip, wheel...done.
(pgadmin4) markm {~/download/pgadmin4} markm$ ls /home/markm/.virtualenvs/pgadmin4/bin/python-config
/home/markm/.virtualenvs/pgadmin4/bin/python-config
(pgadmin4) markm {~/download/pgadmin4} markm$ /home/markm/.virtualenvs/pgadmin4/bin/python-config
Usage: /home/markm/.virtualenvs/pgadmin4/bin/python-config [--prefix|--exec-prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|--help|--abiflags|--configdir]
(pgadmin4) markm {~/download/pgadmin4} markm$ /home/markm/.virtualenvs/pgadmin4/bin/python-config --prefix
/usr
(pgadmin4) markm {~/download/pgadmin4} markm$ /home/markm/.virtualenvs/pgadmin4/bin/python-config --help
Usage: /home/markm/.virtualenvs/pgadmin4/bin/python-config [--prefix|--exec-prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|--help|--abiflags|--configdir]
(pgadmin4) markm {~/download/pgadmin4} markm$ export PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
(pgadmin4) markm {~/download/pgadmin4} markm$ ls /home/markm/.virtualenvs/pgadmin4/bin/python-config
/home/markm/.virtualenvs/pgadmin4/bin/python-config
(pgadmin4) markm {~/download/pgadmin4} markm$ ls
LICENSE  Make-MinGW.bat  Make.bat  Makefile  README  ci  docs  libraries.txt  pgadmin4-BUILD  pkg  requirements.txt  runtime  web
(pgadmin4) markm {~/download/pgadmin4} markm$ workon pgadmin4
(pgadmin4) markm {~/download/pgadmin4} markm$ pip3 install --upgrade -r requirements.txt
Ignoring importlib: markers 'python_version <= "2.7"' don't match your environment
Ignoring ordereddict: markers 'python_version < "2.7"' don't match your environment
Ignoring backports.csv: markers 'python_version <= "2.7"' don't match your environment
Ignoring Flask-Script: markers 'python_version < "2.7"' don't match your environment
Collecting Babel==2.3.4 (from -r requirements.txt (line 4))
  Using cached Babel-2.3.4-py2.py3-none-any.whl
Collecting beautifulsoup4==4.4.1 (from -r requirements.txt (line 5))
  Using cached beautifulsoup4-4.4.1-py3-none-any.whl
Collecting blinker==1.3 (from -r requirements.txt (line 6))
Collecting click==6.6 (from -r requirements.txt (line 7))
  Using cached click-6.6-py2.py3-none-any.whl
Collecting extras==0.0.3 (from -r requirements.txt (line 8))
Collecting fixtures==2.0.0 (from -r requirements.txt (line 9))
  Using cached fixtures-2.0.0-py2.py3-none-any.whl
Collecting Flask==0.11.1 (from -r requirements.txt (line 10))
  Using cached Flask-0.11.1-py2.py3-none-any.whl
Collecting Flask-Babel==0.11.1 (from -r requirements.txt (line 11))
Collecting Flask-Gravatar==0.4.2 (from -r requirements.txt (line 12))
  Using cached Flask_Gravatar-0.4.2-py2.py3-none-any.whl
Collecting Flask-HTMLmin==1.2 (from -r requirements.txt (line 13))
Collecting Flask-Login==0.3.2 (from -r requirements.txt (line 14))
Collecting Flask-Mail==0.9.1 (from -r requirements.txt (line 15))
Collecting Flask-Migrate==2.0.3 (from -r requirements.txt (line 16))
Collecting Flask-Principal==0.4.0 (from -r requirements.txt (line 17))
Collecting Flask-Security==1.7.5 (from -r requirements.txt (line 18))
Collecting Flask-SQLAlchemy==2.1 (from -r requirements.txt (line 19))
Collecting Flask-WTF==0.12 (from -r requirements.txt (line 20))
Collecting html5lib==1.0b3 (from -r requirements.txt (line 21))
Collecting itsdangerous==0.24 (from -r requirements.txt (line 23))
Collecting Jinja2==2.7.3 (from -r requirements.txt (line 24))
Collecting linecache2==1.0.0 (from -r requirements.txt (line 25))
  Using cached linecache2-1.0.0-py2.py3-none-any.whl
Collecting MarkupSafe==0.23 (from -r requirements.txt (line 26))
Collecting passlib==1.6.2 (from -r requirements.txt (line 28))
Collecting pbr==1.9.1 (from -r requirements.txt (line 29))
  Using cached pbr-1.9.1-py2.py3-none-any.whl
Collecting psycopg2>=2.7.3.2 (from -r requirements.txt (line 30))
  Using cached psycopg2-2.7.3.2-cp35-cp35m-manylinux1_x86_64.whl
Collecting pycrypto==2.6.1 (from -r requirements.txt (line 31))
Collecting pyrsistent==0.11.13 (from -r requirements.txt (line 32))
Collecting python-dateutil==2.5.0 (from -r requirements.txt (line 33))
  Using cached python_dateutil-2.5.0-py2.py3-none-any.whl
Collecting python-mimeparse==1.5.1 (from -r requirements.txt (line 34))
Collecting pytz==2014.10 (from -r requirements.txt (line 35))
  Using cached pytz-2014.10-py2.py3-none-any.whl
Collecting simplejson==3.6.5 (from -r requirements.txt (line 36))
Collecting six>=1.9.0 (from -r requirements.txt (line 37))
  Using cached six-1.11.0-py2.py3-none-any.whl
Collecting speaklater==1.3 (from -r requirements.txt (line 38))
Collecting SQLAlchemy==1.0.14 (from -r requirements.txt (line 39))
Collecting sqlparse==0.1.19 (from -r requirements.txt (line 40))
Collecting Werkzeug==0.9.6 (from -r requirements.txt (line 41))
Collecting WTForms==2.0.2 (from -r requirements.txt (line 42))
  Using cached WTForms-2.0.2-py2.py3-none-any.whl
Collecting Flask-Paranoid==0.1.0 (from -r requirements.txt (line 44))
Collecting testtools>=0.9.22 (from fixtures==2.0.0->-r requirements.txt (line 9))
  Using cached testtools-2.3.0-py2.py3-none-any.whl
Collecting htmlmin (from Flask-HTMLmin==1.2->-r requirements.txt (line 13))
Collecting Flask-Script>=0.6 (from Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Collecting alembic>=0.6 (from Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Collecting unittest2>=1.0.0 (from testtools>=0.9.22->fixtures==2.0.0->-r requirements.txt (line 9))
  Using cached unittest2-1.1.0-py2.py3-none-any.whl
Collecting traceback2 (from testtools>=0.9.22->fixtures==2.0.0->-r requirements.txt (line 9))
  Using cached traceback2-1.4.0-py2.py3-none-any.whl
Collecting Mako (from alembic>=0.6->Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Collecting python-editor>=0.3 (from alembic>=0.6->Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Collecting argparse (from unittest2>=1.0.0->testtools>=0.9.22->fixtures==2.0.0->-r requirements.txt (line 9))
  Using cached argparse-1.4.0-py2.py3-none-any.whl
Installing collected packages: pytz, Babel, beautifulsoup4, blinker, click, extras, six, pbr, argparse, linecache2, traceback2, unittest2, python-mimeparse, testtools, fixtures, itsdangerous, Werkzeug, MarkupSafe, Jinja2, Flask, Flask-Babel, Flask-Gravatar, htmlmin, Flask-HTMLmin, Flask-Login, Flask-Mail, SQLAlchemy, Flask-SQLAlchemy, Flask-Script, python-dateutil, Mako, python-editor, alembic, Flask-Migrate, Flask-Principal, passlib, WTForms, Flask-WTF, Flask-Security, html5lib, psycopg2, pycrypto, pyrsistent, simplejson, speaklater, sqlparse, Flask-Paranoid
Successfully installed Babel-2.3.4 Flask-0.11.1 Flask-Babel-0.11.1 Flask-Gravatar-0.4.2 Flask-HTMLmin-1.2 Flask-Login-0.3.2 Flask-Mail-0.9.1 Flask-Migrate-2.0.3 Flask-Paranoid-0.1.0 Flask-Principal-0.4.0 Flask-SQLAlchemy-2.1 Flask-Script-2.0.6 Flask-Security-1.7.5 Flask-WTF-0.12 Jinja2-2.7.3 Mako-1.0.7 MarkupSafe-0.23 SQLAlchemy-1.0.14 WTForms-2.0.2 Werkzeug-0.9.6 alembic-0.9.6 argparse-1.4.0 beautifulsoup4-4.4.1 blinker-1.3 click-6.6 extras-0.0.3 fixtures-2.0.0 html5lib-1.0b3 htmlmin-0.1.11 itsdangerous-0.24 linecache2-1.0.0 passlib-1.6.2 pbr-1.9.1 psycopg2-2.7.3.2 pycrypto-2.6.1 pyrsistent-0.11.13 python-dateutil-2.5.0 python-editor-1.0.3 python-mimeparse-1.5.1 pytz-2014.10 simplejson-3.6.5 six-1.11.0 speaklater-1.3 sqlparse-0.1.19 testtools-2.3.0 traceback2-1.4.0 unittest2-1.1.0
(pgadmin4) markm {~/download/pgadmin4} markm$ ls
LICENSE  Make-MinGW.bat  Make.bat  Makefile  README  ci  docs  libraries.txt  pgadmin4-BUILD  pkg  requirements.txt  runtime  web
(pgadmin4) markm {~/download/pgadmin4} markm$ cd runtime/
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ make clean
make: *** No rule to make target 'clean'.  Stop.
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ qmake
Info: creating stash file /home/markm/download/pgadmin4/runtime/.qmake.stash
Project MESSAGE: Building for QT5+...
Project MESSAGE: Using QWebEngine...
Project MESSAGE: Building for Linux/Mac...
Project MESSAGE: Using /home/markm/.virtualenvs/pgadmin4/bin/python-config
Project MESSAGE: Python3 detected.
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ make
/usr/lib/x86_64-linux-gnu/qt5/bin/uic BrowserWindow.ui -o ui_BrowserWindow.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic ConfigWindow.ui -o ui_ConfigWindow.h
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o pgAdmin4.o pgAdmin4.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o BrowserWindow.o BrowserWindow.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o Server.o Server.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o TabWindow.o TabWindow.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o WebViewWindow.o WebViewWindow.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o ConfigWindow.o ConfigWindow.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/rcc -name pgAdmin4 pgAdmin4.qrc -o qrc_pgAdmin4.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o qrc_pgAdmin4.o qrc_pgAdmin4.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/markm/download/pgadmin4/runtime -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -I/usr/include/x86_64-linux-gnu/qt5/QtQuick -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel -I/usr/include/x86_64-linux-gnu/qt5/QtQml -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6 -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include BrowserWindow.h -o moc_BrowserWindow.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o moc_BrowserWindow.o moc_BrowserWindow.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/markm/download/pgadmin4/runtime -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -I/usr/include/x86_64-linux-gnu/qt5/QtQuick -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel -I/usr/include/x86_64-linux-gnu/qt5/QtQml -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6 -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include Server.h -o moc_Server.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o moc_Server.o moc_Server.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/markm/download/pgadmin4/runtime -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -I/usr/include/x86_64-linux-gnu/qt5/QtQuick -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel -I/usr/include/x86_64-linux-gnu/qt5/QtQml -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6 -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include TabWindow.h -o moc_TabWindow.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o moc_TabWindow.o moc_TabWindow.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/markm/download/pgadmin4/runtime -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -I/usr/include/x86_64-linux-gnu/qt5/QtQuick -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel -I/usr/include/x86_64-linux-gnu/qt5/QtQml -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6 -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include WebViewWindow.h -o moc_WebViewWindow.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o moc_WebViewWindow.o moc_WebViewWindow.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/markm/download/pgadmin4/runtime -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -I/usr/include/x86_64-linux-gnu/qt5/QtQuick -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel -I/usr/include/x86_64-linux-gnu/qt5/QtQml -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6 -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include ConfigWindow.h -o moc_ConfigWindow.cpp
g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o moc_ConfigWindow.o moc_ConfigWindow.cpp
g++ -m64 -lpython3.5m -lpthread -ldl -lutil -lm -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-O1 -Wl,-rpath-link,/usr/lib/x86_64-linux-gnu -o pgAdmin4 pgAdmin4.o BrowserWindow.o Server.o TabWindow.o WebViewWindow.o ConfigWindow.o qrc_pgAdmin4.o moc_BrowserWindow.o moc_Server.o moc_TabWindow.o moc_WebViewWindow.o moc_ConfigWindow.o   -L/usr/X11R6/lib64 -lpython3.5m -ldl -lutil -lm -lQt5WebEngineWidgets -lQt5WebEngineCore -lQt5Quick -lQt5Widgets -lQt5Gui -lQt5WebChannel -lQt5Qml -lQt5Network -lQt5Core -lGL -lpthread
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ ls
BrowserWindow.cpp  ConfigWindow.h   Server.cpp     TabWindow.o        close.png              moc_ConfigWindow.o  moc_WebViewWindow.cpp  pgAdmin4.icns  pgAdmin4.rc       ui_BrowserWindow.h
BrowserWindow.h    ConfigWindow.o   Server.h       WebViewWindow.cpp  forward.png            moc_Server.cpp      moc_WebViewWindow.o    pgAdmin4.ico   qrc_pgAdmin4.cpp  ui_ConfigWindow.h
BrowserWindow.o    ConfigWindow.ui  Server.o       WebViewWindow.h    moc_BrowserWindow.cpp  moc_Server.o        pgAdmin4               pgAdmin4.o     qrc_pgAdmin4.o
BrowserWindow.ui   Info.plist       TabWindow.cpp  WebViewWindow.o    moc_BrowserWindow.o    moc_TabWindow.cpp   pgAdmin4.cpp           pgAdmin4.pro   qss
ConfigWindow.cpp   Makefile         TabWindow.h    back.png           moc_ConfigWindow.cpp   moc_TabWindow.o     pgAdmin4.h             pgAdmin4.qrc   splash.png
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ ./pgAdmin4
Python path:  "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
Python Home:  ""
Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
Traceback (most recent call last):
  File "/home/markm/download/pgadmin4/web/pgAdmin4.py", line 34, in <module>
    import config
  File "/home/markm/download/pgadmin4/web/config.py", line 30, in <module>
    from pgadmin.utils import env, IS_PY2, IS_WIN, fs_short_path
  File "/home/markm/download/pgadmin4/web/pgadmin/__init__.py", line 17, in <module>
    from flask import Flask, abort, request, current_app, session, url_for
ImportError: No module named 'flask'
^C^C^C^Z
[1]+  Stopped                 ./pgAdmin4
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ kill -9 %1

[1]+  Stopped                 ./pgAdmin4
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$
[1]+  Killed                  ./pgAdmin4
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ kill -9 %1
-bash: kill: %1: no such job
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ pip3 install flask
Requirement already satisfied: flask in /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages
Requirement already satisfied: click>=2.0 in /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
Requirement already satisfied: Werkzeug>=0.7 in /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
Requirement already satisfied: itsdangerous>=0.21 in /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
Requirement already satisfied: Jinja2>=2.4 in /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
Requirement already satisfied: markupsafe in /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from Jinja2>=2.4->flask)
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$


On 11/08/2017 12:35 AM, Neel Patel wrote:
Hi Mark,

Before launching pgAdmin4 application, can you please export PYTHONPATH variable to "/home/markm/.virtualenvs/pgadmin4/bin/python-config", so that application will pick the packages from that path.
Below path is reference - You may need to change according to your environment.

e.g.
export PYTHONPATH="/home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages"

Thanks,
Neel Patel

On Tue, Nov 7, 2017 at 9:46 PM, Mark Murawski <[hidden email]> wrote:
Hi Neel,

Yes, this is what I have done already.  I pasted my process in the previous email.

What I did was make a virtualenv for python 3.5, I installed the requirements for python 3.5, and then from the same virtualenv, I built pgadmin4, and then also from the same virtualenv (same shell session and everything), I started pgadmin4.


Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 2.0 not properly starting

Mark Murawski-2
Hi Neel,

I've completely removed python3.4 from my system:

markm {~} root# dpkg -l | grep python3.4
markm {~} root#

There's nothing related to python 3.4 in my environment

(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ export | grep 3.4
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$

And there's nothing specifically setting any python paths


(pgadmin4) markm {~/download/pgadmin4/runtime} markm$ export | grep PYTHON
(pgadmin4) markm {~/download/pgadmin4/runtime} markm$

I've rm -rf ~/.virtualenvs and reinstalled the pip packages, and rebuilt
pgadmin4

Is something hard coded in pgadmin4 to require 3.4 when configuring with
python3?

Grepping for python3.4 has yielded no results, but that doesn't rule out
building the path via concatenation.




On 11/14/17 18:01, Mark Murawski wrote:

> The instructions you've provided don't solve the issue: here's my process.
>
>
> walnut {~} markm$ cat /tmp/scrollback-markm-wm6r
> walnut {~} markm$ ssh -X markm
> markm@markm's password:
> Linux markm 4.9.7 #1 SMP PREEMPT Wed Feb 1 11:01:52 EST 2017 x86_64
>
> You have mail.
> Last login: Tue Nov 14 13:37:45 2017 from 192.168.5.6
>
> markm {~} markm$ export
> PYTHONPATH="/home/markm/.virtualenvs/pgadmin4/bin/python-config"
> markm {~/download/pgadmin4} markm$ source
> /usr/share/virtualenvwrapper/virtualenvwrapper.sh
> markm {~/download/pgadmin4} markm$ mkvirtualenv
> --python=/usr/bin/python3.5 pgadmin4
> Running virtualenv with interpreter /usr/bin/python3.5
> Using base prefix '/usr'
> New python executable in /home/markm/.virtualenvs/pgadmin4/bin/python3.5
> Also creating executable in /home/markm/.virtualenvs/pgadmin4/bin/python
> Installing setuptools, pkg_resources, pip, wheel...done.
> (pgadmin4) markm {~/download/pgadmin4} markm$ ls
> /home/markm/.virtualenvs/pgadmin4/bin/python-config
> /home/markm/.virtualenvs/pgadmin4/bin/python-config
> (pgadmin4) markm {~/download/pgadmin4} markm$
> /home/markm/.virtualenvs/pgadmin4/bin/python-config
> Usage: /home/markm/.virtualenvs/pgadmin4/bin/python-config
> [--prefix|--exec-prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|--help|--abiflags|--configdir]
> (pgadmin4) markm {~/download/pgadmin4} markm$
> /home/markm/.virtualenvs/pgadmin4/bin/python-config --prefix
> /usr
> (pgadmin4) markm {~/download/pgadmin4} markm$
> /home/markm/.virtualenvs/pgadmin4/bin/python-config --help
> Usage: /home/markm/.virtualenvs/pgadmin4/bin/python-config
> [--prefix|--exec-prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|--help|--abiflags|--configdir]
> (pgadmin4) markm {~/download/pgadmin4} markm$ export
> PYTHON_CONFIG=/home/markm/.virtualenvs/pgadmin4/bin/python-config
> (pgadmin4) markm {~/download/pgadmin4} markm$ ls
> /home/markm/.virtualenvs/pgadmin4/bin/python-config
> /home/markm/.virtualenvs/pgadmin4/bin/python-config
> (pgadmin4) markm {~/download/pgadmin4} markm$ ls
> LICENSE  Make-MinGW.bat  Make.bat  Makefile  README  ci  docs
> libraries.txt  pgadmin4-BUILD  pkg  requirements.txt  runtime  web
> (pgadmin4) markm {~/download/pgadmin4} markm$ workon pgadmin4
> (pgadmin4) markm {~/download/pgadmin4} markm$ pip3 install --upgrade -r
> requirements.txt
> Ignoring importlib: markers 'python_version <= "2.7"' don't match your
> environment
> Ignoring ordereddict: markers 'python_version < "2.7"' don't match your
> environment
> Ignoring backports.csv: markers 'python_version <= "2.7"' don't match
> your environment
> Ignoring Flask-Script: markers 'python_version < "2.7"' don't match your
> environment
> Collecting Babel==2.3.4 (from -r requirements.txt (line 4))
>    Using cached Babel-2.3.4-py2.py3-none-any.whl
> Collecting beautifulsoup4==4.4.1 (from -r requirements.txt (line 5))
>    Using cached beautifulsoup4-4.4.1-py3-none-any.whl
> Collecting blinker==1.3 (from -r requirements.txt (line 6))
> Collecting click==6.6 (from -r requirements.txt (line 7))
>    Using cached click-6.6-py2.py3-none-any.whl
> Collecting extras==0.0.3 (from -r requirements.txt (line 8))
> Collecting fixtures==2.0.0 (from -r requirements.txt (line 9))
>    Using cached fixtures-2.0.0-py2.py3-none-any.whl
> Collecting Flask==0.11.1 (from -r requirements.txt (line 10))
>    Using cached Flask-0.11.1-py2.py3-none-any.whl
> Collecting Flask-Babel==0.11.1 (from -r requirements.txt (line 11))
> Collecting Flask-Gravatar==0.4.2 (from -r requirements.txt (line 12))
>    Using cached Flask_Gravatar-0.4.2-py2.py3-none-any.whl
> Collecting Flask-HTMLmin==1.2 (from -r requirements.txt (line 13))
> Collecting Flask-Login==0.3.2 (from -r requirements.txt (line 14))
> Collecting Flask-Mail==0.9.1 (from -r requirements.txt (line 15))
> Collecting Flask-Migrate==2.0.3 (from -r requirements.txt (line 16))
> Collecting Flask-Principal==0.4.0 (from -r requirements.txt (line 17))
> Collecting Flask-Security==1.7.5 (from -r requirements.txt (line 18))
> Collecting Flask-SQLAlchemy==2.1 (from -r requirements.txt (line 19))
> Collecting Flask-WTF==0.12 (from -r requirements.txt (line 20))
> Collecting html5lib==1.0b3 (from -r requirements.txt (line 21))
> Collecting itsdangerous==0.24 (from -r requirements.txt (line 23))
> Collecting Jinja2==2.7.3 (from -r requirements.txt (line 24))
> Collecting linecache2==1.0.0 (from -r requirements.txt (line 25))
>    Using cached linecache2-1.0.0-py2.py3-none-any.whl
> Collecting MarkupSafe==0.23 (from -r requirements.txt (line 26))
> Collecting passlib==1.6.2 (from -r requirements.txt (line 28))
> Collecting pbr==1.9.1 (from -r requirements.txt (line 29))
>    Using cached pbr-1.9.1-py2.py3-none-any.whl
> Collecting psycopg2>=2.7.3.2 (from -r requirements.txt (line 30))
>    Using cached psycopg2-2.7.3.2-cp35-cp35m-manylinux1_x86_64.whl
> Collecting pycrypto==2.6.1 (from -r requirements.txt (line 31))
> Collecting pyrsistent==0.11.13 (from -r requirements.txt (line 32))
> Collecting python-dateutil==2.5.0 (from -r requirements.txt (line 33))
>    Using cached python_dateutil-2.5.0-py2.py3-none-any.whl
> Collecting python-mimeparse==1.5.1 (from -r requirements.txt (line 34))
> Collecting pytz==2014.10 (from -r requirements.txt (line 35))
>    Using cached pytz-2014.10-py2.py3-none-any.whl
> Collecting simplejson==3.6.5 (from -r requirements.txt (line 36))
> Collecting six>=1.9.0 (from -r requirements.txt (line 37))
>    Using cached six-1.11.0-py2.py3-none-any.whl
> Collecting speaklater==1.3 (from -r requirements.txt (line 38))
> Collecting SQLAlchemy==1.0.14 (from -r requirements.txt (line 39))
> Collecting sqlparse==0.1.19 (from -r requirements.txt (line 40))
> Collecting Werkzeug==0.9.6 (from -r requirements.txt (line 41))
> Collecting WTForms==2.0.2 (from -r requirements.txt (line 42))
>    Using cached WTForms-2.0.2-py2.py3-none-any.whl
> Collecting Flask-Paranoid==0.1.0 (from -r requirements.txt (line 44))
> Collecting testtools>=0.9.22 (from fixtures==2.0.0->-r requirements.txt
> (line 9))
>    Using cached testtools-2.3.0-py2.py3-none-any.whl
> Collecting htmlmin (from Flask-HTMLmin==1.2->-r requirements.txt (line 13))
> Collecting Flask-Script>=0.6 (from Flask-Migrate==2.0.3->-r
> requirements.txt (line 16))
> Collecting alembic>=0.6 (from Flask-Migrate==2.0.3->-r requirements.txt
> (line 16))
> Collecting unittest2>=1.0.0 (from testtools>=0.9.22->fixtures==2.0.0->-r
> requirements.txt (line 9))
>    Using cached unittest2-1.1.0-py2.py3-none-any.whl
> Collecting traceback2 (from testtools>=0.9.22->fixtures==2.0.0->-r
> requirements.txt (line 9))
>    Using cached traceback2-1.4.0-py2.py3-none-any.whl
> Collecting Mako (from alembic>=0.6->Flask-Migrate==2.0.3->-r
> requirements.txt (line 16))
> Collecting python-editor>=0.3 (from
> alembic>=0.6->Flask-Migrate==2.0.3->-r requirements.txt (line 16))
> Collecting argparse (from
> unittest2>=1.0.0->testtools>=0.9.22->fixtures==2.0.0->-r
> requirements.txt (line 9))
>    Using cached argparse-1.4.0-py2.py3-none-any.whl
> Installing collected packages: pytz, Babel, beautifulsoup4, blinker,
> click, extras, six, pbr, argparse, linecache2, traceback2, unittest2,
> python-mimeparse, testtools, fixtures, itsdangerous, Werkzeug,
> MarkupSafe, Jinja2, Flask, Flask-Babel, Flask-Gravatar, htmlmin,
> Flask-HTMLmin, Flask-Login, Flask-Mail, SQLAlchemy, Flask-SQLAlchemy,
> Flask-Script, python-dateutil, Mako, python-editor, alembic,
> Flask-Migrate, Flask-Principal, passlib, WTForms, Flask-WTF,
> Flask-Security, html5lib, psycopg2, pycrypto, pyrsistent, simplejson,
> speaklater, sqlparse, Flask-Paranoid
> Successfully installed Babel-2.3.4 Flask-0.11.1 Flask-Babel-0.11.1
> Flask-Gravatar-0.4.2 Flask-HTMLmin-1.2 Flask-Login-0.3.2
> Flask-Mail-0.9.1 Flask-Migrate-2.0.3 Flask-Paranoid-0.1.0
> Flask-Principal-0.4.0 Flask-SQLAlchemy-2.1 Flask-Script-2.0.6
> Flask-Security-1.7.5 Flask-WTF-0.12 Jinja2-2.7.3 Mako-1.0.7
> MarkupSafe-0.23 SQLAlchemy-1.0.14 WTForms-2.0.2 Werkzeug-0.9.6
> alembic-0.9.6 argparse-1.4.0 beautifulsoup4-4.4.1 blinker-1.3 click-6.6
> extras-0.0.3 fixtures-2.0.0 html5lib-1.0b3 htmlmin-0.1.11
> itsdangerous-0.24 linecache2-1.0.0 passlib-1.6.2 pbr-1.9.1
> psycopg2-2.7.3.2 pycrypto-2.6.1 pyrsistent-0.11.13 python-dateutil-2.5.0
> python-editor-1.0.3 python-mimeparse-1.5.1 pytz-2014.10 simplejson-3.6.5
> six-1.11.0 speaklater-1.3 sqlparse-0.1.19 testtools-2.3.0
> traceback2-1.4.0 unittest2-1.1.0
> (pgadmin4) markm {~/download/pgadmin4} markm$ ls
> LICENSE  Make-MinGW.bat  Make.bat  Makefile  README  ci  docs
> libraries.txt  pgadmin4-BUILD  pkg  requirements.txt  runtime  web
> (pgadmin4) markm {~/download/pgadmin4} markm$ cd runtime/
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ make clean
> make: *** No rule to make target 'clean'.  Stop.
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ qmake
> Info: creating stash file /home/markm/download/pgadmin4/runtime/.qmake.stash
> Project MESSAGE: Building for QT5+...
> Project MESSAGE: Using QWebEngine...
> Project MESSAGE: Building for Linux/Mac...
> Project MESSAGE: Using /home/markm/.virtualenvs/pgadmin4/bin/python-config
> Project MESSAGE: Python3 detected.
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ make
> /usr/lib/x86_64-linux-gnu/qt5/bin/uic BrowserWindow.ui -o ui_BrowserWindow.h
> /usr/lib/x86_64-linux-gnu/qt5/bin/uic ConfigWindow.ui -o ui_ConfigWindow.h
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o pgAdmin4.o
> pgAdmin4.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o BrowserWindow.o
> BrowserWindow.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o Server.o Server.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o TabWindow.o
> TabWindow.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o WebViewWindow.o
> WebViewWindow.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o ConfigWindow.o
> ConfigWindow.cpp
> /usr/lib/x86_64-linux-gnu/qt5/bin/rcc -name pgAdmin4 pgAdmin4.qrc -o
> qrc_pgAdmin4.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o qrc_pgAdmin4.o
> qrc_pgAdmin4.cpp
> /usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE
> -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB
> -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB
> -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64
> -I/home/markm/download/pgadmin4/runtime
> -I/usr/include/x86_64-linux-gnu/qt5
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore
> -I/usr/include/x86_64-linux-gnu/qt5/QtQuick
> -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtGui
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel
> -I/usr/include/x86_64-linux-gnu/qt5/QtQml
> -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork
> -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6
> -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed
> -I/usr/include/x86_64-linux-gnu -I/usr/include BrowserWindow.h -o
> moc_BrowserWindow.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o
> moc_BrowserWindow.o moc_BrowserWindow.cpp
> /usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE
> -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB
> -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB
> -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64
> -I/home/markm/download/pgadmin4/runtime
> -I/usr/include/x86_64-linux-gnu/qt5
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore
> -I/usr/include/x86_64-linux-gnu/qt5/QtQuick
> -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtGui
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel
> -I/usr/include/x86_64-linux-gnu/qt5/QtQml
> -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork
> -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6
> -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed
> -I/usr/include/x86_64-linux-gnu -I/usr/include Server.h -o moc_Server.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o moc_Server.o
> moc_Server.cpp
> /usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE
> -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB
> -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB
> -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64
> -I/home/markm/download/pgadmin4/runtime
> -I/usr/include/x86_64-linux-gnu/qt5
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore
> -I/usr/include/x86_64-linux-gnu/qt5/QtQuick
> -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtGui
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel
> -I/usr/include/x86_64-linux-gnu/qt5/QtQml
> -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork
> -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6
> -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed
> -I/usr/include/x86_64-linux-gnu -I/usr/include TabWindow.h -o
> moc_TabWindow.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o moc_TabWindow.o
> moc_TabWindow.cpp
> /usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE
> -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB
> -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB
> -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64
> -I/home/markm/download/pgadmin4/runtime
> -I/usr/include/x86_64-linux-gnu/qt5
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore
> -I/usr/include/x86_64-linux-gnu/qt5/QtQuick
> -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtGui
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel
> -I/usr/include/x86_64-linux-gnu/qt5/QtQml
> -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork
> -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6
> -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed
> -I/usr/include/x86_64-linux-gnu -I/usr/include WebViewWindow.h -o
> moc_WebViewWindow.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o
> moc_WebViewWindow.o moc_WebViewWindow.cpp
> /usr/lib/x86_64-linux-gnu/qt5/bin/moc -DPGADMIN4_USE_WEBENGINE
> -DQT_NO_DEBUG -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB
> -DQT_QUICK_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB
> -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64
> -I/home/markm/download/pgadmin4/runtime
> -I/usr/include/x86_64-linux-gnu/qt5
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore
> -I/usr/include/x86_64-linux-gnu/qt5/QtQuick
> -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets
> -I/usr/include/x86_64-linux-gnu/qt5/QtGui
> -I/usr/include/x86_64-linux-gnu/qt5/QtWebChannel
> -I/usr/include/x86_64-linux-gnu/qt5/QtQml
> -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork
> -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/6
> -I/usr/include/x86_64-linux-gnu/c++/6 -I/usr/include/c++/6/backward
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include -I/usr/local/include
> -I/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed
> -I/usr/include/x86_64-linux-gnu -I/usr/include ConfigWindow.h -o
> moc_ConfigWindow.cpp
> g++ -c -m64 -pipe -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m
> -I/home/markm/.virtualenvs/pgadmin4/include/python3.5m -O2 -Wall -W
> -D_REENTRANT -fPIC -DPGADMIN4_USE_WEBENGINE -DQT_NO_DEBUG
> -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINECORE_LIB -DQT_QUICK_LIB
> -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_WEBCHANNEL_LIB -DQT_QML_LIB
> -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem
> /usr/include/x86_64-linux-gnu/qt5 -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebEngineCore -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQuick -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtWebChannel -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtQml -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem
> /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I.
> -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o
> moc_ConfigWindow.o moc_ConfigWindow.cpp
> g++ -m64 -lpython3.5m -lpthread -ldl -lutil -lm -Xlinker -export-dynamic
> -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-O1
> -Wl,-rpath-link,/usr/lib/x86_64-linux-gnu -o pgAdmin4 pgAdmin4.o
> BrowserWindow.o Server.o TabWindow.o WebViewWindow.o ConfigWindow.o
> qrc_pgAdmin4.o moc_BrowserWindow.o moc_Server.o moc_TabWindow.o
> moc_WebViewWindow.o moc_ConfigWindow.o -L/usr/X11R6/lib64 -lpython3.5m
> -ldl -lutil -lm -lQt5WebEngineWidgets -lQt5WebEngineCore -lQt5Quick
> -lQt5Widgets -lQt5Gui -lQt5WebChannel -lQt5Qml -lQt5Network -lQt5Core
> -lGL -lpthread
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ ls
> BrowserWindow.cpp  ConfigWindow.h   Server.cpp TabWindow.o        
> close.png              moc_ConfigWindow.o moc_WebViewWindow.cpp  
> pgAdmin4.icns  pgAdmin4.rc ui_BrowserWindow.h
> BrowserWindow.h    ConfigWindow.o   Server.h WebViewWindow.cpp  
> forward.png            moc_Server.cpp moc_WebViewWindow.o    
> pgAdmin4.ico   qrc_pgAdmin4.cpp ui_ConfigWindow.h
> BrowserWindow.o    ConfigWindow.ui  Server.o WebViewWindow.h    
> moc_BrowserWindow.cpp  moc_Server.o pgAdmin4              
> pgAdmin4.o     qrc_pgAdmin4.o
> BrowserWindow.ui   Info.plist       TabWindow.cpp WebViewWindow.o    
> moc_BrowserWindow.o    moc_TabWindow.cpp pgAdmin4.cpp          
> pgAdmin4.pro   qss
> ConfigWindow.cpp   Makefile         TabWindow.h back.png          
> moc_ConfigWindow.cpp   moc_TabWindow.o pgAdmin4.h            
> pgAdmin4.qrc   splash.png
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ ./pgAdmin4
> Python path: "/home/markm/.virtualenvs/pgadmin4/lib/python3.4/site-packages"
> Python Home:  ""
> Webapp path:  "/home/markm/download/pgadmin4/web/pgAdmin4.py"
> Traceback (most recent call last):
>    File "/home/markm/download/pgadmin4/web/pgAdmin4.py", line 34, in
> <module>
>      import config
>    File "/home/markm/download/pgadmin4/web/config.py", line 30, in <module>
>      from pgadmin.utils import env, IS_PY2, IS_WIN, fs_short_path
>    File "/home/markm/download/pgadmin4/web/pgadmin/__init__.py", line
> 17, in <module>
>      from flask import Flask, abort, request, current_app, session, url_for
> ImportError: No module named 'flask'
> ^C^C^C^Z
> [1]+  Stopped                 ./pgAdmin4
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ kill -9 %1
>
> [1]+  Stopped                 ./pgAdmin4
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$
> [1]+  Killed                  ./pgAdmin4
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ kill -9 %1
> -bash: kill: %1: no such job
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$ pip3 install flask
> Requirement already satisfied: flask in
> /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages
> Requirement already satisfied: click>=2.0 in
> /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
> Requirement already satisfied: Werkzeug>=0.7 in
> /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
> Requirement already satisfied: itsdangerous>=0.21 in
> /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
> Requirement already satisfied: Jinja2>=2.4 in
> /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from flask)
> Requirement already satisfied: markupsafe in
> /home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages (from
> Jinja2>=2.4->flask)
> (pgadmin4) markm {~/download/pgadmin4/runtime} markm$
>
>
> On 11/08/2017 12:35 AM, Neel Patel wrote:
>> Hi Mark,
>>
>> Before launching pgAdmin4 application, can you please export
>> PYTHONPATH variable to
>> "/home/markm/.virtualenvs/pgadmin4/bin/python-config", so that
>> application will pick the packages from that path.
>> Below path is reference - You may need to change according to your
>> environment.
>>
>> e.g.
>> export
>> PYTHONPATH="/home/markm/.virtualenvs/pgadmin4/lib/python3.5/site-packages"
>>
>> Thanks,
>> Neel Patel
>>
>> On Tue, Nov 7, 2017 at 9:46 PM, Mark Murawski
>> <[hidden email] <mailto:[hidden email]>> wrote:
>>
>>     Hi Neel,
>>
>>     Yes, this is what I have done already.  I pasted my process in the
>>     previous email.
>>
>>     What I did was make a virtualenv for python 3.5, I installed the
>>     requirements for python 3.5, and then from the same virtualenv, I
>>     built pgadmin4, and then also from the same virtualenv (same shell
>>     session and everything), I started pgadmin4.
>>
>