pgadmin4 - centos7 - "The application server could not be contacted"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pgadmin4 - centos7 - "The application server could not be contacted"

Williams, Alex

Hi,


I recently did some yum updates and just said yes to all the updates. And since then when I open pgadmin4, I get the message "The application server could not be contacted" and pgadmin4 does not open. I searched around, and it looks like this is common on Windows, but I've only seen one mention of this with Centos with no reply.


https://stackoverflow.com/questions/47216293/pgadmin4-shows-the-error-the-application-server-couldnt-be-contacted-on-centos



https://www.postgresql.org/message-id/76391938-5d9f-6c10-50f7-7a248600053f%40mail.ru


I checked the pgadmin.log and there's nothing in there that would provide me any useful any information.


My last entry was for a disconnected connection:

2018-04-10 22:09:50,025: ERROR  pgadmin:
Failed to execute query (execute_async) for the server #1 - CONN:5683531
(Query-id: 949081):
Error Message:ERROR:  server closed the connection unexpectedly
        This probably means the server terminated abnormally
        before or while processing the request.

I renamed the folder, and no changes.


Any help would be greatly appreciated.


Thanks,


Alex

Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 - centos7 - "The application server could not be contacted"

David G Johnston
On Thu, Apr 12, 2018 at 4:30 PM, Williams, Alex <[hidden email]> wrote:

Hi,


I recently did some yum updates and just said yes to all the updates. And since then when I open pgadmin4,

You may find the list dedicated to pgAdmin more appropriate for your inquiry - though if you try to connect and fail with psql then the issue is likely not with pgAdmin and you can keep the discussion here.

Reply | Threaded
Open this post in threaded view
|

Re: pgadmin4 - centos7 - "The application server could not be contacted"

Williams, Alex

Hi David,


Thanks, I've given up on getting pgadmin4 to work. I have no idea where files are being installed with yum and why there are so many issues with getting a newer version installed and why so many conflicts with python packages. I tried multiple times from multiple guides and reverted back with vmware workstation to a snapshot where it did work with v1.6. At this point, I bit the bullet and purchased Navicat for Postgres.


Alex


From: David G. Johnston <[hidden email]>
Sent: Sunday, April 15, 2018 11:19:20 PM
To: Williams, Alex
Cc: [hidden email]
Subject: Re: pgadmin4 - centos7 - "The application server could not be contacted"
 
On Thu, Apr 12, 2018 at 4:30 PM, Williams, Alex <[hidden email]> wrote:

Hi,


I recently did some yum updates and just said yes to all the updates. And since then when I open pgadmin4,

You may find the list dedicated to pgAdmin more appropriate for your inquiry - though if you try to connect and fail with psql then the issue is likely not with pgAdmin and you can keep the discussion here.