pgdg-keyring updated to version 2018.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pgdg-keyring updated to version 2018.1

apt.postgresql.org repository
The package pgdg-keyring was updated on apt.postgresql.org:

New version 2018.1:

pgdg-keyring  |  2018.1             |  sid-pgdg      |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2018.1             |  buster-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2018.1             |  stretch-pgdg  |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2018.1             |  jessie-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  wheezy-pgdg   |  amd64,  i386,  source
pgdg-keyring  |  2014.1             |  squeeze-pgdg  |  amd64,  i386,  source
pgdg-keyring  |  2018.1             |  bionic-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  zesty-pgdg    |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2018.1             |  xenial-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2014.1             |  wily-pgdg     |  amd64,  i386,  source
pgdg-keyring  |  2014.1             |  utopic-pgdg   |  amd64,  i386,  source
pgdg-keyring  |  2018.1             |  trusty-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2014.1             |  saucy-pgdg    |  amd64,  i386,  source
pgdg-keyring  |  2017.1             |  precise-pgdg  |  amd64,  i386,  source
pgdg-keyring  |  2014.1~pgdg10.4+1  |  lucid-pgdg    |  amd64,  i386,  source

Old version 2017.3:

pgdg-keyring  |  2017.3             |  sid-pgdg      |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  buster-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  stretch-pgdg  |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  jessie-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  wheezy-pgdg   |  amd64,  i386,  source
pgdg-keyring  |  2014.1             |  squeeze-pgdg  |  amd64,  i386,  source
pgdg-keyring  |  2017.3             |  bionic-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  zesty-pgdg    |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2017.3             |  xenial-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2014.1             |  wily-pgdg     |  amd64,  i386,  source
pgdg-keyring  |  2014.1             |  utopic-pgdg   |  amd64,  i386,  source
pgdg-keyring  |  2017.3             |  trusty-pgdg   |  amd64,  i386,  ppc64el,  source
pgdg-keyring  |  2014.1             |  saucy-pgdg    |  amd64,  i386,  source
pgdg-keyring  |  2017.1             |  precise-pgdg  |  amd64,  i386,  source
pgdg-keyring  |  2014.1~pgdg10.4+1  |  lucid-pgdg    |  amd64,  i386,  source

apt-listchanges: Changelogs
---------------------------

pgdg-keyring (2018.1) sid-pgdg; urgency=medium

  * postinst: apt-key complains that we don't depend on gnupg, but that is not
    a problem. We only attempt to remove the key from trusted.gpg if apt-key
    list reports it is there. Mute the warning.

 -- Christoph Berg <[hidden email]>  Sat, 15 Sep 2018 17:43:57 +0200

The public mirrors serving apt.postgresql.org are synced hourly,
the updated packages will be available there shortly.


Reply | Threaded
Open this post in threaded view
|

Problem with pgdg-keyring 2018.1 in trusty-pgdg

apt.postgresql.org repository
Re: To PostgreSQL in Debian 2018-10-11 <[hidden email]>
> The package pgdg-keyring was updated on apt.postgresql.org:
>
> New version 2018.1:
>
> pgdg-keyring  |  2018.1             |  trusty-pgdg   |  amd64,  i386,  ppc64el,  source

The 2018.1 package was built on Debian unstable, and copied over to
all supported distributions. In the past this worked fine, but since
the "control" part of the .deb file has been changed to control.tar.xz
compression by default in Debian unstable, the format is no longer
compatible with trusty's original dpkg.

The error was not caught by automated testing because trusty-updates
ships a patched version of dpkg (1.17.5ubuntu5.8) which does support
control.tar.xz compression.

This has been fixed now after user complaints on IRC. The new version
2018.1+b1 has been rebuilt on trusty and uses control.tar.gz
compression. (The "data" part is still compressed as data.tar.xz.)

Christoph

signature.asc (849 bytes) Download Attachment