pgrounting extension in 11

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

pgrounting extension in 11

Prakash Ramakrishnan-2
Hi Team,

Anyone help me to solve the below issue not able to create the pgrouting extension 11 version in rhel 6.9 OS,


[root@hkgrhepdbp001 ~]# yum install pgrouting_11
Loaded plugins: enabled_repos_upload, package_upload, product-id, rhnplugin, search-disabled-repos, security, subscription-manager
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
Setting up Install Process
rhel-6-server-rpms                                                                                                                    | 2.0 kB     00:00
tnc_TNC_Nielsen_tnc_nielsen_rpms                                                                                                      | 2.1 kB     00:00
No package pgrouting_11 available.
Error: Nothing to do
Uploading Enabled Repositories Report
Loaded plugins: product-id, rhnplugin

==> ./psql -p 5434
psql (11.5)
Type "help" for help.


postgres=# create extension pgrouting;
ERROR:  could not open extension control file "/usr/pgsql-11/share/extension/pgrouting.control": No such file or directory
postgres=#
postgres=#


--
Thanks,
Prakash.R

Reply | Threaded
Open this post in threaded view
|

Re: pgrounting extension in 11

Adrian Klaver-4
On 9/10/19 5:59 AM, Prakash Ramakrishnan wrote:
> Hi Team,
>
> Anyone help me to solve the below issue not able to create the pgrouting
> extension 11 version in rhel 6.9 OS,

What repo's are you pulling from RH's or PGDG?

If PGDG then I do not see pgRouting for RH 6.x:

https://yum.postgresql.org/testing/11/redhat/rhel-6-x86_64/repoview/letter_p.group.html

>
>
> [root@hkgrhepdbp001 ~]# yum install pgrouting_11
> Loaded plugins: enabled_repos_upload, package_upload, product-id,
> rhnplugin, search-disabled-repos, security, subscription-manager
> This system is not registered with RHN Classic or RHN Satellite.
> You can use rhn_register to register.
> RHN Satellite or RHN Classic support will be disabled.
> Setting up Install Process
> rhel-6-server-rpms                                                      
>                                                               | 2.0 kB  
>    00:00
> tnc_TNC_Nielsen_tnc_nielsen_rpms                                        
>                                                               | 2.1 kB  
>    00:00
> No package pgrouting_11 available.
> Error: Nothing to do
> Uploading Enabled Repositories Report
> Loaded plugins: product-id, rhnplugin
>
> ==> ./psql -p 5434
> psql (11.5)
> Type "help" for help.
>
>
> postgres=# create extension pgrouting;
> ERROR:  could not open extension control file
> "/usr/pgsql-11/share/extension/pgrouting.control": No such file or directory
> postgres=#
> postgres=#
>
>
> --
> Thanks,
> Prakash.R
>


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: pgrounting extension in 11

Prakash Ramakrishnan-2
Hi Adrian,

I have only these files in pgdg,
[root@hkgrhepdbp001 ~]#  yum list | grep pgrouting
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
pgrouting_93.x86_64                    2.0.0-1.rhel6         @pgdg93
pgrouting_94.x86_64                    2.0.1-2.rhel6         pgdg94
pgrouting_94-debuginfo.x86_64          2.0.1-2.rhel6         pgdg94
pgrouting_95.x86_64                    2.0.1-1.rhel6         pgdg95
pgrouting_95-debuginfo.x86_64          2.0.1-1.rhel6         pgdg95


On Tue, Sep 10, 2019, 19:16 Adrian Klaver <[hidden email]> wrote:
On 9/10/19 5:59 AM, Prakash Ramakrishnan wrote:
> Hi Team,
>
> Anyone help me to solve the below issue not able to create the pgrouting
> extension 11 version in rhel 6.9 OS,

What repo's are you pulling from RH's or PGDG?

If PGDG then I do not see pgRouting for RH 6.x:

https://yum.postgresql.org/testing/11/redhat/rhel-6-x86_64/repoview/letter_p.group.html

>
>
> [root@hkgrhepdbp001 ~]# yum install pgrouting_11
> Loaded plugins: enabled_repos_upload, package_upload, product-id,
> rhnplugin, search-disabled-repos, security, subscription-manager
> This system is not registered with RHN Classic or RHN Satellite.
> You can use rhn_register to register.
> RHN Satellite or RHN Classic support will be disabled.
> Setting up Install Process
> rhel-6-server-rpms                                                       
>                                                               | 2.0 kB   
>    00:00
> tnc_TNC_Nielsen_tnc_nielsen_rpms                                         
>                                                               | 2.1 kB   
>    00:00
> No package pgrouting_11 available.
> Error: Nothing to do
> Uploading Enabled Repositories Report
> Loaded plugins: product-id, rhnplugin
>
> ==> ./psql -p 5434
> psql (11.5)
> Type "help" for help.
>
>
> postgres=# create extension pgrouting;
> ERROR:  could not open extension control file
> "/usr/pgsql-11/share/extension/pgrouting.control": No such file or directory
> postgres=#
> postgres=#
>
>
> --
> Thanks,
> Prakash.R
>


--
Adrian Klaver
[hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: pgrounting extension in 11

Adrian Klaver-4
On 9/10/19 6:53 AM, Prakash Ramakrishnan wrote:
> Hi Adrian,
>
> I have only these files in pgdg,

That is something you will need to take up with the PGDG RH packagers.
You can file an issue here:

https://redmine.postgresql.org/projects/pgrpms/issues?set_filter=1

NOTE: You will a need a Postgres community account to get to above link.

> [root@hkgrhepdbp001 ~]#  yum list | grep pgrouting
> This system is not registered with RHN Classic or RHN Satellite.
> You can use rhn_register to register.
> RHN Satellite or RHN Classic support will be disabled.
> pgrouting_93.x86_64                    2.0.0-1.rhel6         @pgdg93
> pgrouting_94.x86_64                    2.0.1-2.rhel6         pgdg94
> pgrouting_94-debuginfo.x86_64          2.0.1-2.rhel6         pgdg94
> pgrouting_95.x86_64                    2.0.1-1.rhel6         pgdg95
> pgrouting_95-debuginfo.x86_64          2.0.1-1.rhel6         pgdg95
>
>
> On Tue, Sep 10, 2019, 19:16 Adrian Klaver <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     On 9/10/19 5:59 AM, Prakash Ramakrishnan wrote:
>      > Hi Team,
>      >
>      > Anyone help me to solve the below issue not able to create the
>     pgrouting
>      > extension 11 version in rhel 6.9 OS,
>
>     What repo's are you pulling from RH's or PGDG?
>
>     If PGDG then I do not see pgRouting for RH 6.x:
>
>     https://yum.postgresql.org/testing/11/redhat/rhel-6-x86_64/repoview/letter_p.group.html
>
>      >
>      >
>      > [root@hkgrhepdbp001 ~]# yum install pgrouting_11
>      > Loaded plugins: enabled_repos_upload, package_upload, product-id,
>      > rhnplugin, search-disabled-repos, security, subscription-manager
>      > This system is not registered with RHN Classic or RHN Satellite.
>      > You can use rhn_register to register.
>      > RHN Satellite or RHN Classic support will be disabled.
>      > Setting up Install Process
>      > rhel-6-server-rpms
>      >                                                               |
>     2.0 kB
>      >    00:00
>      > tnc_TNC_Nielsen_tnc_nielsen_rpms
>      >                                                               |
>     2.1 kB
>      >    00:00
>      > No package pgrouting_11 available.
>      > Error: Nothing to do
>      > Uploading Enabled Repositories Report
>      > Loaded plugins: product-id, rhnplugin
>      >
>      > ==> ./psql -p 5434
>      > psql (11.5)
>      > Type "help" for help.
>      >
>      >
>      > postgres=# create extension pgrouting;
>      > ERROR:  could not open extension control file
>      > "/usr/pgsql-11/share/extension/pgrouting.control": No such file
>     or directory
>      > postgres=#
>      > postgres=#
>      >
>      >
>      > --
>      > Thanks,
>      > Prakash.R
>      >
>
>
>     --
>     Adrian Klaver
>     [hidden email] <mailto:[hidden email]>
>


--
Adrian Klaver
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: pgrounting extension in 11

Prakash Ramakrishnan-2
Thanks, I'll check it out. 

On Tue, Sep 10, 2019, 19:49 Adrian Klaver <[hidden email]> wrote:
On 9/10/19 6:53 AM, Prakash Ramakrishnan wrote:
> Hi Adrian,
>
> I have only these files in pgdg,

That is something you will need to take up with the PGDG RH packagers.
You can file an issue here:

https://redmine.postgresql.org/projects/pgrpms/issues?set_filter=1

NOTE: You will a need a Postgres community account to get to above link.

> [root@hkgrhepdbp001 ~]#  yum list | grep pgrouting
> This system is not registered with RHN Classic or RHN Satellite.
> You can use rhn_register to register.
> RHN Satellite or RHN Classic support will be disabled.
> pgrouting_93.x86_64                    2.0.0-1.rhel6         @pgdg93
> pgrouting_94.x86_64                    2.0.1-2.rhel6         pgdg94
> pgrouting_94-debuginfo.x86_64          2.0.1-2.rhel6         pgdg94
> pgrouting_95.x86_64                    2.0.1-1.rhel6         pgdg95
> pgrouting_95-debuginfo.x86_64          2.0.1-1.rhel6         pgdg95
>
>
> On Tue, Sep 10, 2019, 19:16 Adrian Klaver <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     On 9/10/19 5:59 AM, Prakash Ramakrishnan wrote:
>      > Hi Team,
>      >
>      > Anyone help me to solve the below issue not able to create the
>     pgrouting
>      > extension 11 version in rhel 6.9 OS,
>
>     What repo's are you pulling from RH's or PGDG?
>
>     If PGDG then I do not see pgRouting for RH 6.x:
>
>     https://yum.postgresql.org/testing/11/redhat/rhel-6-x86_64/repoview/letter_p.group.html
>
>      >
>      >
>      > [root@hkgrhepdbp001 ~]# yum install pgrouting_11
>      > Loaded plugins: enabled_repos_upload, package_upload, product-id,
>      > rhnplugin, search-disabled-repos, security, subscription-manager
>      > This system is not registered with RHN Classic or RHN Satellite.
>      > You can use rhn_register to register.
>      > RHN Satellite or RHN Classic support will be disabled.
>      > Setting up Install Process
>      > rhel-6-server-rpms
>      >                                                               |
>     2.0 kB
>      >    00:00
>      > tnc_TNC_Nielsen_tnc_nielsen_rpms
>      >                                                               |
>     2.1 kB
>      >    00:00
>      > No package pgrouting_11 available.
>      > Error: Nothing to do
>      > Uploading Enabled Repositories Report
>      > Loaded plugins: product-id, rhnplugin
>      >
>      > ==> ./psql -p 5434
>      > psql (11.5)
>      > Type "help" for help.
>      >
>      >
>      > postgres=# create extension pgrouting;
>      > ERROR:  could not open extension control file
>      > "/usr/pgsql-11/share/extension/pgrouting.control": No such file
>     or directory
>      > postgres=#
>      > postgres=#
>      >
>      >
>      > --
>      > Thanks,
>      > Prakash.R
>      >
>
>
>     --
>     Adrian Klaver
>     [hidden email] <mailto:[hidden email]>
>


--
Adrian Klaver
[hidden email]