pgsql: Change libpq's default ssl_min_protocol_version to TLSv1.2.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

pgsql: Change libpq's default ssl_min_protocol_version to TLSv1.2.

Tom Lane-2
Change libpq's default ssl_min_protocol_version to TLSv1.2.

When we initially created this parameter, in commit ff8ca5fad, we left
the default as "allow any protocol version" on grounds of backwards
compatibility.  However, that's inconsistent with the backend's default
since b1abfec82; protocol versions prior to 1.2 are not considered very
secure; and OpenSSL has had TLSv1.2 support since 2012, so the number
of PG servers that need a lesser minimum is probably quite small.

On top of those things, it emerges that some popular distros (including
Debian and RHEL) set MinProtocol=TLSv1.2 in openssl.cnf.  Thus, far
from having "allow any protocol version" behavior in practice, what
we actually have as things stand is a platform-dependent lower limit.

So, change our minds and set the min version to TLSv1.2.  Anybody
wanting to connect with a new libpq to a pre-2012 server can either
set ssl_min_protocol_version=TLSv1 or accept the fallback to non-SSL.

Back-patch to v13 where the aforementioned patches appeared.

Patch by me, reviewed by Daniel Gustafsson

Discussion: https://postgr.es/m/a9408304-4381-a5af-d259-e55d349ae4ce@...

Branch
------
REL_13_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/16412c78403e8ebcb06e34ac1eb74ff8dd299495

Modified Files
--------------
doc/src/sgml/libpq.sgml           | 6 +++---
src/interfaces/libpq/fe-connect.c | 2 +-
2 files changed, 4 insertions(+), 4 deletions(-)