pgsql: Fix cross-version compatibility checks of pg_verify_checksums

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

pgsql: Fix cross-version compatibility checks of pg_verify_checksums

Michael Paquier-2
Fix cross-version compatibility checks of pg_verify_checksums

pg_verify_checksums performs a read of the control file, and the data it
fetches should be from a data folder compatible with the major version
of Postgres the binary has been compiled with, but we never actually
checked that compatibility.

Reported-by: Sergei Kornilov
Author: Michael Paquier
Reviewed-by: Sergei Kornilov
Discussion: https://postgr.es/m/155231347133.16480.11453587097036807558.pgcf@...
Backpatch-through: 11

Branch
------
REL_11_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/501f58359b59af1ffb58f9fbd6f97c4b226c69da

Modified Files
--------------
src/bin/pg_verify_checksums/pg_verify_checksums.c | 7 +++++++
1 file changed, 7 insertions(+)