pgsql: Rename PQtraceSetFlags() to PQsetTraceFlags().

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

pgsql: Rename PQtraceSetFlags() to PQsetTraceFlags().

Noah Misch-2
Rename PQtraceSetFlags() to PQsetTraceFlags().

We have a dozen PQset*() functions.  PQresultSetInstanceData() and this
were the libpq setter functions having a different word order.  Adopt
the majority word order.

Reviewed by Alvaro Herrera and Robert Haas, though this choice of name
was not unanimous.

Discussion: https://postgr.es/m/20210605060555.GA216695@...

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/d0e750c0acaf31f60667b1635311bcef5ab38bbe

Modified Files
--------------
doc/src/sgml/libpq.sgml                          | 6 +++---
src/interfaces/libpq/exports.txt                 | 2 +-
src/interfaces/libpq/fe-trace.c                  | 2 +-
src/interfaces/libpq/libpq-fe.h                  | 2 +-
src/test/modules/libpq_pipeline/libpq_pipeline.c | 2 +-
5 files changed, 7 insertions(+), 7 deletions(-)