pgsql: Rename pg_verify_checksums to pg_checksums

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

pgsql: Rename pg_verify_checksums to pg_checksums

Michael Paquier-2
Rename pg_verify_checksums to pg_checksums

The current tool name is too restrictive and focuses only on verifying
checksums.  As more options to control checksums for an offline cluster
are planned to be added, switch to a more generic name.  Documentation
as well as all past references to the tool are updated.

Author: Michael Paquier
Reviewed-by: Michael Banck, Fabien Coelho, Seigei Kornilov
Discussion: https://postgr.es/m/20181221201616.GD4974@...

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/6dd263cfaa8447470af4fae3f61c47438f91d71f

Modified Files
--------------
doc/src/sgml/ref/allfiles.sgml                     |  2 +-
...{pg_verify_checksums.sgml => pg_checksums.sgml} | 24 +++++++++++-----------
doc/src/sgml/reference.sgml                        |  2 +-
src/backend/replication/basebackup.c               |  2 +-
src/bin/Makefile                                   |  2 +-
src/bin/initdb/t/001_initdb.pl                     |  8 ++++----
src/bin/pg_checksums/.gitignore                    |  3 +++
.../{pg_verify_checksums => pg_checksums}/Makefile | 20 +++++++++---------
src/bin/pg_checksums/nls.mk                        |  4 ++++
.../pg_checksums.c}                                | 20 ++++++++++--------
src/bin/pg_checksums/t/001_basic.pl                |  8 ++++++++
.../t/002_actions.pl                               | 18 ++++++++--------
src/bin/pg_verify_checksums/.gitignore             |  3 ---
src/bin/pg_verify_checksums/nls.mk                 |  4 ----
src/bin/pg_verify_checksums/t/001_basic.pl         |  8 --------
15 files changed, 66 insertions(+), 62 deletions(-)