pgsql: Solve cross-version-upgrade testing problem induced by 1fb57af92

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

pgsql: Solve cross-version-upgrade testing problem induced by 1fb57af92

Tom Lane-2
Solve cross-version-upgrade testing problem induced by 1fb57af92.

Renaming varchar_transform to varchar_support had a side effect
I hadn't foreseen: the core regression tests leave around a
transform object that relies on that function, so the name
change breaks cross-version upgrade tests, because the name
used in the older branches doesn't match.

Since the dependency on varchar_transform was chosen with the
aid of a dartboard anyway (it would surely not work as a
language transform support function), fix by just choosing
a different random builtin function with the right signature.
Also add some comments explaining why this isn't horribly unsafe.

I chose to make the same substitution in a couple of other
copied-and-pasted test cases, for consistency, though those
aren't directly contributing to the testing problem.

Per buildfarm.  Back-patch, else it doesn't fix the problem.

Branch
------
REL_11_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/ee6370978fd921c22ec8bf2239ad4d30ae126fed

Modified Files
--------------
src/bin/pg_dump/t/002_pg_dump.pl                                | 4 ++--
src/test/modules/test_ddl_deparse/expected/create_transform.out | 6 ++++--
src/test/modules/test_ddl_deparse/sql/create_transform.sql      | 6 ++++--
src/test/regress/expected/object_address.out                    | 4 +++-
src/test/regress/sql/object_address.sql                         | 4 +++-
5 files changed, 16 insertions(+), 8 deletions(-)