postgresql10-server RPM unpacking of archive failed

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

postgresql10-server RPM unpacking of archive failed

Christian Mair
Hi,

on a CentOS 7.5 machine with PostgreSQL 10.3 installed from the PGDG yum repo,
I have a strange error when trying to update to 10.6.

A simple "yum update" updated everything except postgresql10-server.x86_64!

That package gives (repeatedly) the error message:

Error unpacking rpm package postgresql10-server-10.6-1PGDG.rhel7.x86_64
error: unpacking of archive failed: cpio: lstat

(full output below)

I'm a bit at loss here... I'd interpret the message towards a corrupted
package (?).

Has anybody seen something like this?

Thanks,
Bye,
Chris.



# yum update
Loaded plugins: fastestmirror
Determining fastest mirrors
epel/x86_64/metalink | 25 kB 00:00:00
  * base: centos.mirror.garr.it
  * epel: epel.mirror.far.fi
  * extras: centos.mirror.garr.it
  * updates: centos.mirror.garr.it
base | 3.6 kB 00:00:00
epel | 3.2 kB 00:00:00
extras | 3.4 kB 00:00:00
pbiso | 2.5 kB 00:00:00
pgdg10 | 4.1 kB 00:00:00
pgdg96 | 4.1 kB 00:00:00
updates | 3.4 kB 00:00:00
(1/12): base/7/x86_64/group_gz | 166 kB 00:00:00
(2/12): extras/7/x86_64/primary_db | 205 kB 00:00:00
(3/12): pbiso/x86_64/primary_db | 5.1 kB 00:00:00
(4/12): epel/x86_64/group_gz | 88 kB 00:00:00
(5/12): pgdg10/7/x86_64/group_gz | 245 B 00:00:00
(6/12): pgdg96/7/x86_64/group_gz | 249 B 00:00:00
(7/12): pgdg96/7/x86_64/primary_db | 203 kB 00:00:00
(8/12): pgdg10/7/x86_64/primary_db | 176 kB 00:00:00
(9/12): epel/x86_64/updateinfo | 932 kB 00:00:02
(10/12): epel/x86_64/primary | 3.6 MB 00:00:03
(11/12): base/7/x86_64/primary_db | 5.9 MB 00:00:03
(12/12): updates/7/x86_64/primary_db | 6.0 MB 00:00:03
epel 12706/12706
Resolving Dependencies
--> Running transaction check
---> Package postgresql10-server.x86_64 0:10.3-1PGDG.rhel7 will be updated
---> Package postgresql10-server.x86_64 0:10.6-1PGDG.rhel7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================================================================
  Package Arch Version Repository Size
===============================================================================================================================================================================================
Updating:
  postgresql10-server x86_64 10.6-1PGDG.rhel7 pgdg10 4.6 M

Transaction Summary
===============================================================================================================================================================================================
Upgrade 1 Package

Total download size: 4.6 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
postgresql10-server-10.6-1PGDG.rhel7.x86_64.rpm | 4.6 MB 00:00:01
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
   Updating : postgresql10-server-10.6-1PGDG.rhel7.x86_64 1/2
Error unpacking rpm package postgresql10-server-10.6-1PGDG.rhel7.x86_64
error: unpacking of archive failed: cpio: lstat
   Verifying : postgresql10-server-10.6-1PGDG.rhel7.x86_64 1/2
postgresql10-server-10.3-1PGDG.rhel7.x86_64 was supposed to be removed but is not!
   Verifying : postgresql10-server-10.3-1PGDG.rhel7.x86_64 2/2

Failed:
   postgresql10-server.x86_64 0:10.3-1PGDG.rhel7 postgresql10-server.x86_64 0:10.6-1PGDG.rhel7

Complete!


Reply | Threaded
Open this post in threaded view
|

Re: postgresql10-server RPM unpacking of archive failed

Martín Marqués
Hi,

El lun., 19 nov. 2018 a las 17:15, Chris Mair (<[hidden email]>) escribió:

>
> Hi,
>
> on a CentOS 7.5 machine with PostgreSQL 10.3 installed from the PGDG yum repo,
> I have a strange error when trying to update to 10.6.
>
> A simple "yum update" updated everything except postgresql10-server.x86_64!
>
> That package gives (repeatedly) the error message:
>
> Error unpacking rpm package postgresql10-server-10.6-1PGDG.rhel7.x86_64
> error: unpacking of archive failed: cpio: lstat

I would try cleaning up all the data (packages and metadata) and trying again:

yum clean all
yum update postgresql10-server

Regards,

--
Martín Marqués
It’s not that I have something to hide,
it’s that I have nothing I want you to see

Reply | Threaded
Open this post in threaded view
|

Re: postgresql10-server RPM unpacking of archive failed

Christian Mair
>> on a CentOS 7.5 machine with PostgreSQL 10.3 installed from the PGDG yum repo,
>> I have a strange error when trying to update to 10.6.
>>
>> A simple "yum update" updated everything except postgresql10-server.x86_64!
>>
>> That package gives (repeatedly) the error message:
>>
>> Error unpacking rpm package postgresql10-server-10.6-1PGDG.rhel7.x86_64
>> error: unpacking of archive failed: cpio: lstat

> I would try cleaning up all the data (packages and metadata) and trying again:
>
> yum clean all
> yum update postgresql10-server
>
> Regards,

Thanks Martín,

a yum clean all did not help.

In the end, some time later (and after a reboot) yum update
succeeded and we never found out why.

I think we can archive this as a one-time glitch with yum.

Bye,
Chris.