psql's meta command \d is broken as of 12 beta2.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

psql's meta command \d is broken as of 12 beta2.

Dmitry Igrishin
Hi,

Sorry if this report is duplicate but there is no column relhasoids in
pg_catalog.pg_class required by the underlying query of the \d meta
command of psql.


Reply | Threaded
Open this post in threaded view
|

Re: psql's meta command \d is broken as of 12 beta2.

Pavel Stehule
Hi


po 5. 8. 2019 v 13:35 odesílatel Dmitry Igrishin <[hidden email]> napsal:
Hi,

Sorry if this report is duplicate but there is no column relhasoids in
pg_catalog.pg_class required by the underlying query of the \d meta
command of psql.

do you use psql from this release?

The psql client should be higher or same like server.

Pavel
Reply | Threaded
Open this post in threaded view
|

Re: psql's meta command \d is broken as of 12 beta2.

Dmitry Igrishin
пн, 5 авг. 2019 г. в 14:42, Pavel Stehule <[hidden email]>:

>
> Hi
>
>
> po 5. 8. 2019 v 13:35 odesílatel Dmitry Igrishin <[hidden email]> napsal:
>>
>> Hi,
>>
>> Sorry if this report is duplicate but there is no column relhasoids in
>> pg_catalog.pg_class required by the underlying query of the \d meta
>> command of psql.
>
>
> do you use psql from this release?
>
> The psql client should be higher or same like server.
>
> Pavel
Oops, I'm wrong. When I looked at describe.c I understood my mistake.
Sorry for noise and thank you!


Reply | Threaded
Open this post in threaded view
|

Re: psql's meta command \d is broken as of 12 beta2.

Pavel Stehule


po 5. 8. 2019 v 13:46 odesílatel Dmitry Igrishin <[hidden email]> napsal:
пн, 5 авг. 2019 г. в 14:42, Pavel Stehule <[hidden email]>:
>
> Hi
>
>
> po 5. 8. 2019 v 13:35 odesílatel Dmitry Igrishin <[hidden email]> napsal:
>>
>> Hi,
>>
>> Sorry if this report is duplicate but there is no column relhasoids in
>> pg_catalog.pg_class required by the underlying query of the \d meta
>> command of psql.
>
>
> do you use psql from this release?
>
> The psql client should be higher or same like server.
>
> Pavel
Oops, I'm wrong. When I looked at describe.c I understood my mistake.
Sorry for noise and thank you!

no problem

Pavel