"Resend email" not working

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

"Resend email" not working

Justin Pryzby
Sometimes emails don't seem to resend, or in any case don't arrive.

I've tried this one numerous times, over a period of ~36hr.
https://www.postgresql.org/message-id/0f9b217d-3d05-fb0e-b228-7f57c3720a58%40postgrespro.ru
It's not in my spambox.

| The message Re: COPY FREEZE and setting PD_ALL_VISIBLE/visibility map bits with messageid [hidden email] has been scheduled for resending to [hidden email].

--
Justin


Reply | Threaded
Open this post in threaded view
|

Re: "Resend email" not working

Tom Lane-2
Justin Pryzby <[hidden email]> writes:
> Sometimes emails don't seem to resend, or in any case don't arrive.
> I've tried this one numerous times, over a period of ~36hr.
> https://www.postgresql.org/message-id/0f9b217d-3d05-fb0e-b228-7f57c3720a58%40postgrespro.ru
> It's not in my spambox.

FWIW, I tried it and it worked for me.  Maybe some digging in MTA logs is
called for.

                        regards, tom lane


Reply | Threaded
Open this post in threaded view
|

Re: "Resend email" not working

Magnus Hagander-2
On Mon, Nov 2, 2020 at 8:56 PM Tom Lane <[hidden email]> wrote:
>
> Justin Pryzby <[hidden email]> writes:
> > Sometimes emails don't seem to resend, or in any case don't arrive.
> > I've tried this one numerous times, over a period of ~36hr.
> > https://www.postgresql.org/message-id/0f9b217d-3d05-fb0e-b228-7f57c3720a58%40postgrespro.ru
> > It's not in my spambox.
>
> FWIW, I tried it and it worked for me.  Maybe some digging in MTA logs is
> called for.


Yeah, for specifically
[hidden email] I see it being
delivered to [hidden email] 6 times today. Each of them end up
looking something like this:

2020-11-02 19:56:56 1kZfwm-0002bD-E7 <= [hidden email]
H=localhost [127.0.0.1] P=esmtp S=27302
id=[hidden email]
2020-11-02 19:56:57 1kZfwm-0002bD-E7 => [hidden email]
R=dnslookup T=remote_smtp H=aspmx.l.google.com
[2607:f8b0:4003:c01::1a] X=TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256
CV=yes K C="250 2.0.0 OK x19si10331061oto.263 - gsmtp"


So they have all arrived at google.

Google does, I believe, de-duplication of emails so if they think it
has already arrived, they don't deliver a second copy of it. But in
that case, you should be able to see the first copy...

--
 Magnus Hagander
 Me: https://www.hagander.net/
 Work: https://www.redpill-linpro.com/


Reply | Threaded
Open this post in threaded view
|

Re: "Resend email" not working

Justin Pryzby
On Mon, Nov 02, 2020 at 09:03:44PM +0100, Magnus Hagander wrote:
> On Mon, Nov 2, 2020 at 8:56 PM Tom Lane <[hidden email]> wrote:
> > Justin Pryzby <[hidden email]> writes:
> > > Sometimes emails don't seem to resend, or in any case don't arrive.
> > > I've tried this one numerous times, over a period of ~36hr.
> > > https://www.postgresql.org/message-id/0f9b217d-3d05-fb0e-b228-7f57c3720a58%40postgrespro.ru
> > > It's not in my spambox.
> >
> > FWIW, I tried it and it worked for me.  Maybe some digging in MTA logs is
> > called for.
...
> Google does, I believe, de-duplication of emails so if they think it
> has already arrived, they don't deliver a second copy of it. But in
> that case, you should be able to see the first copy...

Sigh, this is clearly what happened, since I was included on the original mail.
Thanks for the lesson.

--
Justin