restart_lsn is not advancing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

restart_lsn is not advancing

Radoslav Nedyalkov
Hello All,
we are in a situation where restart_lsn for logical replication slots is not advancing.
We have two slots. Both  are active, confirmed_flush_lsn also is updated. 
Client side all looks okay. remote_lsn for subscritions is advancing.

The effect of restart_lsn being 'stopped' is the disk is filling up.

Any idea what could be the cause?
We will try to re-establish replication by dropping current slots , although we have to do it very carefully. We should avoid initial loading (these are 4T of data)

Thanks and regards,
Rado
Reply | Threaded
Open this post in threaded view
|

Re: restart_lsn is not advancing

Radoslav Nedyalkov
one more detail:  pg_replication_slots.catalog_xmin shows the biggest age in the system. 
How could  transaction on catalogues may affect logical slot. Any clue  here ?
Thank you,
Rado

On Wed, Jul 1, 2020 at 2:09 AM Radoslav Nedyalkov <[hidden email]> wrote:
Hello All,
we are in a situation where restart_lsn for logical replication slots is not advancing.
We have two slots. Both  are active, confirmed_flush_lsn also is updated. 
Client side all looks okay. remote_lsn for subscritions is advancing.

The effect of restart_lsn being 'stopped' is the disk is filling up.

Any idea what could be the cause?
We will try to re-establish replication by dropping current slots , although we have to do it very carefully. We should avoid initial loading (these are 4T of data)

Thanks and regards,
Rado